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# $ + K Introduction 
 
General 

ODV is a computer program for the interactive exploration and graphical display of oceanographic 
profile data (bottle, CTD, XBT, etc.). The software runs on PCs under Windows (9x/2000/NT) and on 
UNIX workstations under SUN Solaris. ODV lets you interactively browse through large sets of station 
data. It lets you produce high-quality station-maps, general property-property plots of one or more 
stations, scatter plots of selected stations, property sections along arbitrary cruise tracks and property 
distributions on general iso-surfaces. ODV supports display of original data by colored dots or actual 
data values. In addition, two fast gridding algorithms allow color shading and contouring of gridded 
fields along sections and on iso-surfaces (any plot with a Z-variable can be gridded, color-shaded 
and/or contoured). A large number of derived quantities can be calculated online. These variables can 
be displayed and analyzed in the same way as the basic variables stored on disk. 
 
Ease of use 

ODV is designed to be flexible and easy-to-use. Users are not required to know the details of the in-
ternal data storage format nor are they required to have programming experience. ODV always dis-
plays a map of available stations on the screen and facilitates navigating through the data by letting 
the user select stations, sections and iso-surfaces with the mouse. The screen layout and various 
other configuration features can be modified easily, and favorite settings can be stored in configuration 
files on disk for later use. ODV can create and manage very large data collections. It is therefore pos-
sible to store the available global historical hydrographic data together with newly arriving data on 
relatively inexpensive and widely available hardware and have these data ready for scientific analysis 
in the field or back home in the laboratory. In addition to actual research applications, ODV can be 
useful for data quality evaluation and for teaching and training. 
 
Dense data format 

The ODV data format provides dense storage and allows instant access to any station, even in large 
data collections. The data format is flexible: you can store data for up to 50 variables, where type and 
number of the variables may vary from one collection to another. As an example, ODV requires only 
1MB of disk space for 1600 bottle stations containing data for 7 variables.  
 
ODV maintains quality flags associated with every individual data value. These quality flags can be 
used by ODV as a data quality filter to exclude bad or questionable values from the analysis.  
 
Extensibility 

ODV allows easy import of new data into collections and also allows easy export of some or all data 
from a collection. Hydrographic data in the following widely used formats can directly be incorporated 
into the ODV system: 
 
• WOCE WHP format (distributed via Internet by the WHPO at SCRIPPS),  
• World Ocean Atlas 1994 (WOA94; distributed on CD-ROM by NODC),  
• World Ocean Database 1998 (WOD98; distributed on CD-ROM by NODC),  
• NODC SD2 format 
• Power Ocean Atlas spreadsheet format, 
• ODV spreadsheet format.  
 
Derived variables  

In addition to the basic oceanographic variables stored in the data files, ODV can calculate and dis-
play a large number of derived variables. These derived variables are either coded in the ODV soft-
ware (potential temperature, potential density, dynamic height (all referenced to arbitrary levels), neu-
tral density, Brunt-Väisälä Frequency, sound speed, oxygen saturation, etc.) or are defined in user 
provided macro files. The macro language is easy and general enough to allow a large number of 
applications. Use of macro files for new derived quantities broadens the scope of ODV considerably 
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and allows easy experimentation with new quantities not yet established in the scientific community. A 
separate macro editor that can be invoked from ODV facilitates Creation and modification of ODV 
macros. Any basic or derived variable can be displayed in ODV plots, and they all can be used to de-
fine iso-surfaces (e.g., depth horizons, isopycnals, isothermals or isohalines; property minimum or 
maximum layers like, for instance, the intermediate water salinity minimum layer can be defined as 
iso-surfaces by use of the zero-crossing of the vertical derivative (a derived quantity) of these vari-
ables).  
 
Plot types 

ODV displays color property sections and color distributions on iso-surfaces in two ways, either by 
showing the original data at the data locations (colored dots of user-defined size or numeric values: 
method 1) or by projecting the original data on a (variable resolution) rectangular grid and then dis-
playing the gridded fields (method 2). Whereas method 1 produces ”honest” distributions of the data, 
instantly revealing regions of poor sampling and highlighting occasional bad data values, method 2 is 
nicer to look at and avoids the overlapping that occurs in (1) especially if large dot-sizes are used. It is 
important to note, however, that gridded fields are data-products and that some small-scale features in 
the data might be lost due to the gridding procedure. In both display-modes, ODV allows the export of 
section or surface data to ASCII files or the clipboard for use by dedicated gridding, shading and con-
touring software.  
 
Graphics output 

Color or black and white paper hard copies of the ODV graphics screen (or individual data plots; Post-
Script, GIF, and EMF only) can be easily obtained via the Print command or by producing PostScript 
files (.eps). eps files can be printed on any PostScript printer and they can be included in page de-
scription documents. ODV can also write the contents of its graphics screen to GIF and EMF files suit-
able for inclusion in text documents or post-processing with standard graphics software. 
 

NetCDF Support 

ODV has built-in support for netCDF files, widely used by researchers in different fields of geo-
sciences. Using few user specifications and selections, ODV accesses and interprets a given netCDF 
file in a way that mimics (emulates) a native ODV collection. The full suite of ODV’s analysis and visu-
alization capabilities is provided for the exploration of the data in the netCDF file, and there is no need 
to translate and re-write the data first. Depending on the structure and contents of a netCDF file, dif-
ferent ODV “emulations” are possible. Settings of individual emulations can be saved on disk for later 
use. Note that netCDF files are platform independent, and the same file can be used with ODV on 
Windows or Solaris platforms. 
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# $ + K ODV Modes 

 

ODV can operate in five different modes "MAP", "STATION", "SCATTER", "SECTION", and 
"SURFACE". You can easily switch between these modes at any time by pressing keys F8 through 
F12 or by selecting appropriate options from the background popup menu (see below). The current 
mode and the active configuration file are always indicated in the right-most pane of the ODV status 
bar. STATION mode is the default mode (initial mode for new data collections).  

MAP mode is intended for full-page station maps and does not provide any data plots. Use this mode 
to produce high quality cruise maps (define size and position of the map window, choose among five 
possible map projections, define appropriate coastline and topography settings, mark individual sta-
tions with station numbers and cruise labels, produce printouts or GIF, EMF, and EPS PostScript 
files). 

STATION mode (like all following modes) provides a station map and one or more (max. 20) data plot 
windows. Use this mode to produce X/Y (any basic or derived variable) plots for selected stations. You 
can select stations using different methods (simplest method: click on it with the left mouse button) 
and you add the data of the selected station to the plots by pressing p (double clicking on a station 
selects and plots). Clear the screen and start over by pressing Ctrl-X (this works for all modes). 

In SCATTER mode (like for all following modes), data plots support Z variables (any basic or derived 
variable). The value of a Z variable at a given X/Y point determines the color at X/Y. Plots with Z-
variables (for SECTION and SURFACE modes as well) can be displayed in two ways: (1) by placing 
colored dots or the actual data value at the X/Y locations (default) or (2) as continuous gridded fields 
estimated on the basis of the observed data. Gridded fields can be color-shaded and/or contoured. 
Unlike in SECTION and SURFACE modes, data plots in SCATTER mode (with or without Z variable) 
contain all data points of all stations shown in the map (valid stations).  

SECTION mode also supports Z variables on data plots and allows all plot types of the SCATTER 
mode, but the set of stations used for the plots is restricted to a section band usually following given 
cruise tracks. Section bands can be defined arbitrarily and their width can be adjusted in order to se-
lect the right set of stations. Use this mode to display property distributions along sections, prop-
erty/property plots for all stations within a section and to calculate and investigate geostrophic veloci-
ties perpendicular to the cross-section. 

SURFACE mode lets you define surfaces in 3D (Longitude/Latitude/Depth) space (defined as points of 
constant values of a given variable, e.g., depth, density, temperature, etc.) and lets you display prop-
erty distributions of other variables on this surface. In SURFACE mode you can also produce arbitrary 
property/property plots for the given surface. 
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# $ + K Screen Layout and Function Summary 
 
The ODV application window consists of (from top to bottom):  

(1) main menu... 

providing basic functionality: 

File: open or create a collection; open netCDF file, print the current ODV graphics screen (see (3)); 
produce PostScript, GIF or EMF files of current ODV graphics screen; exit ODV. 

Collection: open or create a collection, open netCDF file, copy, rename, delete collection; sort and 
condense data collection; change collection variables set, delete current station or selected 
station subset. 

Configuration: change station selection criteria; define derived variables; define iso-surface vari-
ables; change map and data plots layout; change variable labels, numeric format and position 
of data in line 3 of ODV text window (see (2)); load and save configuration settings or set de-
faults. 

Import: import data into current collection (WOCE format, WOA94 CD, WOD98 CD, NODC SD2 
format, ODV spreadsheet format, two ODV list formats). 

Export: export data of currently selected stations; export plot values to ASCII files. 
Utilities: produce data inventory table and plot of temporal data distribution; retrieve box average 

values; calculate and visualize geostrophic velocity sections; define current data as reference. 
Help: invoke ODV help system; show version. 
 

(2) a 3-line text window... 

containing information on current station and current sample. Clicking the right mouse button while 
over the text window lets you edit the data and change labels of the variables as well as numeric for-
mat and the order in which they are listed in lines 2 and 3. Moving the mouse over a specific variable 
in the text window gives you more detailed information on this variable in a popup window. You get an 
overview of current station and sample selection criteria if you move the mouse over the area delim-
ited by [ and ] at the beginning of line 1.  
 
If  the ODV window is too small to display all variables in lines 2 and 3 of the text window, a ”>” sign 
appears at the end of line 3. Clicking with the left mouse button on the ”>” sign scrolls the text window 
to its end, clicking on the ”<” sign at the beginning of line 3 brings you back to the start. Placing the 
mouse over lines 2 or 3 and dragging (press and hold down the left mouse button and move the 
mouse) lets you scroll the text window to any position. 
 
(3) the graphics canvas... 

containing the ODV station map and one or more data plots. If only the map is shown, you obtain the 
data plots by double-clicking on individual stations (STATION mode) or anywhere in the map(all other 
modes). Clicking the right mouse button while over the map, the data plots or the background area 
invokes different popup menus: 
 

Background popup menu: clear the screen and restore the station map; print the current ODV 
graphics screen; produce PostScript, GIF or EMF file of current ODV graphics screen; define 
derived variables; define iso-surface variables; change map and data plots layout; change 
variable labels, numeric format and position of data in line 3 of ODV text window; switch be-
tween ODV’s MAP, STATION, SCATTER, SECTION and SURFACE modes; exit ODV. 

 
Map popup menu: zoom into map; open map to full domain of collection (defined by Define Full 

Domain); produce standard, global map; change station selection criteria; define section 
(SECTION mode only); select a new current station by name or internal number; change map 
display options (map projection, topography and coastline files, station annotation style); de-
fine the domain of the current collection. 
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Data plot popup menu: zoom into current window and set X- and Y value ranges; zoom into color-
bar of current window and set Z value range; auto-scale X-, Y- and Z- ranges of current/all 
windows to accommodate all data values; change the color-mapping for current window; 
change display options of current window; select new X-, Y- and Z-variables. 

 
 
(4) a status-line... 

displaying help, status or progress information. Note that the right-most pane of the status bar indi-
cates the current mode and active configuration file. 

 
(5) popup windows... 

displaying additional information. Popup windows appear automatically when the mouse rests over 
specific regions (activation areas) of the ODV screen, they disappear when you move the mouse away 
from the activation areas. See the following table for an overview of ODV popup windows. 

Popup Window Activation Area Content 

Collection variables Collection name in title bar List of collection variables and data availability [%] for currently 
valid stations (those shown in the map, Val), current cruise 
(Cru) and current station (Sta) 

Selection criteria [ ] field at beginning of first text 
line 

List of current station/sample selection criteria 

Cruise information Cruise field following : in first text 
line 

Summary information about current cruise 

Station information Station field following cruise in 
first text line 

Data availability for current station 

Data summary First item (# or “surf”) in 2nd and 
3rd text line 

Data values of current sample for all variables (data quality is 
color coded). 

Data information Any variable in 2nd and 3rd text 
line 

Full variable label, data value and data quality flag 

Configuration Right-most pane in status bar Full file names of current configuration and current section (if 
applicable) 

 

For a maximized ODV window (default state at startup; press the maximize button in the upper right 
corner to maximize) the ODV graphics window represents a full hardcopy page as obtained with the 
Print commands from the main or background menus or when writing PostScript files (choose Save As 
from the background popup menu). You can arbitrarily resize the ODV application window by pressing 
the resize button in the upper right corner or by dragging the window boundaries. For such smaller 
ODV graphics windows use the scrollbars to select the viewable area or place the mouse over the 
background area of the graphics canvas and drag (press and hold down the left mouse button and 
move the mouse). 

ODV always points to a current station, which is marked in the map by a red circle and for which gen-
eral information is listed in the first line of the text window. Among other possibilities, you can select a 
new current station by clicking on its location in the map with the left mouse button. One of the sam-
ples of the current station is the current sample. The data of the current sample are shown in lines 2 
and 3 of the text window, and the current sample is marked in the data plots (if present)  by a red 
cross. Among other possibilities, a new current sample (and current station) can be selected by click-
ing with the left mouse on a data point in any of the data plots. 

In order to plot the current station, all stations scatter plots, color sections or iso-surface distributions 
(in STATION, SCATTER, SECTION, or SURFACE modes, respectively) double-click on the respective 
station or any point inside the map area, or press p. In STATION mode you can add other stations to 
the plots by simply double-clicking on other stations. Note that in SECTION mode you have to define a 
section first for data plots to appear. 
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# $ + K Installing Optional Packages 
 
To install optional packages like high-resolution coastline and topography files or ready-to-use data 
collections download the respective package file from  

http://www.awi-bremerhaven.de/GEO/ODV/ODVwin32/OptPack/ (Windows) 

or  

http://www.awi-bremerhaven.de/GEO/ODV/ODVsolaris/OptPack (SUN Solaris) 

and follow the instructions in “readmeOptPackWIN32.txt” or “readme_ODV_OptPack”, respectively. 
These files also provide an overview over available optional packages for ODV. 
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# $ + K Uninstalling ODV 
 
WIN32: 

To uninstall ODV from your Windows system invoke the Control Panel (Systemsteuerung) by selecting 
Settings->Control Panel (Einstellungen->Systemsteuerung) from the Windows Start menu. Double-
click on Add/Remove Programs (Software), select Ocean Data View and press the Remove 
(Hinzufuegen/Entfernen) button. Note that this process only removes files and registry entries installed 
during the ODV setup. Optional packages or private data collections added later are not uninstalled 
automatically and must be removed manually. 

UNIX: 

To uninstall ODV from a UNIX system, stop any running instance of ODV and execute the following 
commands: 

(1) pwd < ‘echo $ODVHOME‘  

(2) rm –r * 

                                                           
# IDH_UNINSTALL 
$ Uninstalling ODV 
+ auto 
K uninstalling ODV 



 10

# $ + K Creating Collections 
 
If you have data in one of ODV’s import formats, you can create an ODV data collection and import 
the data into the collection by simply dragging the data file on the ODV desktop icon. In this case the 
list of collection variables is automatically determined by the contents of the data file. 

To create a new custom collection choose New from the File menu, select an existing folder or create 
a new one using the standard Windows file dialog box and enter the name of the collection to be cre-
ated. Note that valid ODV collection names may not contain spaces or any of the following characters: 
\ / :. Press Open to accept the settings. You then have to specify number and type of variables to be 
stored in the new collection. You can either use an existing ODV4.x or ODV3.0 collection as a tem-
plate, you can create default WOCE or NODC collections or you can specify the variables manually, if 
you want to create a new type of collection. Make your selection, and then press OK. (If you are using 
a template, you now have to select the template collection .var file). 

In case of manual entry, ODV allows you to specify up to 50 variable names. Enter the variable label 
into the New Variable field and press Add to add it to the list of collection variables. You can delete a 
variable or modify its label by pressing Delete or Edit. You are strongly advised to include unit’s speci-
fications for the new variable enclosed in [...] in the variable label. In order to create subscripts, super-
scripts, and special symbols, the variable labels may contain the following control sequences: 

~$ switch to Symbol font (Greek symbols) 
~# switch to normal text font 
~~ produce ˜ character 
~s produce ß character 
~" next character as Umlaut' 
~^ next character as superscript 
~_ next character as subscript. 

 
When you are done entering variable labels press OK to accept the current settings.  

Please note that for oceanographic data collections the first three variables are predefined as depth, 
temperature and salinity. Also note that, unlike in the WOCE data files, ODV uses depth as the pri-
mary ordering variable. WOCE pressure data are automatically converted into depths when imported. 
Pressure can be defined in ODV as a derived variable. 

After specifying the collection variables, either using a template or by manual entry, ODV creates the 
collection and produces a global map. Use functions from the Import menu to import data into the 
newly created collection.  
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# $ + K Collection Files Summary 
 

Here is a summary of the files comprising an ODV collection together with a description of their role 
and purpose. Although usually it is not necessary for a user to know about the collection file structure, 
this information may be useful in case of problems or unexpected behavior. 

 

File name=collection name 

(the following files must all be located in the same directory [collection directory]) 

Extension Format Comment 
Basic files  Must be present. Must not be changed manually. 
var ASCII Defines collection variables and stores collection name and number of sta-

tions. This file is associated with the ODV executable, e.g. double-clicking 
on the var file starts ODV with the respective collection.  

hob Binary Stores the station meta-data (name, position, date, etc.). 
dob Binary Stores the actual station data and quality flags. 
   
Auxiliary Files  If not present, ODV uses defaults and creates the files. 
inv ASCII Collection inventory listing by cruises. 
log ASCII Collection log file; keeps records of data changes. 
idv ASCII Lists IDs of key variables used as input for derived variables (depth, tem-

perature, oxygen, etc.) 
cfl c Contains name of last configuration file. 
   
Info File  Optional. ODV creates an info file when opening netCDF datasets. 
info ASCII Description of the collection or netCDF dataset (freeform text). 
 
 
 

File name=arbitrary 

(the following files may be located in any directory) 

Extension Format Comment 
cfg binary Configuration files storing layout, value ranges, derived and iso-surface 

variable selections, and many other settings. The name of the collection 
that owns a configuration is recorded inside the cfg file. Certain restrictions 
apply, if a different collection uses the cfg file. 

sec ASCII Stores section outlines and characteristics. 
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# $ + K Translating pre-ODV4.0 Collections 
 
If you are upgrading from previous MS-DOS based ODV versions (3.0 and earlier), you have to trans-
late your old collections to the new format before you can use them with ODV4.0. To translate a col-
lection, first use ODM (contained in the ODV3.0 release) with the collection to be translated. Export 
the collection data to an ASCII file using the ‘l’ option of ODM (select ODM Format as output format 
and use “o3x” as extension when prompted for a file name). Then use ODV4.0 to create a new collec-
tion to receive the data and use the ODV3.0 source collection .var file as a template for the new one 
when prompted for collection variables.  

After the new collection has been created and ODV4.0 has produced the station map, choose ODV3.0 
Listing from the Import menu. Select the ASCII data file created above as data import file and identify 
the (old) ODV3.0 collection .var file as the data source. You then have to associate the source vari-
ables with the target variables. If you have followed the steps above, target and source variables are 
identical (they have the same labels), and the association is made automatically (indicated by aster-
isks in front of the variable labels). Press the OK button to accept the associations. ODV will then read 
the import file and add the stations to the collection. Note that the data quality flags are set to Un-
known if you import data from ODV3.0 collections. 
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# $ + K Migrating between Windows and UNIX 
 
If you migrate from ODV on Windows to ODV on UNIX or vice-versa please note that you cannot use 
collection and configuration files from one platform on the other because of binary incompatibilities. 
Instead, you have to exchange data and configuration information in ASCII files.  

Data Collections: 

To exchange an ODV collection do the following: 

(1) Open the collection on the source platform, choose “Global Map” and open the selection crite-
ria so that all stations of the collection are valid.  

(2) Choose Export->ODV SpreadSheet, keep the default selection of variables and choose an 
appropriate output file name. 

(3) Transfer the spreadsheet file to the target platform, create a new collection using the spread-
sheet file as template and import the spreadsheet file using Import->ODV SpreadSheet. Then 
delete the spreadsheet file. 

 

Configuration Files: 

To exchange all configuration files from a given directory, start ODV on the source platform. Choose 
Configuration-> Exchange Configurations-> Pack select the directory to be exchanged and choose 
one of the .cfg files. ODV will pack all .cfg files into file cfg_pack.cfp located in the same directory. 
Move this file (using ASCII transfer) to the target platform, start ODV, choose Configuration-> Ex-
change Configurations-> Unpack and select the cfg_pack.cfp file just exchanged. After unpacking, the 
cfg_pack.cfp files on source and target platforms can be deleted. 
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# $ + K Importing Data from Spreadsheet Files 
 
ODV can read a large variety of spreadsheet-type ASCII files. The data from these spreadsheet files 
can be imported into existing data collections or can be used to create new ones. Among the sup-
ported file types are those with or without station metadata information, with or without column label 
information, files using different column separation characters as well as different missing value 
strings. A detailed list of specifications for the general ODV spreadsheet format is given in the table 
below.  

Note that ODV spreadsheet files may contain data of many stations from many cruises. All observed 
levels of a given station must be in consecutive order but need not necessarily be sorted by depth or pressure. 
During import, ODV assumes a new station whenever either one of the following entries changes:  "Cruise", "Sta-
tion", "Type", "mon/day/yr", "hh:mm", "Lon (°E)" or "Lat (°N)" (see below). 

The procedure for importing general ODV spreadsheet files is described in the following. Note that for 
the more restricted generic ODV spreadsheet format described below, the import procedure is usually 
much simpler and requires almost no user interaction. 

To import data from a general ODV spreadsheet file into the currently open collection choose Import-
>SpreadSheet and use the standard Windows file-select dialog to identify the data file that you want to 
import. If the file format deviates from the generic ODV spreadsheet format (see below), a “Spread-
sheet File Properties” dialog box appears that lets you set the column separation character and the 
missing data value (fields that contain this value or are empty are considered missing). You can also 
identify the line that contains the column labels (leave empty if not present) and the first data line. ODV 
provides reasonable defaults for all items and only few changes are necessary in most cases. For the 
Column Sep. Character choose the character that will give a vertical list of labels in the Column Labels 
box. Press OK when all spreadsheet file properties are set or Cancel to abort the import. 

If the labels for the metadata columns deviate from the specifications of the generic ODV spreadsheet 
format (see below), a “Header Variable Association” dialog box appears that lets you associate input 
columns with the collection metadata variables or it lets you set defaults for those variables not pro-
vided in the input file. Already associated variables are marked by asterisks (*). To define a new asso-
ciation select items in the “Source File” and “Target Collection” lists and press Associate. To invoke a 
conversion during import press Convert and choose one of the available conversion algorithms.To 
release an existing association, select the respective variables and press Undo. If the import file does 
not contain information for one or more collection header variables you can specify defaults: (1) select 
the respective target variable; (2) press Set Default and (3) enter the default value. Note that the 
specified default settings are used for all data lines in the file. Press OK when done or Cancel to abort 
the import procedure. Finally specify import options and press OK to start the data import.  

Note that files that deviate from the generic ODV spreadsheet format (see below) should not be 
dragged and dropped onto the ODV desktop icon or an open ODV window. 

 

General ODV Spreadsheet Format: 

General ASCII coding 

File extension any 

Columns 

Station metadata information and data values for up to 50 variables are stored 
in separate columns. Some or all metadata columns may be missing. Metadata 
and data columns can be in arbitrary order. The line containing the column 
labels (if present, see below) and all data lines in the file must have the same 
number of columns. 

Column separation character 

TAB or ; or SPACE or / 

IMPORTANT: Note that cruise and station labels must not contain the column 
separation character; e.g., using SPACE or / as column separation character 
will break the label “CFC [um/kg]” into two tokens. 

Column labels line 1. May be missing; if provided must appear before any data line. 

                                                           
# IDH_IMPDAT_SPREADSHT 
$ Importing Data from SpreadSheet Files 
+ auto 
K SpreadSheet format; importing SpreadSheet data  
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2. Labels for metadata and data columns are arbitrary. Recommended header 
labels are: "Cruise", "Station", "Type", "mon/day/yr", "hh:mm", "Lon (°E)", 
"Lat (°N)", "Bot. Depth [m]". 

3. Labels for data variables can be up to 60 characters long and should include 
unit specifications enclosed in brackets [ ]. 

4. Each column for a data variable can have an optional quality-flag column 
immediately following the variable to which it belongs. The label of a quality-
flag column must be either QF or QF:* where * represents an arbitrary char-
acter sequence. 

Data lines  

1. May start at any line of the file. All lines following the first data line are as-
sumed to be data lines as well (no comments at the end of the file!). 

2. Each line contains metadata and data for one observed level. All observed 
levels of a given station must be in consecutive order but need not be 
sorted. An ODV Spreadsheet file can store the data of many stations from 
many cruises. 

3. Station “Type” is a single character string (use B for stations with less than 
about 250 levels (e.g., bottle data) and C for stations with more than about 
250 levels (e.g., CTD, XBT, etc.). Specifying * for “Type” lets ODV make the 
choice. 

4. If “Bot. Depth” is not available, use “0” (zero) in this field. 

5. The station header information (if header columns are included) must be 
present on all lines. 

Quality flag columns 

1. If data quality information is available for a given variable, this information is 
stored in the column immediately following to the right of the variable to 
which it belongs.  

2. Quality flags are single digit integers: 0=good, 1=unknown, 4=questionable, 
8=bad. 

Missing data value  blank field or any numerical value beyond the range of good data. 

 

 

In addition to the general ODV spreadsheet format described above, a more restricted variant called 
generic ODV spreadsheet format is available that can be imported without user interaction and can be 
dragged and dropped onto the ODV desktop icon or an open ODV window. If at all possible try to 
comply with the generic ODV spreadsheet format. A detailed list of specifications for the generic ODV 
spreadsheet format is given in the table below. 

 

Generic ODV Spreadsheet Format: 

General ASCII coding 

File extension .txt 

Columns 
Station header information (metadata) and data values for up to 50 variables 
are stored in separate columns. Header and data columns can be in arbitrary 
order. All lines in the file must have the same number of columns. 

Column separation character TAB or ; 

First line: Column Labels 

1. Contains column labels. 

2. Standard header labels are: "Cruise", "Station", "Type", "mon/day/yr", 
"hh:mm", "Lon (°E)", "Lat (°N)", "Bot. Depth [m]".  

3. Labels for data variables can be up to 60 characters long and should include 
unit specifications enclosed in brackets [ ]. 

4. Each column for a data variable can have an optional quality-flag column 
immediately following the variable to which it belongs. The label of a quality-
flag column must be either QF or QF:* where * can be an arbitrary character 
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sequence. 

2nd until last line: Data Lines 

1. Each line contains metadata and data for one observed level. All observed 
levels of a given station must be in consecutive order but need not be 
sorted. An ODV Spreadsheet file can store the data of many stations from 
many cruises. 

2. Cruise and station labels are limited to a maximum of 20 characters. The 
use of numbers for the station label will enable enhanced internal sorting 
and selection functionality and is recommended. 

3. Station “Type” is a single character string. You should use B for stations with 
less than about 250 levels (e.g., bottle data) and C for stations with more 
than about 250 levels (e.g., CTD, XBT, etc.). Specifying * for “Type” lets 
ODV make the choice. 

4. If “Bot. Depth” is not available, use “0” (zero) in this field. 

5. The station header information must be present on all lines. 

Quality flag columns 

1. If data quality information is available for a given variable, this information is 
stored in the column immediately following to the right of the variable to 
which it belongs.  

2. Quality flags are single digit integers: 0=good, 1=unknown, 4=questionable, 
8=bad. 

Missing data value  blank field or –1.e10. 

 

Import files in generic ODV Spreadsheet Format can be processed by ODV in a semi-automatic way: 
the identification of header columns requires no user interaction and these files can be dragged-and-
dropped onto the ODV icon or an open ODV window. 

To import data from a generic ODV spreadsheet file into the currently open collection choose Import-
>SpreadSheet and use the standard Windows file-select dialog to identify the data file that you want to 
import. Specify import options and press OK to start the data import.  
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# $ + K Importing WOCE WHP Hydrographic Data 
 
To import WOCE hydrographic data into an ODV collection, download the data files from the DAC or 
SAC (http://whpo.ucsd.edu/ or http://www.dkrz.de/~u241046/) and unzip them into an empty directory 
(source directory). Choose Import->WOCE Bottle Data or Import->WOCE CTD Data from ODV’s main 
menu. Use the standard Windows file-select dialog to identify the header file (*.sum) of the WOCE 
data set. If you are importing CTD data, ODV will now read all *.ctd files from the source directory and 
import them into the current collection. Note that ODV automatically converts the pressure data in the 
source files to depth in the collection. Note that ODV imports a maximum of 10,000 observed levels. If 
a station contains more levels, it will be truncated. 

If you import bottle data, you then identify the data file (default extension .hyd), specify import options 
and press OK to start the data import. ODV will read and import all stations in the WOCE data file. 
Note that ODV identifies and imports the WOCE data quality flags in addition to the actual data values. 
These quality flags can later be used to filter the data by excluding, for instance, bad or questionable 
data from the analysis. (You can modify the data quality filter by choosing selection criteria from the 
map popup menu (choose the Sample Selection tab).) 

Note that you can drag-and-drop .sum files onto ODV. 

                                                           
# IDH_IMPDAT_WOCE 
$ Importing WOCE WHP Hydrographic Data 
+ auto 
K WOCE hydrographic data; importing WOCE data; associate variables; convert units 
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# $ + K Importing NODC-WOA94 Hydrographic Data 
 
You can use ODV to import original hydrographic data directly from the distribution CDs of the World 
Ocean Atlas 1994 by choosing Import->WOA94 CD Data->Single File. Use the standard Windows file-
select dialog to identify the data file (*.ol) of the WOA94 data set that you want to import. Specify sta-
tion selection criteria to be satisfied by WOA94 stations (simply press OK to import all stations falling 
into the current map domain), specify import options and press OK to start the data import. ODV will 
read the selected WOA94 data file and import all stations that satisfy the station selection criteria. Note 
that you can also drag-and-drop .ol files onto ODV. 

You can import data from multiple WOA94 files using the same station selection criteria and import 
options in a single import operation. To do so, prepare an ASCII file (default extension .lst) containing 
the names of the files to be imported (full pathnames, one per line). Choose Import->WOA94 CD 
Data->Multiple Files, specify station selection criteria to be satisfied by WOA94 stations (simply press 
OK to import all stations falling into the current map domain), specify import options and press OK to 
start the data import. ODV will read all the files listed in the ASCII file and will import all stations that 
satisfy the station selection criteria. 

Note that only stations falling into the current map domain are imported into the collection. To make 
sure that all stations are imported, choose Global Map from the map pop-up menu before starting the 
import. 

                                                           
# IDH_IMPDAT_NODC 
$ Importing NODC-WOA94 Hydrographic Data 
+ auto 
K NODC data; WOA94; importing WOA94 data 
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# $ + K Importing NODC-WOD98 Hydrographic Data 
 
You can use ODV to import original hydrographic data directly from the distribution CDs of the World 
Ocean Database 1998 by choosing Import->WOD98 CD Data->Single File. Use the standard Win-
dows file-select dialog to identify a zipped data file (*.gz) of the WOD98 data set that you want to im-
port. Specify station selection criteria to be satisfied by WOD98 stations or simply press OK to import 
all stations falling into the current map domain, specify import options and press OK to start the data 
import. ODV will read the selected WOD98 data file and import all stations that satisfy the station se-
lection criteria. The cruise label of imported stations consists of the string ”WOD98” followed by the 
two digits NODC country-code and the NODC/OCL internal cruise number. The station number (if any) 
is preserved by ODV. 

You can import data from multiple WOD98 files using the same station selection criteria and import 
options in a single import operation. To do so, prepare an ASCII file (default extension .lst) containing 
the names of the files to be imported (full pathnames, one per line). Choose Import->WOD98 CD 
Data->Multiple Files, specify station selection criteria to be satisfied by WOD98 stations (simply press 
OK to import all stations falling into the current map domain), specify import options and press OK to 
start the data import. ODV will read all the files listed in the ASCII file and will import all stations that 
satisfy the station selection criteria. 

Note that only stations falling into the current map domain are imported into the collection. To make 
sure that all stations are imported, choose Global Map from the map pop-up menu before starting the 
import. 

                                                           
# IDH_IMPDAT_NODCWOD98 
$ Importing NODC-WOD98 Hydrographic Data 
+ auto 
K NODC data; WOD98; importing WOD98 data 
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# $ + K Importing NODC-SD2 Hydrographic Data 
 
You can use ODV to import original hydrographic data from NODC SD2 files by choosing Import-
>NODC SD2 Format->Single File. Use the standard Windows file-select dialog to identify the data file 
that you want to import. Specify import options and press OK to start the data import. 

If you want to import multiple SD2 files, put all the SD2 files in a single directory and produce a file 
containing the list of SD2 file-names that you want to import (default list-file extension .lst; one file-
name per line). Choose Import->NODC SD2 Format->Multiple Files and select the list-file. 

                                                           
# IDH_IMPDAT_NODCSD2 
$ Importing NODC-SD2 Hydrographic Data 
+ auto 
K NODC data; SD2 format; importing NODC SD2 data 
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# $ + K Importing Other Hydrographic Data 
 
If your hydrographic data are not in WOCE WHP, WOA94 or NODC SD2 format you can import these 
data into ODV collections using the ODV4.x ASCII format that permits long cruise and station labels as 
well as data quality flag values for every actual data value.  Users of old ODV versions may translate 
data via the ODV3.0 ASCII exchange format. 

 

ODV4.x ASCII exchange format 

The ODV4.x ASCII exchange format is a single-file format. Information on variables as well as the data 
values and quality flags for all stations to be imported are contained in one file (default extension 
.o4x). This file must contain information on type of data as well as number and labels of variables at 
the top (see below or file import4.o4x in the ODV samples directory). (Note that in the example below, 
the "....+." lines at the top and bottom only serve as rulers and are not part of the file.) 
 
Sample .o4x variables section 
....+....1....+....2....+....3....+....4....+....5....+....6....  
ODV4.0 Listing 
 File Name: import4.o4x 
      Type: HYD 
     Nstat: 12 
 Variables: 8 
 
Depth [m]                                                    6.0 
Temperature [°C]                                             8.2 
Salinity [psu]                                               8.3 
Oxygen [~$m~#mol/kg]                                         6.0 
Phosphate [~$m~#mol/kg]                                      8.2 
Silicate [~$m~#mol/kg]                                       8.1 
Nitrate [~$m~#mol/kg]                                        7.1 
Nitrite [~$m~#mol/kg]                                        6.1 
....+....1....+....2....+....3....+....4....+....5....+....6....  
 
 
One empty line separates the variables section of the data file from the header line of the first station 
(see file import4.o4x in the ODV samples directory for an example). Station header lines must start 
with a # in column 1. The following items are: (1) cruise-label of the station (cols. [3:22], format a20); 
(2) station-label ([24:43], a20); (3) station-type (either B, C or X for bottle, CTD or XBT data; [45:45], 
a1); (4) date mm/dd/yyyy ([47:66], i2,1x,i2,1x,i4); (5) east longitude (decimal; [58:64], f7.3); (6) north 
latitude (decimal; [66:72], f7.3); (7) bottom depth ([m]; [74:78], i5); (8) depth of deepest observation 
([m]; [80:84], i5); (9) number of depths sampled ([85:89], i5); (10) number of variables for which data 
are provided in the file ([91:93], i3). In the example file, the station 06MT18/558 is of type "Bottle", it 
contains 14 observed depths and data for 8 variables at these observed depths are to follow. These 
variables have to be identified by specifying their numbers (as defined in the variables section at the 
beginning of the file) on the second header line (e.g., 1 represents Depth and, for instance, 6 repre-
sents Silicate). Note that as the only format restriction, the variable numbers on the second header line 
have to be separated by at least one blank. 
 
For each observed depth (14 in the example file) one line of data has to follow. Each of these lines 
must contain a data and quality flag value for every variable specified on the second header line in 
that order. Missing values have to be set to -1.000E+10 in the data file. Note that data and quality flag 
values have to be separated by at least one space. Quality flags are single digit integers with the fol-
lowing meaning: 0=Good, 1=Unknown, 4=Questionable, 8=Bad. Immediately after the last data line of 
a given station follows the first header line (starting with the #) of the next station to be imported or the 
end-of-file if the station is the last to be read. 
 
Once the.o4x file has been created, run ODV and open or create the collection that is to receive the 
                                                           
# IDH_IMPDAT_OTHER 
$ Importing Other Hydrographic Data 
+ auto 
K importing other hydrographic data; quality flags; data quality flags 
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new data. Then choose ODV4.x Listing from the Import menu. Select the ASCII data file created 
above as data import file. Specify import options and press OK to start the data import. ODV will then 
read the import file and add/merge the stations to the collection. Note that you can also drag-and-drop 
.o4x files onto ODV. 
 
 
 
ODV3.0 ASCII exchange format 

To import data using the ODV3.0 exchange format you have to provide two ASCII files, one containing 
the actual data for all the stations that you want to import (default extension is .o3x) and one (small) 
file that describes the variables included in the data file (extension must be .var).  

Sample .var File 

....+....1....+....2....+....3....+....4....+....5....+....6.... 
ODV4.0 
Collection: SAVE 
      Type: HYD 
     Nstat: 0 
 Variables: 7 
 
Depth [m]                                                    6.0 
Temperature [°C]                                             8.2 
Salinity [psu]                                               8.3 
Oxygen [~$m~#mol/kg]                                         6.0 
Phosphate [~$m~#mol/kg]                                      8.2 
Silicate [~$m~#mol/kg]                                       8.1 
Nitrate [~$m~#mol/kg]                                        7.1 
....+....1....+....2....+....3....+....4....+....5....+....6.... 
 

Note that the “....+.” lines at the top and bottom only serve as rulers and are not part of the .var 
file. Also note that the .var file has the same format as ODV4.x collection definition files but that the 
information needed for the data import is confined to entries concerning the variables. In line 5 of the 
file starting in column 13 you have to specify the number of variables included in the data file to be 
imported. Then, after one blank line you have to provide variable label and numeric format for all the 
variables on separate lines. The numeric format has the appearance ll.d (ll is the total length in charac-
ters and d is the number of decimal figures) and starts in column 61. 

 

Sample .o3x header lines 

....+....1....+....2....+....3....+....4....+....5....+....6....+....7... 
# REID_ET           212 B  6/21/1967 243.167 -28.233  3400  3310   34   7 
    1    2    3    4    5    6    7 
 

The data for all the stations to be imported have to be provided in a single ASCII file (default extension 
.o3x). This file has to meet the following format specification (note that the ruler at the top is not part of 
the file): 

The file must begin with the header line of the first station to be imported. Station header lines must 
start with a # in column 1. The following items are: (1) cruise-label of the station (cols. [3:12], format 
a10); (2) station-label ([14:23], a10); (3) station-type (either B, C or X for bottle, CTD or XBT data; 
[25:25], a1); (4) date mm/dd/yyyy ([27:36], i2,1x,i2,1x,i4); (5) east longitude (decimal; [38:44], f7.3); (6) 
north latitude (decimal; [46:52], f7.3); (7) bottom depth ([m]; [54:58], i5); (8) depth of deepest observa-
tion ([m]; [60:64], i5); (9) number of depths sampled ([66:69], i4); (10) number of variables for which 
data are provided in the file ([71:73], i3). In the example above, the station REID_ET/212 is of type 
“Bottle”, it contains 34 observed depths and data for 7 variables at these observed depths are to fol-
low. These variables have to be identified by specifying their numbers as defined in the .var file on the 
second header line (e.g., 1 represents Depth and, for instance, 6 represents Silicate). Note that as the 
only format restriction, the variable numbers on the second header line have to be separated by at 
least one blank. 
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For each observed depth (34 in the example above) one line of data has to follow. Each of these lines 
must contain a numerical value for every variable specified on the second header line in that order. 
Missing values have to be set to -1.000E+10 in the data file. Immediately after the last data line of a 
given station follows the first header line (starting with the #) of the next station to be imported or the 
end-of-file if the station is the last to be read. 
 
Once the .var and .o3x files have been created, run ODV and open or create the collection that is to 
receive the new data. Then choose ODV3.0 Listing from the Import menu. Select the ASCII data file 
created above as data import file and identify the variables to be imported by selecting the import .var 
file as the data source. Specify import options and press OK to start the data import. ODV will then 
read the import file and add/merge the stations to the collection. Note that the data quality flags are set 
to Unknown if you import data using ODV3.0 exchange format. 



 24

# $ + K Import Options Dialog 
 
When importing data, ODV will present an Import Options dialog prompting the user for information 
that determines the actions taken. 
 
Import Mode: 

Add/Replace Station Data: Choose this option if you want to add data from the import file to the 
collection. If the Check for pre-existing stations box is checked, ODV searches the collection for 
stations with the same name, date and position and (if found) asks for permission to replace the 
existing station in the collection with the new version from the import file (see Cruise Label As-
sociation below for a description of the station search procedure). 

 
Merge Data (selected variables): Choose this option if you want to add data for one or more 
variables (merge variables) and leave existing data for other variables unchanged. A ”merged” 
value of a ”merge variable” at a given level depends on existing and new variable values ac-
cording to the following table: 
 

Existing value New value Merged value 
yes yes Average of existing and new values 
yes no Existing value 
no yes New value 
no no Missing value 

 
Note that the Check for pre-existing stations box cannot be unchecked for this mode. Before 
adding data, ODV searches the collection for matching stations (see Cruise Label Association 
below for a description of the station search procedure) and if found, reads the original station 
from the collection, adds the data for the selected variables and replaces the original station 
with the updated version. If no matching station is found, the user is notified. 
 
Update Data (selected variables): Choose this option if you want to update data for one or more 
variables (update variables) and leave existing data for other variables unchanged. An ”up-
dated” value of an ”update variable” at a given level only depends on the new variable values 
and existing values are discarded. Note that the Check for pre-existing stations box cannot be 
unchecked for this mode. Before updating data, ODV searches the collection for matching sta-
tions (see Cruise Label Association below for a description of the station search procedure) and 
if found, reads the original station from the collection, updates the data for the selected vari-
ables and replaces the original station with the updated version. If no matching station is found, 
the user is notified. 
 

 
Cruise Label Association: 

When searching a collection for stations matching a specific station to be imported, the cruise 
labels in the collection and in the import-file need not be identical. Instead you can establish 
alias names using the Target and Source combo-boxes. If, for instance, in the existing collection 
a set of stations is named 06MT15/3 and in the import file the same stations are named 
METEOR15/3 you set up an alias name by first choosing 06MT15/3 from the Target combo-box 
and then typing METEOR15/3 in the source field. Note that the default entries in the Source 
field are the same as the target names, so in case the cruise labels in the import file and in the 
collection are identical, you do not need to modify the Cruise Label Association at all. 

 
Variable Association: 

Usually the number, order and meaning of variables stored in the import file differ from the 
number, order and meaning of variables stored in the collection and you must establish a 
source/target association of variables. ODV automatically associates variables with matching 
labels (name and units). Note that associated variables are marked with a *. You can click on 
such a variable to identify its associated variable. To establish a variable association manually 
click on the respective source variable, then click on the target variable to be associated with 
the source variable and either press the Associate or Convert buttons. Use Associate if the data 

                                                           
# IDH_IMPDAT_DIALOG 
$ Import Options Dialog 
+ auto 
K import options 
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values in the import file should be imported without modification, but use Convert if you need to 
transform units during import. When using Convert, you can choose between predefined, com-
monly used transformations and you can establish your own general linear transformation for-
mula. Note that source variables not associated with a target variable will not be imported into 
the collection. If you merge data into the collection, establish associations only for those vari-
ables that you want to add to the collection. Note that Depth [m] (the first variable in any ODV 
collection) must be associated in any case. 
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# $ + K Exporting Data into Spreadsheet Files 
 
You can export the data of the currently selected stations into a single ASCII spreadsheet file by 
choosing Export->SpreadSheet from ODV’s main menu. Then select the variables to be included in 
the export file (default: all variables) and specify destination directory and file-name using the standard 
Windows file-select dialog-box. Note that spreadsheet files can be re-imported using the Import-> 
SpreadSheet. Note that valid ODV spreadsheet names may not contain spaces or any of the following 
characters: \ / :. 

                                                           
# IDH_EXPDAT_SPREADSHT  
$ Exporting Data into SpreadSheet Files  
+ auto 
K exporting data into SpreadSheets  
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# $ + K Exporting Data into ASCII Listings 
 
You can export the data of the currently selected stations into a single ASCII listing file by choosing 
Export->ODV4.x Listing from ODV’s main menu. Then select the variables to be included in the export 
file (default: all variables) and specify destination directory and file-name using the standard Windows 
file-select dialog-box. Note that ODV4.x Listing files can be re-imported using the Import-> ODV4.x 
Listing. For further information on the ODV4.x Listing format click here. Note that valid ODV listing 
names may not contain spaces or any of the following characters: \ / :. 
 

                                                           
# IDH_EXPDAT_LIST 
$ Exporting Data into ASCII Listings 
+ auto 
K exporting data into ASCII listings 



 28

# $ + K Exporting Plot Values 
 
You can export the data values displayed in ODV plot windows to ASCII files for subsequent process-
ing (averaging, gridding, contouring, etc.) by choosing Export->Export Plot Values from ODV’s main 
menu. When prompted for, enter a descriptive text identifying the data of this export (txtID) and click 
OK. ODV will create a sub-directory in the ODV temporary-files directory (normally \Program 
Files\Ocean Data View\Temp) named Export\txtID. All exported files will be written to this directory. If it 
already exists, ODV asks for your permission to delete all files from the directory before continuing. 
Note that the names of the exported files start with “win?” where ? represents the respective window 
number. The actual x-y-z-sigmaz data are found in files win?.oai (one data point per line). 

For windows with gridded fields, ODV also exports the results of the gridding operation (files 
win?.oao). The format of the .oao files is as follows: 

0    (ignore) 

nx  ny    (no of x and y grid-points) 

... nx X-grid values ...  (X-grid positions) 

... ny Y-grid values ...  (Y-grid positions) 

... nx*ny gridded values ... (estimated field, X-line by X-line starting at first Y-grid value) 

 

                                                           
# IDH_EXPDAT_PLOTS 
$ Exporting Plot Values 
+ auto 
K exporting plot values 
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# $ + K Derived Variables – Overview 
 

In addition to the basic variables stored in the collection files, ODV can calculate a large number of 
derived variables which (once defined) are available for analysis and use in the data plots in the same 
way as the basic variables. There are three types of derived variables: 

 

• built-in derived variables including many commonly used parameters from physical and 
chemical oceanography. 

• macro files of user defined expressions stored in files for use with arbitrary ODV collections. 

• expressions defined by the user “on-the-fly” for the current collection only. 

To define or delete derived variables choose the Derived Variables option from the background popup 
menu or Configuration->Derived Variables from the main menu. To add a macro choose Macro File 
from the “Choices” list; to add an user defined expression choose Expression. To add a built-in derived 
variable choose any other item in the “Choices” list. 

                                                           
# IDH_ODV_DEFDERIVED_OVERVIEW 
$ Derived Variables - Overview 
+ auto 
K derived variables; built-in derived variables; macros; expressions 
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# $ + K Built-in Derived Variables 
 
The algorithms for many commonly used parameters from physical oceanography including potential 
temperature and density referenced to arbitrary reference pressures, neutral density, Brunt-Vaisala 
Freq., dynamic height and many others are built into ODV and can be calculated and analysed on-the-
fly. In addition, there is a large set of variables from chemical oceanography and other useful mathe-
matical constructs, like for instance vertical integrals and derivatives. A list of available built-in derived 
variables is included below. 

To define or delete built-in derived variables choose the Derived Variables option from the background 
popup menu. ODV will show list-boxes of available and already defined derived variables. To add a 
derived variable select an item from the Choices list either by clicking the item or pressing Add or by 
double-clicking the item. Some variables, like for instance potential temperature and density require 
additional information, e.g., the reference pressure. Enter this information and press OK. Other derived 
variables like for instance oxygen saturation require that you identify the appropriate input variable(s). 
To delete a derived variable click on this variable in the Already Defined list box and press Delete or 
simply double-click on the item to be deleted. Note that when deleting a variable that is required as 
input by other derived variables, these quantities are deleted as well. 

 

List of built-in derived variables: 

Variable Comment 
Brunt-Vaisala Freq. [cycl/h] EOS80 
CFC-11 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
CFC-12 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
CFC-10 Saturation [%] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 
CFC-113 Saturation [%] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 
CH4 Saturation [%] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 
CO2(TCO2,TALK) [umol/kg] Dickson and Goyet, DOE Handbook, 1991 
CO3

- -(TCO2,TALK) [umol/kg] Dickson and Goyet, DOE Handbook, 1991 
Day of Year  
Difference from Reference Data (details) 
Dynamic Height [dyn m] EOS80 (any reference pressure) 
Freezing Temperature [°C] F. Millero, UNESCOTech. Papers in the Marine Science, No. 28., 29-35, 1978 
HCO3

-(TCO2,TALK) [umol/kg] Dickson and Goyet, DOE Handbook, 1991 
Latitude  
Longitude  
Neutral Density [kg/m3] Jackett & McDougall, J. Phys. Ocean., 237-263, 1997 
Oxygen Saturation [%] Weiss, Deep Sea Res., 17, 721-735, 1970 
pCFC-11 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
pCFC-12 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
pCFC-10 [pptv] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 
pCFC-113 [pptv] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 
pCH4 [ppbv] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 
pCO2(TCO2,TALK) [uAtm] Dickson and Goyet, DOE Handbook, 1991; Weiss 74 
pH(TCO2,TALK)  Dickson and Goyet, DOE Handbook, 1991 
Potential Density [kg/m3] EOS80 (any reference pressure) 
Potential Temperature [°C] Bryden, Deep Sea Res.,20,401-408, 1973 (any reference pressure) 
Pressure [db] Saunders, J. Phys.  Ocean., 1981 
Ratio Any two variables 
Sound Speed [m/s] Chen & Millero 1977, jasa, 62, 1129-1135 
Specific Heat Cp  [J/(kg °C)] F. Millero et al, J. Geoph. Res., 78, 4499-4507, 1973 
Time [yr]  
Vertical Derivative Any variable 
Second Vertical Derivative Any variable 
Vertical Integral Any variable 
 

Vertical Integral: 

The user selects the variable for which the vertical integral is to be calculated (designated A in the following; 
any basic or already defined derived variable can be used) and specifies the starting depth z0 for the integral 
(default: 0 m). For each observed level of a given station, ODV will calculate the integral A*dz from z0 to the 
respective level. The units of the integral are the units of the quantity A times length (km used by ODV). For 
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variables with volumetric concentration units (e.g., moles per cubic meter) the calculated integral is equivalent 
to "standing stock per square meters". Note that by definition the value of the integral at z0 is zero. (Example: 
To obtain the salt content in the top 500m of the water column, select salinity as variable for the integral and 
use 0 as start value. Then look up the value of the vertical integral at 500 m (by interpolating between 
neighbouring points) or in SURFACE mode define the integral at depth=500 as an iso-surface variable.) 
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# $ + K Macros of Derived Variables 
 
You can implement new derived variables not included in the list of built-in derived quantities if the 
value of your new derived variable at a specific level only depends on other variable values at the 
same level. In these cases you specify the input variables and the formula of the new derived quantity 
in a macro file. Macro files must have the extension .mac, they must be located in the ODV macros 
directory (normally c:\Program Files\Ocean Data View\Include\Macros) and their format must follow 
the specifications given below. You can use the ODV Macro Editor (invoked by: Utilities->Invoke 
Macro Editor) to facilitate macro definition. Use the example macro files that are distributed with ODV 
as sample files for your own definitions. 
 
You activate a macro derived variable by selecting Derived Variables from the background popup 
menu and choosing Macro File from the list of available quantities. Then select one of the macro files 
found in the ODV macros directory (normally c:\Program Files\Ocean Data View\Include\Macros) and 
identify the variables needed to calculate the new quantity. If one of the required variables is not avail-
able, press Cancel to abort setup of the macro file. 
 
The ODV Macro Format: 
 
Sample macro file po.mac: 
 
ODV4.0 Macro 
>|--->----------------------------------------------------------|>--| 
     PO [~$m~#mol/kg]                                             5.0 
#1   Phosphate [~$m~#mol/kg] 
#2   Oxygen [~$m~#mol/kg] 
 
135 #1 *  #2 + 
 
The first line of a ODV macro file must contain the string ODV4.0 Macro and is used for identification 
purposes only. The second line serves as a ruler to facilitate the formatting of the rest of the file. The 
actual definition of the new derived variable starts on line three, column 6 with the label of the new 
variable followed by the numeric format ll.d used for the ODV text-window starting on column 66. ll 
specifies the length of the text-field and d specifies the number of decimal places. Then, one line fol-
lows for every other variable (basic or already defined derived variable) that is used in the calculation 
of the new variable. Start these lines with a # in the first column followed by a single digit (numbers 
must be in consecutive order 1, 2, ... 9). Beginning in column 6, enter a name describing the quantity 
that is to be used. Note that for the variable labels you can use the control sequences for Greek sym-
bols, sub- and superscripts described above. 
 
One empty line separates the block of variables to be used in the calculations from the actual specifi-
cation of the algebraic operations to be executed for each observed depth of a station (see the exam-
ple macro file above). You can use the operators + - * / ** for the basic arithmetic operations,  min and 
max for minimum and maximum of preceding two operands, ln and exp for the natural logarithm and 
exponential, and sin and cos for sine and cosine (arguments in radians). Type in the macro formula 
as if you were using a Hewlett-Packard calculator (operands precede their operators) and use, for 
instance, the sequence #1 to reference the value of variable #1. Use the symbols %t, %d, %x, and %y 
to refer to time of observation (in years since 1900; e.g., %t=84.4877 for Jun/27/84), day-of-the-year, 
(east-) longitude and (north-) latitude, respectively. Separate the individual items (operands and opera-
tors) by at least one space and continue definition of the macro formula on following lines, if neces-
sary. Note that the total number of characters in the formula-definition may not exceed 500. The 
maximum number of simultaneously active macros in an ODV session is 10. 
 
In the example above which calculates the quantity PO = 135 * PO4 + O2 the sequence 135 #1 * yields 
the product of 135 and the value of variable #1 at the current level. Once executed, the sequence 135 
#1 * is replaced by the result of the multiplication and the value of variable #2 is then added. Note that 
the value of a derived quantity is set to -1.e10 (missing data value) if one or more of the input variables 
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have no measurement. 
 
The macro capabilities of ODV are general enough to allow a wide range of applications. Two addi-
tional examples are given below. 
 
(a) decay correcting a radioactive tracer to a reference date t0 (here: t0=1980; tau=17.6 yrs): 

T(t0) = T(t) e(t - t0)/tau 
 
ODV4.0 Macro 
>|--->----------------------------------------------------------|>--| 
     Trit80 [TU]                                                  7.2 
#1   Tritium [TU]        
 
%t 80 - 17.6 / exp #1 * 
 
 
 
(b) multi-parameter distance of water-mass characteristics (here using pot. temperature, salinity and 
silicate): 

C = {(c - c0) / sigma }2 + ... 
 
 
ODV4.0 Macro 
>|--->----------------------------------------------------------|>--| 
     MP-Dist{10,34.7,25}                                          7.0 
#1   Tpot [C] 
#2   Salinity [psu] 
#3   Silicate [umol/kg] 
 
#1 10   - 0.1  / 2 **  
#2 34.7 - 0.05 / 2 ** + 
#3 25   - 0.5  / 2 ** + 
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# $ + K Expressions 
 
Expressions are similar to macros, they use the same function set and are defined in roughly the same 
way. The main difference is that the definition of an expression is not recorded in a file and expres-
sions cannot be edited. Expressions are ideal for checking out newly devised derived quantities 
quickly. The scope of an expression is limited to the collection for which it is defined. If an expression 
is complicated or if you want to use the same expression with many different collections, you should 
create a macro file instead. 

To setup an expression derived variable select Derived Variables from the background popup menu, 
choose Expression from the list of available quantities and press Add. ODV will show a dialog similar 
to the macro editor dialog. You should enter the label of the new variable and the corresponding units 
in the Label field. Then select the input variables required by the new variable, e.g., select a variable in 
the Choices list and press <-. Finally, specify the expression to be evaluated for the new quantity. You 
can use the operators + - * / ** for the basic arithmetic operations, min and max for minimum and 
maximum of preceding two operands, ln and exp for the natural logarithm and exponential, and sin 
and cos for sine and cosine (arguments in radians). Type in the macro formula as if you were using a 
Hewlett-Packard calculator (operands precede their operators) and use, for instance, the sequence #1 
to reference the value of the first input variable #1. Use the symbols %t, %d, %x, and %y to refer to 
time of observation (in years since 1900; e.g., %t=84.4877 for Jun/27/84), day-of-the-year, (east-) 
longitude and (north-) latitude, respectively. Separate the individual items (operands and operators) by 
at least one space and continue definition of the macro formula on following lines, if necessary. Note 
that the total number of characters in the formula-definition may not exceed 500. Press OK to finish 
the setup of the new expression.  

Note that expressions can not be edited. If you want to modify the algorithm you have to delete the old 
expression variable and define a new one. 

                                                           
# IDH_ODV_DEFDERIVED_EXPR 
$ Expressions 
+ auto 
K expressions 



 35

# $ + K Choosing Current Sample and Current Station 
 
When ODV has opened a collection and has drawn the station map, one of the valid stations shown in 
the map is the current station. This station is marked by a red circle and the header as well as data 
information appears in ODV’s text window. There are several different ways to select a new current 
station: 

(1) click the left mouse button on any station in the map. if there are multiple stations at the same 
position (repeat stations, mooring instruments, etc.) and the “multi-station selection” option 
under Configuration->General Settings->Station Selection is switched on, ODV presents a list 
of matching stations and lets the user select one of those. Otherwise, the first matching station 
is selected by default. 

(2) choose Select Station by Name from the map popup menu and specific cruise label, station la-
bel and station type. 

(3) choose Select Station by Number from the map popup menu (or simply press #) and specify the 
internal sequence number of the station. 

 
Pressing the right arrow key (->) advances to the next valid station, pressing the left arrow key (<-) 
gets you to the previous one. Note that when selecting a new current station by mouse-clicking 
(method 1) on a station 
 
One of the samples of the current station is the current sample, and the data values of this sample are 
listed in line 3 of ODV’s text window. If data plots are on the screen the current sample is also marked 
by red cross hairs in each of the plots. You can select deeper or shallower new samples of the same 
station by pressing the up/down and PgUp/PgDn arrow-keys, or you can make any data point in any of 
the data plots the current sample by simply clicking on it with the left mouse button. 

If you move the mouse over lines 2 and 3 of the text window you get more detailed information on the 
data value, including its quality flag. You can change the numeric format and order in which the vari-
ables are listed in the text window by choosing Variables Settings from the text-window popup menu. 

                                                           
# IDH_ODV_CURRENT 
$ Choosing Current Sample and Current Station 
+ auto 
K current sample; current station; selecting samples; selecting stations; using arrow-keys 



 36

# $ + K Changing Variable Settings 
 
You can modify the variable labels, the default min/max ranges, the numeric format and the position in 
line 3 of ODV’s text-window of any collection variable using the Variables Settings option of the text 
window popup menu (click right mouse button while over the text window and select Variables Set-
tings).  

First select a variable that you want to modify using the Variable control (if the mouse was over the 
respective variable when you right-clicked, this variable is already pre-selected). Then modify the dif-
ferent properties for this variable. You change the variable label and units string by editing the Label 
item. Note that the units should be enclosed between [ and ] brackets. You change the default lower 
and upper value ranges of the variable by setting the Minimum and Maximum entries. You modify the 
numeric format used to list data for the variable in line 3 of the text window by setting the Format en-
tries. The first number specifies the length of the field (in characters) and the second number specifies 
the number of decimal places. Finally, you can change the position of the variable in the text window 
using the Position combo-box (select the new position of the variable, e.g. potential temperature next 
to (in-situ) temperature). Continue making changes for other variables (select them using the Variable 
combo-box) and press OK when you are done. 
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# $ + K Changing Station Selection Criteria 
 
When ODV opens a collection and draws the station map, it checks whether the stations satisfy the 
current station selection criteria. Only stations that do are considered valid, they are marked in the 
map and only these are available for browsing and plotting. To change the selection criteria choose 
Selection Criteria from the map popup menu. Choose the category that you want to modify by clicking 
on the respective tab, e.g., Name/Range, Date/Time, Availability and Sample Selection, and manipu-
late the various controls. In the Domain category you can define a rectangular sub-domain of the map 
by specifying respective lon/lat values or you can press the Zoom button to define the rectangle by 
zooming. You can define a polygon as valid domain by pressing the Polygon button and then entering 
the vertices of the polygon with the mouse. Note that the polygon is closed automatically. In the Avail-
ability category you can mark one or more variables that must be present for a station to be consid-
ered valid. In the Sample Selection category you can set the data quality filter and invalidate all sam-
ples that have values for the Validate Variable outside a given range. If you want to relax the criteria of 
a given category, press the Relax All Criteria button. If you are done press OK. ODV will rebuild the 
station map using the new selection criteria. 
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# $ + K Changing Map Projections 
 
You can change the map projection using Display Options from the map popup menu, selecting the 
General tab and choosing a suitable projection from the Map Projection combo-box. The following 
projections are available: (1) ”Default Projection”, (2) "Orthographic (North Polar)", (3) "Orthographic 
(Equatorial)", (4) "Orthographic (South Polar)", (5) "Orthographic (General)", and (6)  "Mollweide". The 
orthographic projections are hemispheric while the default and Mollweide projections are global in 
extent. All projections allow zooming-in or specification of a sub-region using the Domain tab of the 
map display option dialog. With the "Orthographic (General)" projection you can specify an arbitrary 
lon/lat eye position (pole) from which the globe is then viewed. For the other projections the pole lati-
tude is fixed and the user may only vary the pole longitude. 

Note that for projections (2) to (6) the definition of sub-domains by zooming can be a little bit tricky. If 
you need accurate results either use the Domain tab of the map display option dialog or switch to De-
fault Projection temporarily, then zoom (thereby defining the sub-region) and finally switch back to the 
desired map projection.  

For a description of other map display options see Changing Display Options. 
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# $ + K Full Screen Station Maps 
 
You can produce full-screen station maps by choosing MAP Mode from the background popup menu. 
You can label a station in the map by double clicking on it, and you can remove the annotation of the 
current station by pressing the delete button (Del or Entf). Note that the positioning of the annotation 
depends on the mouse position at the time of the double-click relative to the station position. Try it. 
You change the annotation style and font-size through Display Options dialog box. You can produce a 
hardcopy of the station map through File->Print or you can obtain a PostScript, GIF or EMF file of the 
map using File->Save As from the main menu and selecting the desired format. 
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# $ + K Producing Property-Property Plots 
 
When ODV is in STATION mode (indicated in the lower right corner of the window; switch to STATION 
mode by choosing STATION Mode from the background popup menu) you can produce prop-
erty/property plots of the current station by pressing p or by double-clicking the left mouse on the cur-
rent station in the map. You can add the data of other stations to the plots by either double-clicking on 
them or by selecting them as current station and pressing p. 

 

See also: zooming and auto-scaling; selecting new X-and Y-variables; changing display options; print-
ing; PostScript file. 
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# $ + K Zooming and Automatic Scaling 
 
You can change the variable ranges of any data plot by moving the mouse over this window, clicking 
the right mouse button to invoke the data plot popup menu and choosing either Full Range or Zoom. 
For Full Range, the X- and Y-Ranges of the current window are adjusted to accommodate all plotted 
data values in this window. If you use Full Range (All) you can auto-scale all data plots on the screen. 

If you select Zoom, a red zoom-frame appears around the current window. To manipulate this zoom-
frame move the mouse over it, press the left mouse button and drag the frame to desired locations. To 
accept the current setting of the zoom-frame and adjust the variable ranges accordingly double-click 
the left mouse button or press ENTER. If you want to abort the zoom operation and keep the present 
variable ranges, press ESC or click the right mouse button. 

In addition to this the standard zoom procedure that allows maximum control, a "quick-zoom" option is 
also available. When the mouse is over the map or any data plot press (and hold down) the Ctrl key 
and press (and hold down) the left mouse button to drag a zoom box. Releasing the left mouse button 
applies the zoom box settings to the window from which the “quick-zoom” was initiated. 
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# $ + K Changing Window Layout 
 
ODV keeps window layout information separately for each of its modes, STATION, SCATTER, 
SECTION and SURFACE. The layout information includes position and size of map and data-plots, 
number of data-plots, variables on X-, Y- and Z-axis, size of symbols and the selection of topography 
files for the map. In each of its modes, you can change the respective window layout by invoking the 
background popup menu (click the right mouse button while over the background area) and choosing 
Graphics Layout. ODV will outline the current layout and lets you move, resize, delete or create win-
dows. To perform one of these operations on a window, move the mouse inside that window and in-
voke the layout-popup menu by clicking the right mouse button and select the appropriate option.  

If you choose Move/Resize a red zoom-frame appears around the respective window. You move and 
resize this zoom frame by moving the mouse over it, pressing the left mouse button and dragging. To 
accept the new size and position for the window double-click the left mouse button or press ENTER. 
To abort the Move/Resize operation leaving the window position unchanged press ESC. You create 
new windows by creating a twin of an existing window and modifying its properties.  

To select new variables on X-, Y- and Z-axis of the window select the appropriate option and choose a 
variable from the list-box that appears. Note that by default variable values increase to the right and 
upwards. If you want to reverse the direction (e.g., depth in depth profiles) check the Reverse Variable 
Range box. Press OK to accept the choice. You leave Graphics Layout mode by choosing either Ac-
cept or Cancel.  Note that you can modify other properties of map and data plots using the Display 
Options function from the map and data-plot popup menus. 
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# $ + K Changing Display Options 
 
You can modify display properties of the map and any data plot using the Display Options function 
from the map and data-plot popup menus. To invoke these menus move the mouse over the respec-
tive window and click the right mouse button. 

Map: 

The ”Map Display Options” property sheet lets you modify map properties in four categories: General, 
Layers, Domain and Annotations. You access any of these categories by clicking on the respective 
tab. 

General  

Select the color palette used for the map, choose a background color and specify whether grid lines 
should be drawn or not. Specify a map projection and choose color and symbol size for the station 
dots. 

Layers 

ODV can draw ocean bathymetry, coastlines, land topography and other, additional features like lakes, 
rivers, borders, sea-ice extend, ocean fronts etc. into the map window. A low resolution, global version 
of these geographical feature files (GlobLR series) is provided by default when you install ODV (ver-
sion 4.1 and above). Higher resolution global and regional datasets are available as optional packages 
and can be downloaded and installed at any time. Choose one of the installed series from the ”Series” 
list. Check the ”Draw Color Bar” box if a bathymetry/topography color bar should be drawn. 

The geographical features mentioned above are implemented and drawn by ODV as individual layers. 
These layers are grouped into seven layer sets: (1) "pre-Bathymetry", (2) "Ocean Bathymetry", (3) 
"pre-Coastlines", (4) "Coastlines", (5) "pre-Topography",(6) "Land Topography", (7) "post-
Topography". You compose a layer set by selecting it in the Layer Sets list and pressing the Compose 
button. ODV will show a list of available layers for this layer set. Choose one or more layers from the 
Available list (using standard Windows techniques), specify drawing characteristics and press the ”<-” 
button to add the layers to the Selected list. To remove layers from the Selected list, select them and 
press ”->”.  

When specifying drawing characteristics follow these rules:  

(a) if the features should be outlined by lines (stroked), choose the appropriate line-width, -type 
and –color or choose ”none” as color, if you don’t want outlines. Note that due to limitations of 
Windows, lines that are more than 1 pixel wide, will always be solid on the screen and in GIF 
and .emf files. ODV PostScript files, however, honor your selection for any line-width. 

(b) if the features should be filled choose the appropriate Fill color or ”none”, if you don’t want fill-
ing.  

If you choose ”automatic” for line and fill colors, ODV will use default colors. Note that for some layer 
sets ”automatic” defaults to ”none”. Also note that some feature files like rivers or borders should not 
be filled, and you should explicitly set the fill color to ”none”. 

When ODV produces the map it processes the layer sets in the order given above. For a given layer 
set it draws the individual layers in the order in which they appear in the Selected list (note that ocean 
bathymetry and land topography layers are sorted automatically when you add them). You should 
define sea-ice distributions in the "pre-Coastlines" set and lakes, rivers and borders in the "post-
Topography" category. 

Domain 

Specify a lon/lat sub-domain or switch to the full domain of the collection or to a global map. 

Annotations 

Specify whether selected stations should have cruise and/or station labels and set the font size of the 
labels. Note that this option only applies to full-screen MAP mode and STATION mode (press F8 or F9 
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to switch to these modes). To select a station in MAP and STATION mode double click on it with the 
left mouse button. The position of the mouse pointer relative to the station position determines the 
position of the label. If you want the label to appear above the station location, point the mouse slightly 
above the station and double-click; if the label is to appear to the lower-right of the station, double-click 
on a lower-right position and so on. 

 

Data-plot windows: 

For property/property plots (STATION mode) you may set the symbol-size and the width of the con-
necting lines between data points. Choosing zero in either case selects no symbol or no connecting 
lines. For scatter, section or surface plots (SCATTER, SECTION and SURFACE modes) you can set 
the display mode (Original Data: colored dots, numeric values or arrows; Quick Gridding; VG Grid-
ding), the dot (or font) size for the original data, the point-size (for scatter plots), and the X- and Y- 
averaging length scales for gridded fields. Note that two different gridding algorithms are available and 
that contouring is supported for both. Also note that the X- and Y- length scales are measured in per 
mille of the respective axis range and that large values result in smooth fields. You should try different 
settings for the length-scales and select the ones that you like most.  

For gridded fields, use the Properties button to set additional general options and to specify contour 
lines. Note that you add sets of contour lines by specifying Start, Increment and End values. Choose 
appropriate line-styles and colors and set the Contour Label Size entry. Then press the Add button to 
add the respective set a contour lines with the specified properties. You can repeat this procedure with 
possibly different line properties. The maximum number of contour lines per window is 50. To modify 
the properties of an existing contour line, select it in the “Already Defined” list, modify the properties in 
the “New” area and press Add to implement the changes. 

Uncheck the Automatic Axis Labels box if you want to switch off the automatic generation of axis la-
bels and place annotations manually. Note the Apply to all Windows check box in the Display Options 
dialogs for data windows. If this box is checked the modifications that you make will apply to all data 
plots in the current mode. If you want to establish individual styles for your data plots, make sure this 
box is not checked.  
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# $ + K Print 
 
Choose Print from the File or background popup menus to print the contents of the current ODV 
graphics window.  

WIN32: 

ODV invokes a standard Windows print-dialog box and lets you select one of the printers available on 
your system. Press OK to start the printing. Note that print jobs for complicated screen graphics tend 
to be large and time-consuming. If you have access to a PostScript printer, use the PostScript option 
instead. 

UNIX: 

Note that the ODV Print option on UNIX only works with PostScript printers. ODV shows a list of such 
printers currently registered for use by ODV. Choose one of these printers and press OK to start the 
printing. You can add other PostScript printers by clicking on New, specifying a printer name and the 
corresponding print command (e.g., “lpr –P xxxx”, where xxxx represents the network printer name). 
To delete one of the registered printers from the list, select it and click on Delete. 
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# $ + K PostScript Files 
 
The resulting PostScript file can be printed by sending it to a PostScript printer or it can be included in 
LaTex, Word, PageMaker and other page-design documents (to use this feature, you must save the In 
addition to the Print command that prints the current ODV screen on any printer connected to your 
system, you can produce PostScript files of the current ODV screen or individual data plots by choos-
ing Save As from the background popup-menu (ODV screen) or Extras->Save Single As from a data 
plot popup menu (individual plot). Note that you can reach these options via shortcut key-strokes:  (1) 
pressing Ctrl-S while the mouse is over the background area produces a full ODV screen representa-
tion while (2) pressing Ctrl-S with the mouse over a data plot will produce a PostScript version of the 
respective data plot. For PostScript output, make sure to select the PostScript (*.eps) file type in the 
file-save dialog box that ODV will present. At this time you may specify a destination file other than the 
default destination suggested by ODV. 

While Print jobs tend to be large for complicated section and surface plots, the PostScript files are 
much tighter and printing may be faster. Note that by default the PostScript files are written to ODV’s 
Temporary Files directory and that the file-name is derived from the current configuration name. You 
can choose any other file name or destination directory using the Windows File Save dialog that ap-
pears automatically. 

                                                           
# IDH_ODV_POSTSCRIPT 
$ PostScript Files 
+ auto 
K PostScript files; deleting temporary files 
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# $ + K GIF and EMF Files 
 
You can export the current ODV graphics screen or individual data plots in GIF or enhanced meta files 
(EMF) (suitable for including in text documents or post-processing with standard graphics software) by 
choosing Save As from the background popup menu (ODV screen) or Extras->Save Single As from a 
data plot popup menu (individual plot). Note that you can reach these options via shortcut key-strokes:  
(1) pressing Ctrl-S while the mouse is over the background area produces a full ODV screen represen-
tation while (2) pressing Ctrl-S with the mouse over a data plot will produce a version of the respective 
data plot. ODV will present a file-save dialog box and you should choose the appropriate output file-
type (GIF (*.gif) or Enh. Metafile (*.emf)). Note that by default GIF or EMF files are written to ODV’s 
temporary directory and that the file-name is derived from the current configuration name. You can 
choose any other name or destination. 

Also note that GIF files by definition only support up to 256 colors. If you use different palettes for the 
individual data plot windows, only the palette of the last plot window is displayed correctly in the GIF 
file, and false colors may appear in the other windows. In these cases you should use the ”Enh. Meta-
file (*.emf)” output format instead of GIF, or you should produce separate GIF files for the individual 
data plot windows (option Extras->Save Single As of the data plot popup menu). 

UNIX: 

The “GIF (*.gif)” and ”Enh. Metafile (*.emf)” output options are not available under UNIX. To produce a 
.gif file of the ODV graphics canvas or individual plot windows, use the Solaris Desktop_Apps applica-
tion “Image Viewer”, capture the ODV screen or some part of it and save the picture as .gif. 

                                                           
# IDH_ODV_GIF 
$ GIF and EMF Files 
+ auto 
K GIF files; EMF files 
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# $ + K Producing Scatter Plots 
 
You can produce property/property plots of all data of all currently valid stations (optionally colored 
using a third variable) by switching to ODV’s SCATTER Mode (using the background popup menu) 
and double-clicking the left mouse button on the map.  

 

See also: zooming and auto-scaling; selecting new X-and Y-variables; changing display options; print-
ing; PostScript file. 

                                                           
# IDH_ODV_SCATTER 
$ Producing Scatter Plots 
+ auto 
K scatter plots 
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# $ + K Defining a Section 
 
Before you can plot sections you have to define and install section outline and characteristics first. To 
define a new section or use a previously defined section invoke the map popup menu by clicking the 
right mouse button when the mouse is over the map. Choose Define Section ->Define Section Spine  
for a new section and Define Section ->Load Section if you want to use a previously defined one. In 
the latter case simply select one of the sections from the list (by double-clicking on it). If you create a 
new section, note that the mouse cursor changes to a cross hair indicating that the user is expected to 
enter a sequence of points that define the centerline of the section. You enter a point by moving the 
cross hair to the desired location and clicking the left mouse button. To remove a point, move the 
mouse close to it and click the right mouse button. To accept the set of points press ENTER or specify 
the last point with a double-click of the left mouse. Note that you may construct rather complicated 
sections following arbitrary cruise tracks. 

After specifying the section spine, ODV assigns a default width for the section band and selects dis-
tance from the starting point (the first point entered) as the default along-section coordinate. A dialog 
box appears that lets you change the default characteristics of the section. All stations inside the sec-
tion band marked in the map belong to the section and are plotted in subsequent plot operations. You 
can change the characteristics of the section at any time by choosing Define Section ->Change Char-
acteristics from the map popup menu. If you plan to use this section again later, you should save the 
section definition by choosing the Define Section ->Save Section As option. To undefine a section 
select Define Section ->Undefine Section.  

 

See also: Plotting a Section. 

                                                           
# IDH_ODV_DEFSEC 
$ Defining a Section 
+ auto 
K defining a section; specifying the section spine; using named sections; SECTION mode 
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# $ + K Plotting a Section 
 
Once you have defined a section you can plot color property distributions along the section and prop-
erty/property plots for all stations belonging to the section by double-clicking the left mouse button 
while over the map or by pressing p. For color property distributions along the section choose Section 
Coordinate on the X-axis and arbitrary variables for Y and Z.. 

 

See also: zooming and auto-scaling; Color-Zooming; Changing the Color Mapping Function; selecting 
new X, Y-and Z-variables; changing display options; displaying gridded fields; exporting plot 
values;printing; PostScript file. 

                                                           
# IDH_ODV_PLOTSEC 
$ Plotting a Section 
+ auto 
K plotting a section; section coordinate 



 51

# $ + K Color-Zooming 
 
Color section plots and color distributions on iso-surfaces allow modifications of the Z-variable ranges 
by color zooming. To invoke color-zooming move the mouse over the section or iso-surface plot that 
you want to modify and click the right mouse button to bring up the data plot popup menu. Selecting Z-
Zoom will draw a red zoom-frame around the color bar of the respective window. Manipulate and drag 
this zoom-frame as described above. To accept the current setting of the zoom-frame and adjust the 
Z-variable range accordingly double-click the left mouse button or press ENTER. If you want to abort 
the zoom operation and keep the present variable range, press ESC or click the right mouse button. 

                                                           
# IDH_ODV_COLORZOOM 
$ Color-Zooming 
+ auto 
K color-zooming; configuration 
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# $ + K Changing the Color Mapping Function 
 
For color section plots and color distributions on iso-surfaces you can manipulate the color mapping of 
the Z-variable values. To invoke the color-mapping option move the mouse over the section or iso-
surface plot that you want to modify and click the right mouse button to bring up the data plot popup 
menu. Selecting Color Mapping allows you to change the color mapping interactively. For non-linear 
color-mappings move the Median trackbar to the Z-value which is to receive the highest color-
resolution and increase the non-linearity using the Nonlinearity trackbar. Press the Linear Mapping 
button to restore a linear color mapping. Note that in addition to changing the value->color mapping 
function, you can also load different color palettes. 

 

                                                           
# IDH_ODV_CHCMAP 
$ Changing the Color Mapping Function 
+ auto 
K changing the color mapping function; median; non-linear color mapping; configuration 
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# $ + K Displaying Gridded Fields 
 
Instead of showing colored dots at the sample positions you can also produce gridded property fields 
for any window that has a Z-variable (property distributions along sections and on iso-surfaces are 
examples) using either of two gridding algorithms: Quick Gridding and VG Gridding. Quick Gridding is 
a fast method that yields good results in cases of good data coverage, however, for poor or inhomo-
geneous data coverage VG Gridding is preferable  (see below). Contouring of the property fields in 
addition to color shading is supported for both gridding modes. 

To switch from “Original Data Points” mode to one of the gridding modes  move the mouse over the 
data plot that you want to modify and invoke the data-plot popup menu by clicking the right mouse 
button. Choose Display Options, then check either the Quick Gridding or and VG Gridding button and 
set appropriate averaging length-scales for the X- and Y-axis, respectively. Note that values represent 
per mille of full axis range and that large values result in smooth fields. Also note that you can specify 
contour lines for the property field and set other properties by pressing the Properties button. If you 
want to modify the display options for individual plots, make sure the Apply to all Windows box is not 
checked. Consider exporting the section or iso-surface data and using dedicated gridding and contour-
ing software if you are not satisfied ODV output. 

 

VG Gridding Algorithm 
 

In contrast to Quick Gridding that uses an equidistant, rectangular grid, VG Gridding analyzes the 
distribution of the data points and constructs a variable resolution, rectangular grid, where grid-spacing 
along X and Y directions varies according to data density. High resolution (small grid-spacing) is pro-
vided in regions with good data coverage, whereas in areas of sparse sampling the grid is coarse and 
resolution is limited. For typical hydrographic sections, for instance, this procedure leads to higher 
spatial resolution in the upper water column and in boundary current regions (data coverage is usually 
very good in these areas) as compared to the deep, open ocean regions. 

After construction of the grid, the property under consideration (temperature, salinity, etc.) is estimated 
at every grid point by applying a weighted-average scheme using data values from a neighborhood of 
the grid-point. Weights decrease with increasing distance from the grid-point, and separate (e-folding) 
length-scales in X and Y directions specified by the user are applied. The user-provided X and Y 
length-scales are measured in “per-mille” of the respective axis range and are representative for the 
area of poorest data coverage (coarsest grid). Averaging length-scales are proportional to grid-
spacing, e.g., in areas of higher grid-resolution (upper water column, boundary currents, etc.) smaller 
averaging length-scales are used automatically.  This overall approach allows to resolve small-scale 
features in areas of dense data coverage and at the same time provides smooth and stable fields in 
other regions where observations might be sparse. Special methods are implemented that increase 
execution speed and allows field estimations within a few seconds even for thousands of data points. 

As a final step, the estimated field values are passed to shading and contouring routines for display of 
the results on the screen or on a printer. 

                                                           
# IDH_ODV_PLOTGRIDDED 
$ Displaying Gridded Fields 
+ auto 
K gridded fields; contouring; configuration 
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# $ + K Difference Fields 
 
You can compare property distributions of the currently selected stations with previously saved refer-
ence data and produce difference fields by defining property differences as derived variables. Choose 
Derived Variables from ODV’s background menu (or press Alt+D) and select Diff. from Ref. Choose 
the ExportID.txt file of the reference data that you want to use in one of the subdirectories of 
Temp\Reference. ODV will show a list of available reference data files from that directory. Select an 
.oal file that has the variable for which you want to produce the difference field as Z variable and ap-
propriate X and Y variables (e.g., for producing longitude vs. depth sections, make sure the reference 
data file has longitude as X and depth as Y variable). Now identify the Z, X and Y variables in the cur-
rent collection (if longitude or latitude are required, define them as derived variables prior to invoking 
Diff. from Ref.) to complete the definition of the difference variable. Note that the name of the new 
variable is composed of  the name of the Z variable and the identification string of the reference data 
set. Once defined, you can use the difference variable in any data plot. 

                                                           
# IDH_COMPAREWITHREF 
$ Difference Fields  
+ auto 
K difference fields; reference data 
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# $ + K Defining Iso-Surfaces 
 
When you switch to SURFACE mode (by selecting SURFACE Mode from the background popup 
menu) or when you choose Iso-Surface Variables from the background popup menu ODV shows a list 
of currently defined iso-surface variables and lets you edit and delete existing or create new ones. To 
delete an existing iso-surface variable double-click on it with the left mouse or select it using a single 
left mouse click and press Delete. To add a new iso-surface variable first construct it inside the New 
box and then press Add. Constructing an iso-surface variable requires that you specify the variable 
that you want to display on a given surface (display variable), the variable that defines the surface 
(surface variable) and a numeric value for the surface variable. For top or bottom property distributions 
choose Depth as surface variable and enter top or bottom instead of a numeric value (a t or b as first 
character is sufficient). If you want to use derived variables as display or surface variables, make sure 
that they are defined (see: Derived Quantities) before you invoke the Iso-Surface Variables dialog. 

If an iso-surface variable is selected in the Already Defined box you can synchronize all other vari-
ables to use the same surface by clicking on the S-Sync button (surface synchronization). You can 
synchronize all other variables to use the same display variable by clicking on the V-Sync button (vari-
able synchronization). 

                                                           
# IDH_ODV_DEFSURF 
$ Defining Iso-Surfaces 
+ auto 
K defining iso-surfaces; iso-surface variables; SURFACE mode; surface variable 
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# $ + K Plotting Surface Distributions 
 
Once you have defined iso-surface variables you can plot color property distributions on the iso-
surfaces as well as iso-surface property/property plots using all stations marked in the map by double-
clicking the left mouse button while over the map or by pressing p. Color plots are obtained for Longi-
tude and Latitude on X- and Y-axis, respectively. For all other constellations you get property/ property 
plots. Note that in addition to the iso-surface variables that you define explicitly, additional parameters 
like time, day-of-the-year, longitude and latitude are recorded for every station and can be used in the 
property/ property plots. 

 

See also: zooming and auto-scaling; Color-Zooming; Changing the Color Mapping Function; selecting 
new X, Y-and Z-variables; changing display options; displaying gridded fields; exporting plot 
values;printing; PostScript file. 

 

                                                           
# IDH_ODV_PLOTSURF 
$ Plotting Surface Distributions 
+ auto 
K plotting surface distributions 



 57

# $ + K netCDF Overview 
 
NetCDF (network Common Data Form) is an interface for array-oriented data storage and access, 
which is widely used in climate research and other fields of geo-sciences. Many important datasets 
and model output files are distributed and shared among scientists in netCDF format. 

NetCDF data is: 

Self-Describing. A netCDF file includes information about the data it contains.  

Architecture-independent. A netCDF file is represented in a form that can be accessed by computers 
with different ways of storing integers, characters, and floating-point numbers.  

Direct-access. A small subset of a large dataset may be accessed efficiently, without first reading 
through all the preceding data.  

Appendable. Data can be appended to a netCDF dataset along one dimension without copying the 
dataset or redefining its structure. The structure of a netCDF dataset can be changed, though this 
sometimes causes the dataset to be copied.  

Sharable. One writer and multiple readers may simultaneously access the same netCDF file.  

 

NetCDF conventions: 

The netCDF data model is very general and the structure and contents of netCDF files can vary con-
siderably. In order to facilitate and promote the interchange and sharing of netCDF datasets a number 
of conventions have been defined. Two of these conventions (COARDS and GDT; for specifications 
see netCDF web page given below) are widely used by climate researchers and modelers, and a large 
number of important datasets are available as COARDS/GDT netCDF files. Such datasets are avail-
able for download at, for instance, http://www.cdc.noaa.gov/PublicData/, http://ferret.wrc.noaa.gov/, 
http://ingrid.ldeo.columbia.edu/, and http://www.epic.noaa.gov/epic/ewb/. 
 

For more information on netCDF visit the netCDF web page 
http://www.unidata.ucar.edu/packages/netcdf/. 

 

ODV netCDF support: 

ODV can read and visualize the data in a netCDF file as if it was an ODV collection. The full suite of 
ODV capabilities are available when working with netCDF files. Exceptions are those functions that 
require write permission to the netCDF file and would modify the dataset (ODV will not write to a 
netCDF file). If the netCDF file follows the COARDS and GDT netCDF conventions, ODV will be able 
to interprete a large variety of variables like, for instance, absolute and relative time formats and it can 
identify attributes of variables such as missing value indicators, long variable names, units and others. 
ODV allows subsetting of the data which is often required when working with very large datasets.  

                                                           
# IDH_NETCDFOVERVIEW 
$ netCDF Overview 
+ auto 
K netCDF overview 
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# $ + K Using netCDF Files 
 
ODV can read and display data in netCDF files, widely used by researchers in different fields of geo-
sciences. Using few user specifications and selections, ODV accesses and interprets a given netCDF 
file in a way that mimics (emulates) a native ODV collection. The full suite of ODV’s analysis and visu-
alization capabilities is provided for the exploration of the data in the netCDF file, and there is no need 
to translate and re-write the data first. Depending on the structure and contents of a netCDF file, dif-
ferent ODV “emulations” are possible. Settings of individual emulations can be saved on disk for later 
use. Note that netCDF files are platform independent, and the same file can be used with ODV on 
Windows or Solaris platforms. 

 

(1) Opening a netCDF file 

You open a netCDF file with ODV by choosing File>Open netCDF File. Use the standard Windows file 
selection dialog to identify the file that you want to open. Alternatively you can start ODV from the 
command line and specify a netCDF file name as a command line argument. On Windows, you can 
also drag a netCDF file on the ODV desktop icon. In all cases the extension of the netCDF file must be 
either .nc or .cdf. ODV opens the netCDF file and retrieves information on dimensions and variables 
contained in the file. 

 

(2) Defining the netCDF emulation 

In a sequence of steps you must now define how ODV should view (or emulate) the netCDF file. This 
involves selection and subsetting (if required) of coordinate axis (dimensions), association of ODV 
header variables with information from the netCDF file and the definition of the primary variable (first 
variable in an ODV collection) that determines the logical structure of a “station” (e.g., profile, time 
sequence, etc.) and is used for sorting within a station. 

ODV first asks whether a new emulation is to be defined or whether a previously defined and saved 
emulation should be used. If you choose a previously defined emulation, no additional input is required 
and ODV proceeds as if it was using a native ODV collection: it draws a station map and offers the full 
suite of ODV analysis and display capabilities. Note that ODV will not modify an open netCDF file and 
treats it as a read-only dataset. As a consequence, all ODV functions that require data-write opera-
tions (data import, header and data editing, collection manipulation operations, etc.) are disabled when 
working with netCDF files. 

 

(2.a) Subsetting and selecting netCDF coordinates 

If you define a new emulation, the first step is to subset and select netCDF coordinates. ODV will show 
a list of dimensions/coordinates contained in the file together with their lengths and the currently used 
index set (shown in the Dimensions list; note that indices start at 0 and index sets are defined by start 
index:stride:end index; the default initial index set is all indices).  

Subsetting 

For practicality reasons especially for very large netCDF dataset it is often necessary to restrict 
data access to the region, depth range and time interval of interest and to exclude the rest from 
the analysis. Imagine, for instance, the file contains data for many months, but you are interested 
only in a few or a single month; or the file contains many depth levels, but you only want to ana-
lyze a specific depth. In all these cases you should subset the respective dimension or coordi-
nate.  

To subset a particular dimension/coordinate select it in the Dimensions list (it must be the only se-
lection in the list) and press the Subset Dimension button. ODV shows a list of all coordinate val-
ues and lets you specify the start index, stride, and end index of the index set to be used. To se-
lect a single index enter the (same) index value in the Start Index and End Index fields. Press OK 
to accept the new index set. Repeat this procedure for all dimensions/coordinates that you want 

                                                           
# IDH_USENETCDFFILES 
$ Using netCDF Files 
+ auto 
K opening netCDF Files; emulating netCDF Files 
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to subset. 

Selection 

Then you must select all the dimensions/coordinates that you want to use for subsequent analy-
sis of associated variables. Apply multiple selections using the standard Windows selection tech-
niques(holding down Crtl or Shft keys while clicking the left mouse button). If there are multiple 
dimensions available for the common coordinates X (Longitude), Y (Latitude), Z (Depth/Height), 
and T (Time), make sure that you select only one for each direction.  

For a given selection of dimensions, the set of netCDF variables that are defined on the selected 
dimensions is shown in the Corresponding Variables list. Make sure that the variables that you 
are interested in are shown in this list. Other variables in the netCDF file that depend on coordi-
nates not selected in the Dimensions list are not shown as Corresponding Variables and those 
variables are unavailable unless you select the corresponding dimensions. To view the complete 
header information of the netCDF file (similar to a “ncdump –h” call) press View netCDF File Info. 

 

(2.b) Specifying header information 

In a second step you must identify the netCDF variables that provide header information for the ODV 
stations: e.g., longitude (Lon (°E)), latitude (Lat (°N)), date (mon/day/yr), etc. This is done by establish-
ing associations (1-to-1 or on-the-fly conversions) between variables from the netCDF file (Source File 
list) and the standard ODV header variables (Target Collection list).To establish a (1-to-1) association 
between a netCDF variable and an ODV header variable select the netCDF variable in the Source File 
list and the header variable in the Target Collection list and press Associate. To establish a conversion 
between a netCDF and ODV header variable (usually needed for netCDF time variables), select the 
two variables as above and then press Convert. Choose one of the available conversion procedures 
from the combo-box and press OK. For the General Linear Transformation provide scale factor and 
offset. 

Many netCDF files use relative times as days or hours since a specific start date. You can exploit this 
information to obtain date and time of a station: select the relative time in the Source File list and 
mon/day/yr in the Target Collection list and press Convert. Then choose the appropriate conversion 
algorithm. Note that ODV assumes that the reference date is based on the Gregorian calendar. ODV 
mon/day/yr values are Gregorian dates. 

Note that the header variables Station and Type are set automatically by ODV. For header variables 
not associated with any netCDF variable, ODV uses default settings. You can modify the default value 
for a header variable (e.g., Cruise, etc.) by selecting it in the Target Collection list and pressing Set 
Default. 

 

(2.c) Selecting primary coordinate 

Finally you have to select the primary coordinate which is subsequently used by ODV as first collection 
variable which is also used as sorting variable within a station. This is an important specification as it 
determines the logical structure of an ODV station. If, for instance, you use “Depth” or any other verti-
cal coordinate, the stations represent vertical profiles; if you use Time, the stations represent se-
quences in time. If the mon/day/yr header variable was defined in step 2.b above, the Use Decimal 
Date/Time button is enabled and you can use a decimal time variable (units=YEARS) derived from the 
station header as primary coordinate. 

If the data in the netCDF file represent values on horizontal surfaces (e.g., fluxes across the air-sea 
interface, etc.) and there is no netCDF variable that explicitly specifies the respective surface (no verti-
cal coordinate) press the Use Dummy Variable button and specify the label and units of the dummy 
variable (e.g., Depth [m]) and the associated numerical value that defines the surface (e.g., 0 for 
ocean surface). 

 

(3) Exploring the netCDF file 

After completing steps 2.a through 2.c ODV has sufficient information to access the netCDF data in 
the user requested way. ODV will draw a station map and then offers the full suite of ODV analysis 
and display capabilities. Note that ODV will not modify an open netCDF file and treats it as a read-only 
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dataset. As a consequence, all ODV functions that require data-write operations (data import, header 
and data editing, collection manipulation operations, etc.) are disabled when working with netCDF 
files.  

Also note that data access from netCDF files is slower as compared with native ODV collections. If 
you are using large netCDF datasets with tens of thousands of (emulated) stations and you are ex-
periencing slow buildup of SCATTER or SURFACE plots, you should consider subsetting (see above) 
or export the netCDF data to a native ODV collection using Export>ODV Collection and then use the 
newly created collection for analysis and visualization. 

In order to produce vertical sections you should switch to SECTION mode, for instance, by choosing 
Configuration>UseTemplate>SECTION 2 Win and then define sections of your choice using Define 
Section>Define Section Spine from the map popup menu. To create property distributions on horizon-
tal surfaces or other longitude/latitude isosurfaces switch to SURFACE mode, for instance, by choos-
ing Configuration>UseTemplate>SURFACE 1 Win. Then define isosurface variables through Configu-
ration>Iso-Surface Variables and use them as Z-variables on the plot windows. 
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# $ + K Changing the Set of Collection Variables  
 
In situations when new data become available for variables that are not already included in a given 
data collection, you might want to add these variables to the collection. Also, sometimes you might 
want to delete some of the existing variables from a collection.  

To add and/or delete collection variables open the collection and choose Collection>Add/Delete Vari-
ables from the main menu. Add a new variable by entering the variable label (including units enclosed 
by brackets [ ]) in the “New Variable” control and press Add. You delete a variable by selecting it in the 
“Defined Variables” list and pressing Delete. You can change the order of the variables by choosing 
one and moving it Up or Down. Press OK when you are done. Note that the entire collection has to be 
re-written which might take some time for large data collections. 

                                                           
# IDH_ODVADDVARS 
$ Changing the set of variables 
+ auto 
K adding/deleting variables in a collection 
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# $ + K Sorting and Condensing a Collection 
 
The station search and selection algorithms of ODV work most efficiently if the stations in a collection 
are ordered in a specific way. Therefore, it is recommend that you sort and condense your collections 
after importing, replacing, merging or deleting large numbers of stations. You invoke the sort and con-
dense procedure by choosing Collection->Sort and Condense from ODV’s main menu. 

                                                           
# IDH_SORTCONDENSE 
$ Sorting and Condensing a Collection 
+ auto 
K sorting and condensing a collection 
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# $ + K Deleting Selected Station-Subset 
 
You can delete the currently selected stations from the collection by choosing Collection->Delete Sta-
tion Subset from ODV’s main menu. To delete the current station only, choose Collection ->Delete 
Current Station. Note that the data-space of the deleted stations in the collection disk files is not freed 
until you sort and condense the collection. 
 

                                                           
# IDH_DELETESUBSET 
$ Deleting Selected Station-Subset 
+ auto 
K deleting selected station-subset 



 64

# $ + K Data Inventory Tables 
 
You can produce an inventory table of the currently open collection by choosing Utilities->Inventory 
Table from ODV’s main menu. The output file is plain ASCII and is written to the collection directory 
(extension .inv). 

 

                                                           
# IDH_INVTABLE 
$ Data Inventory Tables 
+ auto 
K data inventory tables 
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# $ + K Temporal Data Distribution Plots 
 
You can produce plots of the temporal distribution of the currently selected stations (by months and 
years) by choosing Utilities->Temporal Distribution from ODV’s main menu.  

 

                                                           
# IDH_TEMPDISTR 
$ Temporal Data Distribution Plots 
+ auto 
K temporal data distribution plots 
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# $ + K Data Retrieval for Lon/Lat/Depth Boxes 
 
ODV can calculate and export average values and standard deviations for selected variables using all 
original data points within given boxes defined by Lon/Lat/Depth intervals. Note that for the retrieval 
only those stations are used that satisfy the current selection criteria and are show in the map. You 
can obtain averages for different years, months, seasons etc. by applying appropriate station selection 
criteria prior to invoking the retrieval. To select the data retrieval option choose Utilities->Data Re-
trieval from ODV’s main menu. ODV will prompt you for a retrieval input file (extension .rtv) containing 
geometry information for the boxes and the variable numbers for which output is to be produced. The 
.rtv file has to be prepared prior to invoking the retrieval option.  

The format of the .rtv file is as follows: 

• plain ASCII, one box/variable definition per line, 7 numbers separated by (one or more) spaces, 

• meaning of numbers: lon lat dep (box center) dlon dlat ddep variable#. 

Once you have specified a .rtv file, ODV will start working. Note that while averaging, ODV will check 
for data outliers and will use only data within 3 standard deviations of the mean. The output will be 
written to a file with the same name as the .rtv file and extension .out. 

The format of the .out output file is as follows: 

• plain ASCII, one line of output per line in the .rtv file, 11 values separated by TABS, 

• meaning of values: lon lat dep variable# (same as in .rtv) alon alat adep aval +- sdev nu nr. 

alon, alat, adep, aval are average Longitude, Latitude, Depth and variable values of the data used, 
sdev is the standard-deviation of the individual variable values, nu is the number of data points used 
and nr is the number of data points rejected. Note that for each box retrieval all individual data values 
are exported to ASCII files ODVrtv?.dat in ODV’s temporary files directory (normally: c:\Program 
Files\Ocean Data View\Temp). In the .dat files the meaning of values is as follows: # lon lat dep day-
of-year value weight used/rejected-flag. 

 

                                                           
# IDH_DATARETRIEVAL 
$ Data Retrieval for Lon/Lat/Depth Boxes 
+ auto 
K data retrieval; retrieval 
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# $ + K Geostrophic Velocity Sections 
 
In SECTION mode, ODV lets you calculate and visualize geostrophic velocities via the Utilities-
>Geostrophic Flows option. Define a reference layer by choosing a depth horizon or an iso-level of 
any other basic or derived variable (i.e., potential density, etc.) and specify the name of the .o4x output 
file that receives the results. Note that by default this file is written to subdirectory ‘GeoVel’ of the col-
lection directory (this subdirectory is created automatically if not already present). ODV will start the 
calculations and export the station-pair results and geostrophic velocities to the .o4x file specified 
above.  
 
Once completed, ODV allows you to invoke a new ODV session on the newly calculated section pair 
and velocity data. If you click on ‘Yes’, the new ODV will create a new collection in the GeoVel direc-
tory and will automatically import the .o4x file just written. Using standard ODV procedures, you should 
then define an appropriate map domain by zooming into the map, you should switch to SECTION 
mode by pressing F11, and you should define Geostr. Vel. [cm/s], Geostr. Vel. (north comp.) [cm/s] 
and/or Geostr. Vel. (east comp.) [cm/s] as Z-variable of one or more plot windows. The station label of 
a given station-pair A->B:alpha consists of the original station numbers A and B of the stations used in 
the pair and the direction alpha of flow for positive values of Geostr. Vel. [cm/s]  (alpha=0: eastward; 
alpha=90: northward; etc.). 
 
Geostrophic velocities are derived from dynamic height differences between two hydrographic sta-
tions. Because, in general, the observed depths for the two stations do not match, in a first step the 
measurements have to be mapped to a set of common depths (ODV uses piecewise linear least 
squares for the interpolation on a predefined set of standard depths). Then dynamic heights at the 
standard depths are calculated for both stations, and the geostrophic velocities for the station pair (at 
the standard depths) are obtained from the dynamic height differences. ODV also calculates average 
values for all variables in the collection (pair-averages). Both, the pair-averages and the geostrophic 
velocities are representative for the mid-point between the two stations involved, and ODV writes 
those values to the output .o4x file for a “virtual” pair station located at the mid-point between the two 
stations in the pair (note the station label of the pair station contains the station labels of the original 
stations involved). 
  
Note that geostrophic velocities are not calculated close to the Equator or for stations with sparse hy-
drographic observations. Because results are very sensitive to data errors, you should quality control 
the temperature and salinity data of the section carefully prior to invoking the Utilities->Geostrophic 
Flows option. One way to proceed is to flag suspicious data as ”Questionable” or ”Bad” using the Edit 
Data option and to accept only ”Good” data for display and calculation (by applying appropriate selec-
tion criteria). Also by applying appropriate station selection criteria, you should make sure that only 
stations for a given expedition are included in the calculations and that stations from other cruises 
inside the section-band are excluded (watch out for other oceanographic lines crossing the section-
band). 

                                                           
# IDH_GEOSTRFLOWS 
$ Geostrophic Velocity Sections 
+ auto 
K geostrophic velocity; velocities 
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# $ + K Defining Reference Datasets 
 
You can save the original data of the current plot windows in ASCII disk files and use these data later 
as reference datasets by choosing Utilities->Define as Reference from ODV’s main menu. When 
prompted for, enter a descriptive text identifying the reference data (txtID) and click OK. ODV will cre-
ate a sub-directory in the ODV temporary-files directory (normally c:\Program Files\Ocean Data 
View\Temp) named Reference\txtID and writes all files to this directory. If it already exists, ODV asks 
for your permission to delete all files from the directory before continuing. Reference data are used by 
ODV when you define difference variables. 

                                                           
# IDH_DEFASREFERENCE 
$ Defining Reference Datasets 
+ auto 
K reference data 
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# $ + K Finding Outliers 
 
You can scan the currently selected stations for samples with data values outside a specified range by 
choosing Utilities->Find Outliers. Select a scan-variable from the list of variables and enter the minimal 
and maximal accepted range values. Press OK to start the scan. ODV will report the number of out-
liers found and lets you view the list of outliers and lets you inspect and modify the outlier data values 
or quality flags. 

If you check Inspect and Edit Outliers, ODV will visit all identified outliers and allows you to delete the 
respective value or to mark it as “Questionable” or “Bad”. If you press Aplly to All, ODV applies the 
selected to all outliers, otherwise the user is prompted for an action for each individual outlier. Note 
that the respective outlier is marked in the data plots. 

                                                           
# IDH_FINDOUTLIERS 
$ Finding Outliers 
+ auto 
K outliers 
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# $ + K Finding Redundant Stations 
 
You can scan a collection for stations with identical or nearly identical positions and times of occupa-
tion (redundant stations) by choosing Utilities->Find Redundant Stations. The list of redundant stations 
is written to disk (default name redundant.lst). In the redundant.lst file, blank lines separate sets of 
redundant stations. For each station the following information is given: (1) internal no., (2) cruise label, 
(3) station label, (4) station type, (5) date, (6) longitude, (7) latitude,  (8) no. of observed levels, (9) 
deepest level, (10) availability indicators for basic variables 2...nvar (e.g., 7 means that between 70 
and 79% of the observed levels contain data for a given variable).To delete a redundant station, make 
it the current station using Select Station by Name from the map popup menu and then delete it using 
Actions->Delete Current Station. 

Note that for large collections, the redundant stations scan is a lengthy procedure. 

                                                           
# IDH_FINDREDUNDANT 
$ Finding Redundant Stations 
+ auto 
K redundant stations 
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# $ + KOverview – Graphics Objects 
 
You can improve ODV graphics output and give it a finishing, professional touch by adding text, high-
lighting data points and adding lines or other geometric objects. ODV graphics objects include (1) text 
annotations, (2) straight lines, (3) rectangles and squares, (4) ellipses and circles, (5) polylines 
(straight-line segments or Bezier smoothed), (6) filled polygons(straight-line segments or Bezier 
smoothed), (7) symbols, (8) symbol sets and (9) legends. 

 
Creation 
Except for legends, which are created automatically, you create and add any other graphics object by 
choosing Extras->Add Graphics Object->... (where ”...” represents the desired object type) from the 
map or data plot popup menus or by choosing Add Graphics Object->... from the background popup 
menu. After creation, dialog boxes are presented that let you define various properties of the object. 
These properties can be changed (see ”Edit” below) at any time. A graphics object is owned by the 
window (or background area) from which the creation was initiated, and the coordinates of the graph-
ics object are recorded in the respective window coordinate system. As a consequence, all objects of 
a window follow automatically when the respective window is moved or resized. 
 

Edit and Delete 
The properties of a given object can be modified by moving the mouse over it (for symbol sets move 
the mouse over one of the symbols), clicking the right mouse button and choosing Edit Object from the 
popup menu. Dialog boxes (different for the different objects) appear and let you change properties 
easily and quickly. Any graphics object may be clipped to its parent window (check the ”clip to window” 
box), and you may request that it is drawn before the data of the window are drawn (check the ”pre-
data plot” box).You delete an object by moving the mouse over it, clicking the right mouse button and 
choosing Delete Object. 
 

Dragging 
If the attribute ”allow dragging” of a graphics object is set, the object can be re-positioned by simply 
dragging it to a different location. To drag an object, move the mouse over it, click and hold down the 
left mouse button and move the mouse. By default, dragging is switched on initially for all graphics 
objects except symbol sets which are linked to data values. You can change the ” allow dragging” 
attribute at any time using the Edit dialogs (see above). 

                                                           
# IDH_GOOVERVIEW 
$ Overview – Graphics Objects 
+ auto 
K graphics objects; lines; rectangles; circles; polylines; polygons 
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# $ + K Annotations 
 
You can add annotations to the ODV graphics window by choosing (Extras->)Add Graphics Object-
>Annotation from the background, map or data plot popup menus. A cross-hair cursor will appear, and 
you should move it to the location where the annotation should appear and then click the left mouse 
button. Note that the window from which the creation was initiated owns the respective object. When 
adding (or editing) annotations you may set the position, orientation (degrees, counter-clockwise), font 
size (pt), color and alignment parameter of the annotation text. Annotations can have a frame, and the 
annotation rectangle can be filled before drawing the annotation. You can choose different colors for 
all these items. Maximum length of the annotation text is 255 characters. For special text effects, you 
can use the following control sequences within the text:  

~$ switch to Symbol font (Greek symbols) 
~# switch to normal text font 
~~ produce ˜ character 
~s produce ß character 
~" next character as Umlaut' 
~^ next character as superscript 
~_ next character as subscript. 

 

Like all other graphics objects, you can drag an annotation to a different position by moving the mouse 
cursor over it, pressing and holding down the left mouse button and moving the mouse. You can edit 
an annotation by moving the mouse over it, clicking the right mouse button and choosing Edit Object 
from the popup menu. To delete an annotation (all annotations) choose Delete Object (Delete All Ob-
jects) from its popup menu. 

Note that the axis labels of the data plot windows are implemented as (automatic) annotations. They 
are created automatically when the plot window is drawn and they are deleted when the respective 
data plot window is deleted. You can drag, edit or delete axis labels, but please note that the auto-
matic versions re-appear if the plot window is redrawn. If you want to change an axis label ”perma-
nently” you should create an annotation manually by choosing Extras->Add Graphics Object-
>Annotation from the background popup menu. Make sure that you save the configuration after defin-
ing the new annotation and delete the automatic axis annotation before printing or writing PostScript 
files. 

                                                           
# IDH_ANNOTATIONS 
$ Annotations 
+ auto 
K annotations 
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# $ + K Lines and Polygons 
 
You add straight lines, polylines and polygons to the map, data plots or background by choosing (Ex-
tras->)Add Graphics Object->Line, ...->Polyline or ...->Polygon from the map, data plot or background 
popup menus. In all three cases the cursor changes to a cross hair and you should proceed by speci-
fying the nodes of the object. For a ”Line” you must define starting- and endpoint: move the cross-hair 
to the start of the line and click the left mouse button, then move to the end-point and click the left 
button again. For Polyline or Polygon you may define up 1000 points. Note that polygons are closed 
automatically by ODV. If you want to delete a point, move the cross hair close to it and click the right 
mouse button. You end the definition of polygon or polyline points by pressing ENTER. 
 
Once you have specified the nodes of the line, polyline or polygon, ODV presents a dialog box that 
lets you define color, width and type of the (poly)line and the fill-color of the polygon (ignored for Line 
and Polyline; choose ”none” as fill-color to avoid filling of the polygon). Also note that lines wider than 
1 pixel are always solid on many screen and printer devices. However, the requested line-type is al-
ways honored in ODV PostScript files. Polylines and polygons may be smoothed by checking the 
”Bezier smoothing” box. 
 

                                                           
# IDH_LINESPOLYGONS 
$ Lines and Polygons 
+ auto 
K lines; polygons  
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# $ + K Rectangles and Ellipses 
 
You add rectangles (squares) and ellipses (circles) to the map, data plots or background by choosing 
(Extras->)Add Graphics Object->Rectangle, or ...->Ellipse from the map, data plot or background 
popup menus. A red zoom rectangle will appear that represents the bounding box of the new rectan-
gle or ellipse. The zoom rectangle can be moved and resized, press ENTER to accept a setting. A 
dialog box appears that lets you define properties of the rectangle or ellipse (for details see Lines and 
Polygons). 
 

                                                           
# IDH_RECTCIRCLES 
$ Rectangles and Ellipses 
+ auto 
K rectangles; ellipses 
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# $ + K Symbols 
 
You add symbols (dots, squares, diamonds, triangles, inverted triangles, stars, crosses, pluses) to the 
map, data plots or background by choosing (Extras->)Add Graphics Object->Symbol from the map, 
data plot or background popup menus. A cross-hair cursor will appear, and you should move it to the 
location where the symbol should appear. Then click the left mouse button. The “Symbol Properties” 
dialog box appears and lets you set various symbol properties.  
 

                                                           
# IDH_ SINGLESYMBOLS 
$ Symbols 
+ auto 
K symbols 
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# $ + K Symbol Sets and Legends 
 
You can highlight a subset of the data points in a plot window or a subset of stations in the map by 
assigning a symbol to the selected data points (symbol-set). To create a symbol-set for a data window 
or the map, move the mouse over this window and choose Extras->Add Graphics Object->Symbol 
Set. The symbol set selection dialog box appears and lets you select the subset of data points (specify 
cruise labels, stations and/or individual samples). Press the <- button to add the points to the list of 
selections. Press OK once all desired points are selected. Then the symbol set properties dialog box 
appears which lets you define the symbol characteristics. A symbol set can have a descriptive text 
(legend), which will automatically be added to the legends of the respective window (check the add to 
legends box). Unlike other graphics objects, symbol sets cannot be dragged because they are associ-
ated with the selected data points. You can change all properties of a symbol set at any time by mov-
ing the mouse over any one of its symbols, clicking the right mouse button and choosing Edit Graphics 
Object. 
If a data window or the map contain symbol sets with the add to legends option switched on, a legend 
box containing the symbol and legend text of all symbol sets for this window appears. Legend sets can 
be dragged to different locations and their properties (the size of the legend box is modified by chang-
ing the font size for the legend text) can be modified at any time (move mouse over legend set, click 
right mouse button and choose Edit Graphics Object). 
 

                                                           
# IDH_SYMBOLSETSLEGENDS 
$ Symbol Sets and Legends 
+ auto 
K symbol sets; legends 
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# $ + K Gazetteer of Undersea Features 
 
ODV can be used to identify undersea features like seamounts, ridges, fracture zones, troughs, ba-
sins, etc. To invoke the gazetteer option, choose Extras->Gazetteer from the map popup menu (or 
press Ctrl-g while the mouse is over the map). The gazetteer dialog box is shown and lets you select a 
specific database, lets you specify feature selection criteria as well as size and color of the gazetteer 
marks drawn by ODV. To switch on the gazetteer option, make sure to check the Show Gazetteer 
Feature box (to switch gazetteer features back off, uncheck this box). A list of undersea features from 
the selected gazetteer database is loaded, and the feature positions are marked in the map. Moving 
the mouse close to a feature point invokes a popup window displaying the name of the feature.  

Three gazetteer files are provided with the ODV distribution: (1) GazetteerGEBCO.gzt from the Int. 
Hydrogr. Bureau (IHB), (2) GazetteerBGN.gzt from the US Defense Mapping Agency, and (3) 
WHP_Sections.gzt, which is a compilation of the sections occupied during the WOCE Hydrographic 
Programme. GazetteerGEBCO.gzt is the default gazetteer file, but you can switch to other .gzt files 
using the gazetteer dialog box (press Ctrl-g while over the map). You can produce feature subsets by 
specifying a feature type and/or feature name sub string again using the gazetteer dialog box. The 
name and type selections are case-insensitive. Use the gazetteer feature selection if you know the 
name of a feature (or part of the name) and want to identify its location (note that you might have to 
open the map to global extent in order to see the feature mark). Gazetteer settings are not saved in 
configuration files. Whenever you open a collection, the gazetteer option is switched off initially and 
you have to switch it on in order to use it. 

Gazetteer files can be edited and extended. You can also create your own, new gazetteer databases. 
In order to use a private gazetteer with ODV, the file must have the extension .gzt, it must be located 
in the ODV gazetteer directory (normally: c:\Program Files\Ocean Data View\Include\Gazetteers) and 
its format must satisfy the specifications below: 

The first line of the file must start with % GZT01: followed by the name of the file.  

Then there are 7 lines starting with % and containing arbitrary comments.  

The next line must be: Feature;Type;No;East-Longitude;North-Latitude; there has to 
be  one blank line following.  

The rest of the file contains the actual item definitions. Each feature is listed on a separate line. 

The name of the feature, its type, the number of lon/lat points and the longitude/latitude entries are 
separated by semicolons ”;”. Longitude is specified in degrees East (0-360). The number of lon/lat 
points can be up to 1500, and the length of a line may be up to 200kB. 

 

                                                           
# IDH_GAZETTEER 
$ Gazetteer of Undersea Features 
+ auto 
K gazetteer; undersea features 
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# $ + K Drag-and-Drop 
 
WIN32: 

You can drag and drop files on the ODV window or icon. Depending on the extension of the dropped 
file, ODV will perform the following actions: 

.var: close current collection and open dropped one. 
 
.o4x: import data from dropped file into currently open collection (if no collection is open when the 

file is dropped, ODV creates a new collection in the directory of the dropped file and imports 
the data into the newly created collection). 

 
.ol: import data from dropped file (WOA94) into currently open collection (if no collection is open 

when the file is dropped, ODV creates a new collection in the directory of the dropped file and 
imports the data into the newly created collection). 

 
.sum: interpret file as WOCE station header file, inquire name of associated WOCE data file (bottle 

data) and import data into currently open collection (if no collection is open when the file is 
dropped, ODV creates a new collection using WOCE default variables in the directory of the 
dropped file and imports the data into the newly created collection). NOTE: If you want to im-
port WOCE CTD data you have to use Import->WOCE CTD Data from the main menu to initi-
ate the import procedure. 

 
.txt: import data from dropped file (assuming TAB separated ODV SpreadSheet text file) into cur-

rently open collection (if no collection is open when the file is dropped, ODV creates a new 
collection in the directory of the dropped file and imports the data into the newly created col-
lection). 

 
UNIX: 

Drag-and-drop is currently not implemented under UNIX. However, by using appropriate file names as 
command line arguments, you can obtain similar results. Start ODV from any Terminal window by 
typing: odv  [file name[.extension]]. Note that for file name you either use absolute 
pathnames or pathnames relative to the directory from which you start ODV. If you use a relative 
pathname, “.” and “..” are not allowed. You can use command line arguments to … 

1. … start ODV and open an existing collection: use the collection name for file name. If 
you omit an extension, the default .var is used. 

2. … create a new collection and import data: use the name of the data file (must be one of 
ODV’s import types, e.g., .o4x, .txt, .sum, .ol) to be imported for file name. In this case you 
must provide the extension. ODV will create a new collection in the directory of the import 
file and will import the data from the file. The collection variables are determined from informa-
tion in the data file. 

                                                           
# IDH_DRAGANDDROP 
$ Drag-and-Drop 
+ auto 
K drag-and-drop 
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# $ + K Defining Patches 
 
You can define water-mass patches by specifying polygons in the X/Y space of any data plot currently 
displayed on the screen. To do so, move the mouse over the data plot that you want to use for defini-
tion (e.g., theta/S plot) and click the right mouse button. From the popup menu choose Define Patch 
(note that the cursor changes to a cross-hair) and define the nodes of the patch-polygon by clicking 
the left mouse button at the node positions (you delete points by moving the mouse close to them and 
clicking the right button). Terminate definition of the polygon by pressing Enter or double-clicking the 
left mouse button. Note that the polygon is automatically closed by ODV. ODV then prompts you for a 
patch name (no extension) and writes the patch definition to a file in the collection directory. 

Once you have defined one or more water-mass patches for a collection, you can use them to com-
pose and activate the derived variable Patches. Choose Derived Variables from the background 
popup menu and select Patches from the Choices list. You can compose the Patches variable by se-
lecting one or more of the available water-mass patches (defined previously as described above) into 
it. When you are done press OK. To evaluate the Patches variable for a given sample, ODV deter-
mines whether the sample is inside one of the patch-polygons selected into the variable, and (if found) 
assigns the number of the respective patch as Patches value. If the sample is outside all the selected 
patches, its value is set to the missing data value.  

Like all other variables (basic or derived) you can use the Patches variable on any axis of any data-
plot. Use it, for instance, as Z-variable along sections or for iso-surface variables in order to display the 
spatial extent of specific water masses. 

                                                           
# IDH_ODV_DEFPATCH 
$ Defining Patches 
+ auto 
K defining patches; water-mass characteristics; Patches derived variable 



 80

# $ + K Editing Data 
 
You can edit the header information and the data-values of the current station and then save the modi-
fied values in the collection data files on disk.  

Header information: 

To modify the station header information of the current station, move the mouse over the ODV text-
window, click the right mouse button and select Edit Header. Then make your changes in the dialog 
box that appears and press OK to save the changes in the collection files. Press Cancel to discard 
your modifications and leave the collection files unchanged. 

 

Station data: 

To modify station data for a given variable move the mouse over the respective variable in the ODV 
text-window. Then click the right mouse button and select Edit Data (you can also simply press e while 
the mouse is over the respective variable). ODV will show a dialog box that lets you change data val-
ues and quality flags (1) for the current sample (initial setting), (2) for a user-defined sample subset or 
(3) for the whole profile. You can define a sample subset in the “Sample(s)” list-box by using the Win-
dows extended selection keys Ctrl and Shft together with clicks of the left mouse button. To select the 
whole profile click on Whole Profile in the “Scope” group. 

If you have selected a single sample, the corresponding data value is shown in the “Edit” group. You 
can change this value by typing a new numerical value in the Value field (if you have selected more 
than one sample, this field is deactivated). Pressing Delete Value(s) removes the data values of all 
selected samples. You should use this button with great care because the original data values are lost 
permanently. Usually it is preferable to leave the actual data value unchanged and to update the data 
quality flag(s) of the selected samples by checking the corresponding Quality Flag item. Pressing OK 
saves the changes to disk, pressing Cancel aborts the edit session and leaves the station data in their 
original form. 

If you change quality flags, you can later use different sample selection criteria to exclude bad or ques-
tionable data from the ODV data analysis. Note that edit operations are logged in the .log file of the 
collection. The .log file can be view using the Utilities->View log File option. 

 

                                                           
# IDH_ODV_EDIT 
$ Editing Data 
+ auto 
K editing header and data; data quality flags 
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#$+K Changing the Color Palette 
 
You can change the color palette that ODV uses for scatter, section and iso-surface plots by selecting 
Display Options from the data-window popup menu. Choose one of the available palette files, and 
ODV will redraw the data window using the new palette. Note that on high or true color systems you 
can use different palettes for the different data windows, on systems with only 256 colors all data win-
dows use the same palette (the last one chosen). Also note that when you use more than one palette, 
the palette of the last window determines the colors used in ODV GIF files. 
 
You can create new color palettes or modify existing palettes by means of the PalEdt.exe program in 
the ODV binaries directory (normally  c:\Program Files\Ocean Data View\Bin). PalEdt.exe can be in-
voked from ODV by choosing Utilities->Invoke Palette Editor. 
 

ODV-style color palettes define 177 colors:  

• 0-15:  basic colors (used in ODV STATION mode); color 8 used for section topography; 

• 16-31: gray-scale; color 31 used as background color of ODV plot windows; 

• 32-144: main palette used for color-shading; 

• 145-160: colors used for map bathymetry and continents; 

• 161-176 colors used for map land topography. 
 

                                                           
# IDH_ODV_PALETTE 
$ Changing the Color Palette 
+ auto 
K changing the color palette; color palette; palette 
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#$+K General Settings 
 

You can specify general ODV settings like the font that ODV uses or the “good coverage criteria” using 
the Configuration->General Settings option of the main menu. 

 

Font: 

Choose a font and various properties and set the global font scaling factor f. Choose a value f>1 if you 
want larger text and axis annotations, or f<1 otherwise. Note that the more exotic fonts might not be 
supported by ODV’s PostScript output. 

 

Print: 

Check the “Show Collection Info” box if you want the ODV time-stamp and collection/configuration info 
on printouts.  

 

Good Coverage Criteria: 

Some ODV operations, like for instance interpolation on standard depths or calculation of various de-
rived variables require that there are "sufficient" input data available. Dynamic height, for instance 
requires temperature and salinity, and the respective profiles should not have too wide data holes. 
Using the Good Coverage Criteria dialog box you can set and modify the test criteria. These criteria 
are then applied to any variable required for a specific operation. If one or more required variables fail 
the test, the respective operation is not performed. 

 # Levels minimal # of observed levels for a required variable (A); 

 Fraction > at least xx % of levels must contain data for A; 

 delta_Depth.. specifies the depth dependent tolerable gap between data points. 

 

Station Selection: 

Check the “Allow multi-station selection” box if you want to select among multiple stations at a given 
position clicked on with the mouse.  

                                                           
# IDH_GENERALSETTINGS 
$ General Settings 
+ auto 
K general settings; fonts; good coverage criteria 
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# $ + K Hardware Requirements 
 
ODV runs on PCs under Windows 9x/2000/NT and on UNIX workstations under SUN Solaris. The 
hardcopy routines of ODV have been tested on black white and color Apple LaserWriter, Canon Laser 
Copier and HP DeskJet printers, but should work on other printers as well. If you have a PostScript 
printer available, you can use ODV’s Save As PostScript option instead of Print, for faster and higher 
quality output. 

 

Solaris Requirements: 

Ocean Data View runs on Solaris 2.5.1 (SunOS 5.5.1 Generic 103640-08 Mar/97 or later), 2.6 (SunOS 
5.6 Generic 105181-05 Jan/98 or later), Solaris 7 (SunOS 5.7 Generic Oct/98 or later), and Solaris 8. 

For proper functioning you may have to adjust graphics system settings and you must make sure that 
certain SUN Solaris system patches are installed on your machine. Note that installing patches and 
setting system parameters requires root privileges and must be performed by your system administra-
tor. Retrieving system information, however, can be done by anybody (see below). 

**SYSTEM INFORMATION 

To retrieve information about your system, use the following UNIX commands.  

��Operating System:  uname -r 

��Kernel:    showrev -a | grep "Kernel" 

��Installed patches: showrev -p 

��Graphics Card:  ls /dev/fbs/* 

(Examples: /dev/fbs/afb* Elite3D; /dev/fbs/cgsix* GX; /dev/fbs/ffb* Creator/Creator3D; /dev/fbs/gfxp0* 
PGX32; /dev/fbs/leo* ZX; /dev/fbs/m640 PGX; /dev/fbs/sx* SX; /dev/fbs/tcx* TCX;) 

**COLOR SUPPORT 

Make sure to enable maximum color capabilities by editing file /usr/dt/config/Xservers. For a 24bit 
system, for instance, the "defdepth" entry should be set to 24: 

  :0 Local local_uid@console root /usr/openwin/bin/Xsun :0 -nobanner -dev /dev/fbs/xxxx defdepth 24 

where xxxx represents the graphics device name of the system. You must restart the Xserver by log-
ging out and then back in to activate the changes. 

**REQUIRED SYSTEM PATCHES 

Use "showrev -p" to obtain a list of installed patches on your system. If one or more of the required 
system patches listed below are not included in the list or an older version of the patch is installed, ask 
your system administrator to install the missing patches (required version or above). For graphics card 
identifiers see **SYSTEM INFORMATION above. 

> Solaris 2.5.1 

103566-46 
103627-11 
103640-29 
106529-04 
105789-07 Creator/Elite3D Graphics Card only 
103792-25 M64     Graphics Card only 
103793-01 TCX     Graphics Card only 
105790-19 Creator Graphics Card only 
105791-25 Elite3D Graphics Card only 
 

                                                           
# IDH_HARDWARE 
$ Hardware Requirements 
+ auto 
K hardware requirements 
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> Solaris 2.6 

105181-16 
105633-32 
106040-12 
106125-08 
105591-06 
105361-10 Creator/Elite3D Graphics Card only 
105362-24 M64     Graphics Card only 
105363-24 Elite3D Graphics Card only 
105492-02 cgsix   Graphics Card only 
105630-28 Creator Graphics Card only 
106391-01 TCX     Graphics Card only 
 

> Solaris 7 

107078-18 
106327-05 
106144-12 Elite3D Graphics Card only 
106145-12 Creator Graphics Card only 
106146-10 M64     Graphics Card only 
107851-01 PGX     Graphics Card only 
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# $ + K Directory Structure 
 
The default installation directory for ODV is c:\Program Files\Ocean Data View on Windows and 
~/odv for UNIX (indicated as root in the following, for UNIX replace \ by /). This is the base directory 
for several sub-directories containing files of specific type.  

root\Bin: 
ODV executable, help files, and PostScript preamble file. 

root\Coast\GlobLR: 
Low-resolution coastline and topography files for the whole globe. 

root\Coast\GlobHR: 
High-resolution coastline and topography files for the whole globe (available as op-
tional package). 

root\Include: 
Default directory for ODV include files (e.g., ETOPO global topography available as 
optional package). Note that there are several sub-directories containing other files 
of a given type. 

root\Include\AtmHist: 
Concentration histories of various atmospheric trace gases. 

root\Include\Gazetteers: 
ODV gazetteer database files. 

root\Include\Macros: 
ODV macro files (.mac). 

root\Include\Palettes: 
ODV palette files (.pal). 

root\Data: 
Default base-directory for ODV data collections. You can place your data collec-
tions anywhere on disk or CD-ROM, however, it is recommended that you create 
individual sub-directories for every collection that you maintain. 

root\Data\Save: 
Sample ODV data collection containing the South Atlantic Ventilation Experiment 
data. 

root\Samples: 
Directory for ODV sample files. Use these files as templates for data import or 
macro files. 

root\Temp: 
Directory for temporary files. ODV routinely removes files with names starting with 
ODV from this directory if they are older than 3 days. 

                                                           
# IDH_DISTRIBUTION 
$ Directory Structure 
+ auto 
K directory structure; installation 
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#$+K Limitations and Known Problems 
 

Limitations 

No. of stations per collection No limit 

No. of data values per station 100,000 

No. of levels per station 20,000 

No. of data plot windows 20 

No. of variables stored in a collection 50 

No. of contour lines per window 50 

Length of collection names (characters) 30 

Length of variable names (characters) 60 

Length of cruise labels (characters) 20 

Length of station labels (characters) 20 

 

 

Known Problems 

Windows: 

After extensive use of ODV and many redraws of the screen, font and color selection may fail and the 
ODV graphics window is corrupted.  

Workaround: Exit and re-start ODV. In severe cases it may be necessary to re-boot. 

 

Solaris: 

Occasional incomplete drawing of station map and occasional failure to clip correctly.  

Workaround: Enforce redrawing the map by moving the mouse over the map and pressing “r” or re-
load the current configuration using Configuration->Load Configuration. 

 

                                                           
# IDH_KNOWNPROBLEMS 
$ Limitations and Known Problems 
+ auto 
K limitatations; known problems; problems 
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# $ + K Overlaying a property distribution with contour-lines of an-
other property 
 
With ODV, you can produce section or iso-surface plots where the distribution of one property (color 
shaded and/or contoured) is overlaid with contour lines of another property. Useful applications, of this 
technique are, for instance, density contours on top of any property section or depth contours on iso-
surface or isopycnal distributions.  

To produce such plots, follow these steps: 

• In SECTION or SURFACE mode, switch to Graphics Layout mode by choosing Graphics Layout 
from the background popup menu.  

• Setup the window for the underlying distribution (window a: define size and position; select a Z-
variable for that window (property A)). 

• Create a twin of window a by moving the mouse over window a, clicking the right mouse button 
and selecting Create Twin. Move the mouse over the newly created window (window b), click the 
right mouse button and select Move/Resize. Move (without changing the size) window b over win-
dow a until they coincide. Press ENTER to accept. Now select the Z-variable for the overlay con-
tour lines in window b (property B). Leave the Graphics Layout mode by pressing ENTER. 

• When ODV has redrawn the data plots, move the mouse over window b, right-click the mouse and 
select Display Options. Check the VG Gridding button, as background color choose none (first 
choice), and click on the Properties button. Uncheck the Do Color Shading mark and proceed by 
defining contour lines . Use a color for the contour lines that will be clearly visible on top of the 
color distribution of property A (e.g., white or black). Click OK to accept the display option settings. 

• When ODV has redrawn the data plots, move the mouse over the background area and press r to 
enforce a redraw of all data windows. Before printing or PostScript, GIF or EMF export, separate 
the labels of properties A and B by dragging the respective annotations (move the mouse over the 
a label, hold down the left mouse button and move; note that this separation has to be repeated 
after redrawing). 

• If you are satisfied, save the configuration as usual for later use. 

Note that for a window entirely overlain by another window (like window a), the only way to access and 
modify its properties is via the Configuration->Window Properties option from the main menu.  

                                                           
# IDH_PROPOVERLAYS 
$ overlays 
+ auto 
K overlays 
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# $ + K Using ODV graphics in publications and on Web pages  
 
ODV graphics, either as entire ODV pages or individual data plots, can be included in print documents, 
posters or on Web pages.  

For Web pages you should create GIF output of the whole ODV screen or of individual plots (press 
Ctrl-s while the mouse is over the background or the respective plot window and choose GIF as output 
type) and place the GIF graphics using your favorite Web editor (e.g., MS FrontPage or Netscape 
Composer). 

For print documents the resolution of GIF files is usually insufficient and you should use ODV Post-
Script (.eps) output instead. 
 
A variety of typesetting and page design software supports the import of Encapsulated PostScript files 
(.eps) in mixed text/graphics pages (e.g., MS Word or compatibles, LaTeX, Adobe PageMaker, etc.). If 
you use the LaTex typesetting system, see the file Pssample.tex (usually in directory c:\Program 
Files\Ocean Data View\Samples) for an example on how to include PostScript graphics in TeX docu-
ments. Note that the required epsf and epsfig style files are also included in the samples directory.  
 
If you use Word or PageMaker or other publishing software follow these guidelines: Compose your 
page as usual and insert the respective ODV PostScript file at the right position. Adjust the size of the 
figure appropriately. When you are done composing the page you can directly print the document on a 
PostScript printer. If no PostScript printer is available you need to have a PostScript printer-driver and 
the GhostScript/GhostView package (http://www.cs.wisc.edu/~ghost/aladdin/index.html) installed on 
your machine. In that case select the PostScript printer-driver as printer and redirect the output into a 
file. Open this file with GhostView and print to any printer connected to your system. 

                                                           
# IDH_ODVPUBLISH 
$ publishing 
+ auto 
K publishing; poster; LaTex; Word; PageMaker; documents 



 89

# $ + K Preparing coastline and bathymetry files  
 
ODV comes with a coarse resolution global set of coastline and bathymetry files (GlobLR). Higher 
resolution versions of coast/bathymetry data are available for the whole globe (GlobHR) or for selected 
regions as optional packages (Baltic, BayOfBiscay, MedHR, and MeditHR). If you need high-resolution 
representations of coastline and bathymetry for a region not provided by the ODV distribution and if 
you have such high-resolution data available, here is how to produce ODV usable files. 

 

Preparing new files 

The data for the coastline and bathymetry contours must be in separate files. I recommend to use 
”World”  as the name for the coastline file. For naming of the bathymetry files you must use the ”xxxm” 
scheme, where xxx represents the depth of the respective depth contour (no white space between the 
depth value and the ”m”). For the ASCII version of the coast/bathymetry files the file extension must be 
.coa.  

The lat/lon coordinates of  the coast (or a depth contour) are stored in individual polygon segments 
with less than 1500 vertices each. Note that lat and lon are decimal, lon is in degrees East (0 – 360) 
and lat is in degrees North (-90 – 90). The format of a polygon segment in a .coa file is as follows: 

 

nT  nS 

lat_1 lon_1 

..... 

lat_nT lon_nT 

 

where nT is the total number of vertices for this segment and nS is the number of ”true” 
coast/bathymetry vertices. nT may be larger than nS, in which case vertices nS+1 .... nT  are used to 
close the segment (land-side closure). These extra vertices are not shown when the segment is 
stroked. Note that both, nT and nS, must be less than 1500. (Tip: If you cut long contours into pieces, 
the individual pieces should have no more than 1000 vertices initially. This leaves room for a complex 
closure  segment.) On the next line following the last vertex of a segment follow nT and nS numbers of 
the next polygon segment or ”0 0”, at the end of the file.  

Before the file can be used by ODV, the data have to be converted to binary format (.cdt files). This 
cannot be done using ODV directly, and you should send the (zipped) .coa files to rschlitzer@awi-
bremerhaven.de to complete this step. 

Please note that in order to use filling of bathymetry and coastlines, all polygons have to be properly 
closed such that the filled area represents the land-sided area. If you only have the outlines of depth 
contours or the coast, you can still use them with ODV, but you must select a line drawing mode and 
you must avoid filling (use the Display Options menu of the map to change display settings). 

 

Installing new files 

When installing the binary version of coastline-, bathymetry-, topography and overlay files follow these 
instructions: 

• Create a new subdirectory of the ODV “Coast” directory (normally: c:\Program Files\Ocean 
Data View\Coast) and choose a descriptive name for it (e.g., GulfOfMaine; this directory is the 
base directory of the new file series).  In this new subdirectory create directories “bathymetry”, 
“topography”, and “overlays”. 

• Copy the coastline file (normally called “World.cdt”) into the series base directory (e.g., 
c:\Program Files\Ocean Data View\Coast\ GulfOfMaine). 

                                                           
# IDH_PREPARECOAST 
$ coastlines 
+ auto 
K coastlines; bathymetry; topography 
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• Copy all bathymetry files (e.g., 100m.cdt, 500m.cdt, etc.) into the “bathymetry” subdirectory, all 
topography files into the “topography” directory and all general purpose overlay files (rivers, 
lakes, borders, etc.) into the “overlays” directory. If no topography and/or overlay files are 
available the respective folders remain empty. 

 

Using new files 

To use the newly installed files in ODV maps do the following: 

• Invoke the map “Display Options” dialog box (e.g., right-click the mouse while over the map 
and choose “Display Options”). 

• Select the “Layers” tab. 

• Choose the newly installed series name (e.g., GulfOfMaine) in the “Series” combo-box. 

• Compose the layer-set(s) of interest by selecting a layer-set (e.g., Ocean Bathymetry) and 
then pressing “Compose”. Select the contour files that you want to use in the “Available” list, 
set the desired stroke and fill properties and finally press “<-“ to add the files to the “Selected” 
list (note: if you forget to press “<-“ no file is added). To remove files from the “Selected” list 
select them and press “->”.  

When specifying drawing characteristics follow these rules:  

(a) if the features should be outlined by lines (stroked), choose the appropriate line-width, -
type and –color or choose ”none” as color, if you don’t want outlines. Note that due to limi-
tations of Windows, lines that are more than 1 pixel wide, will always be solid on the 
screen and in GIF and .emf files. ODV PostScript files, however, honor your selection for 
any line-width. 

(b) if the features should be filled choose the appropriate Fill color or ”none”, if you don’t want 
filling.  

If you choose ”automatic” for line and fill colors, ODV will use default colors. Note that for some layer 
sets ”automatic” defaults to ”none”. Also note that some feature files like rivers or borders should not 
be filled, and you should explicitly set the fill color to ”none”. 

When ODV produces the map it processes the layer sets in the order as listed in the “Display Options” 
dialog box. For a given layer set it draws the individual layers in the order in which they appear in the 
Selected list (note that ocean bathymetry and land topography layers are sorted automatically when 
they are added). You should define sea-ice distributions in the "pre-Coastlines" set and lakes, rivers 
and borders in the "post-Topography" category. 


