sigle.gif (4112 bytes)

RasTop 2.0 Help
Home | About | Copyrights | Notice | Using | Programs | Library

dotnul.gif (43 bytes)
  Commands:
arrow1.gif (162 bytes)Using RasTop
arrow1.gif (162 bytes)RasTop World
arrow1.gif (162 bytes)Menu
arrow1.gif (162 bytes)Summary
arrow1.gif (162 bytes)Reference
arrow1.gif (162 bytes)Internal Parameters
arrow1.gif (162 bytes)Atom Expression
arrow1.gif (162 bytes)Colour Schemes
arrow1.gif (162 bytes)Atom Sets
Content:
Menu
   arrow1.gif (162 bytes)File
   arrow1.gif (162 bytes)Edit
   arrow1.gif (162 bytes)Molecule
   arrow1.gif (162 bytes)Atoms
   arrow1.gif (162 bytes)Bonds
   arrow1.gif (162 bytes)Ribbons
   arrow1.gif (162 bytes)Envelops
   arrow1.gif (162 bytes)View
Menu Shortcuts
Mouse
Molec. File Editing
Main Toolbar
Selection Toolbar
Color Palette
Control Panel
Status Bar
Preferences

 

Using RasTop

Getting Started

RasTop is available on Windows 9x, Windows NT, and Windows 2000 platforms.  Please, report problems found on newer platforms.

Standard Installation:

Extract the RasTop folder from the rastop.zip file. Install the folder in the directory of your choice. To get RasTop icon in the start-up manager on Windows 95 platform, proceed as following: 1) Right-click on RasTop.exe file and select 'create shortcut'; 2) Transfer the shortcut into the folder "C://Windows/Start Menu/Programs".  Alternatively, place a shortcut on your Desktop.

To start RasTop, double click on the RasTop icon. When started for the first time, the program displays a single main window and one empty graphic window.

The Preferences are active only if the folder "C:/Program Files/RasTop" is defined. You must create this folder yourself. The RasTop exe file may be in an other location. When created, click under the file>Preferences menu option to activate the Preferences dialog box. Locate the help source - this site, either by browsing the hard-drive and selecting the file "index.html" in the RasTop help folder, or by manually entering its URL (http://www...) . Select the Default Representation script located in the folder containing the RasTop.exe file.

RasTop is a multi-document interface. Several graphic windows, each displaying a single molecular file, can be opened at the same time. Graphic windows are independent from each other, but can communicate using the clipboard to transfer various information such as spatial position or current atom selection. The same molecular file can be opened simultaneously in different graphic windows or on the same one.

The main window contains the following elements:

- one, or several graphic windows.
- a menu (check menu commands here),
- a main toolbar,
- a selection toolbar,
- a color palette,
- a control panel,
- a status bar,

Most of these elements are switched on and off by clicking in the pull-down menu under 'windows' (Vindows>).

Custom Installation:

If your monitor only supports 256 colors, download the rastop8bit.zip file, unzip and replace the original, 32 bit, exe file - RasTop.exe -  by the new exe file. Change the name back to RasTop.exe if you wish.

If you cannot get started and always receive the warning message "missing mfc42.dll", download and unzip the patch mfc42.zip; install the file mfc42.dll in the folder containing the RasTop.exe file.


up.gif (892 bytes)Tutorial

The chapter is still at its embryonic development stage.

The subfolder "data" in RasTop folder contains a few samples of molecular files. To open your first molecule, click on the menu command file>open. Browse your directories up to the RasTop folder, open successively the folders data and molecule, select a pdb file (a file ending by the extension ".pdb"). A molecule will be displayed on your screen.

Play with the mouse on screen to move and rotate the molecule. With the left and the right button and with or without the Shift key or the Ctrl key depressed, many options are available.

The  file>open menu command is in fact reserved for opening RSM scripts, i.e scripted files that contain both molecular and rendering information. This command tolerates direct opening of pbd files and cif files. Other molecular files should be opened using the command file>load molecular file.

To open your first RSM file, click on the menu command file>open. Browse your directories up to the RasTop folder, open successively the folders data and rsm, select the file 2H1.rsm. The antibody 2H1 in complex with the peptide PA1 will appear on screen.

To modulate the rendering, play with the submenu commands under the menus atom, bonds, or ribbons.

Rendering command usually act on selected atoms only. To see the atoms currently selected, click the toolbar button "show selection": selection_show.jpg (6726 bytes). Selected atoms will appear in orange, non-selected atoms will be in dark blue. At this stage all atoms should be selected.

Atom selection is by far one of the most difficult aspects of molecular rendering. Use the selection toolbar to proceed to varied atom selections. For example, select the word "aromatic" is the pulldown of the property box (located in the selection toolbar) and click on the button "new selection" in the toolbar. All the amino acids of aromatic type are now selected, check by clicking the button "show selection". The amino acid classification used by RasMol is depicted in the amino acid table.

In the original RasMol program written by Roger Sayle, all commands are entered by hand on a command line. In RasTop, the process is the same except that commands are now generated internally.  In our example, clicking the "new selection" button generated the command "select aromatic". RasMol script command may be entered manually using the dialog box activated by the menu Edit>Command.

Scripting of atom selections is explained in the page atom expression. Complex expressions not available in the menu have to be entered manually after clicking the Edit>Command menu.  New users and beginners will take advantage of reading the significance of the commands in the Command Reference page. It is not unusual to enter atom selections by hand.

Starting version 2.0, RasTop can load multiple molecules in a unique "world". An RSM script is added to the current world by the command File>Add, other molecular files are added by a simple File>Load command. When the world cursor is on, all molecules are moved together and when the world cursor if off, only the active molecule is moved. By active molecule, we mean the molecule that is currently selected for rendering. To determine which molecule is the active one, click the toolbar button "show selection": selection_show.jpg (6726 bytes), the non-active molecules are drawn in green whereas the active one is in orange for the selected atoms or in blue for the non-selected atoms.

When only one molecule is loaded, it is always better to have the world cursor activated ("world on").


up.gif (892 bytes)Graphic Windows

Graphic windows display a 32-bits output with a maximum of 1024 different colors per window. The high color resolution allows 64 shade variations per color. The 8-bits version displays only 256 colors and is adapted to 256 colors monitors. Note that most export formats are still under their initial 8-bits RasMol version. These routines still need to be updated, and so far the best way to export 32-bits color images is the clipboard (the MAC format PIC seems well supported too!).

Click on the top right of the window menu bar to resize, iconize, or maximize the window. Use the mouse to move, rotate, zoom, or slab the molecule. Left-clik the mouse to obtain information on a particular atom or operate the picking mode.


up.gif (892 bytes)Menu

Click here to see all menu commands.

With RasMol, most commands are entered manually in a command line window distinct from the graphic window. For example you type 'spacefill on' to generate a sphere rendering. RasTop does not require manual entries, but the concept of script command is still in use, just  in a way that is transparent to the user. In fact most of the menu commands generate their own script that is transferred to RasMol internally. Some operations are more than simple commands. In general, menu commands to manipulate atoms, bonds, and envelops are active, i.e. they activate the rendering. For example coloring bonds in green generates the script commands 'bonds on' and 'color bonds green'. Some commands also keep memory of the last action. For example, if you draw spheres of radius 120, the next sphere command will draw spheres of radius 120. This might be confusing when switching between graphic windows, but overall it simplifies the rendering operations.


up.gif (892 bytes)Menu Shortcuts

To activate a shortcut, press the corresponding letter while maintaining the Ctrl key down.

dotnul.gif (43 bytes)
Ctrl-A      Select All
Ctrl-C      Copy Selection
Ctrl-D      Define
Ctrl-E      Select Expression
Ctrl-F      Full Screen
Ctrl-I      Copy Image
Ctrl-L      Load Molecular File
Ctrl-M      Enter RasMol Command
Ctrl-N      New graphic window
Ctrl-O      Open an <*.rsm> script
Ctrl-P      Print
Ctrl-Q      Select Inverse
Ctrl-R      Restrict
Ctrl-S      Save
Ctrl-T      Tile all graphic windows
Ctrl-V      Paste
Ctrl-W      Show Selection
Ctrl-X      Copy Selection
Ctrl-Z      Select Previous

Pressing the Space key activates or deactivates the Display mode and shows the selected atoms. Edit>Select>Show menu shortcut.


up.gif (892 bytes)Mouse

Action Mouse Click
Rotate X,Y Left
Translate X,Y Right
Rotate Z Shift key + Right
Wheel
Zoom Shift key + Left
Shift or Ctrl key + Wheel
Slab Plane Ctrl key + Left
Back Clipping Ctrl key + Right


up.gif (892 bytes)Molecular File Editing

RasTop supports limited molecular file editing. The molecular file dialog box acts as a simple text editor. Drag the cursor with the mouse left button down to select text areas; use the shortcuts Ctrl-X, Ctrl-C, and Ctrl-V to cut, copy and paste, respectively.

Name box:   Change the title of the current file.

Format box:   Change the molecular file format. The molecular file format must match the format to load successfully.

Export option:   Export the molecular file as a text file.

Process option:   Save the changes to the molecular file and reprocess it. The rendering information are discarded. Not available starting version 2.0.

Save option:   Save the molecular file, do not process it, and keep the rendering information. To visualize the changes on screen, proceed as following:

1. Save the modified molecular file.
2. Save your work as an <*.rsm> script.
3. Reopen your saved file.

If you save on your previous <*.rsm> file, it is irreversibly modified. It is safer to make modifications of the molecular file on a copy of your <*.rsm> script. To do so, save initially your script under a different name, or reopen your script using the File>Open menu command.

Close option:   Exit the molecular file editing box without saving.


up.gif (892 bytes)Main Toolbar

main_new.jpg (4226 bytes)    Create a new untitled graphic window. File>New menu shortcut.
main_open.jpg (5944 bytes)    Open an <*.rsm> file. File>Open menu shortcut.
main_save.jpg (5475 bytes)    Save the active graphic window. File>Save menu shortcut.
main_print.jpg (5844 bytes)    Print the active graphic window. File>Print menu shortcut.
    Help
main_tile.jpg (5929 bytes)    Tile all graphic windows. View>Tile menu shortcut.
main_molec.jpg (5616 bytes)    Edit the molecular file.

    Render selection with CPK spheres.
    Render selection with stars
    Render selection with wireframe
    Render selection with balls & sticks
    Remove sphere, star, cylinder, and ribbon rendering

     Render selection with ribbon.
     Create dot envelop.

Picking mode

The picking mode is activated by clicking a picking icon once and deactivated either by clicking the same icon again, or by clicking twice in the window screen anywhere. Deactivating the picking mode updates the previous selection set.

By default, clicking an atom displays its residue name, residue number, atom name, atom serial number and chain in the information line, see RasMol 'picking ident' parameter. Pressing the Ctrl key while clicking switches the display to atom coordinates.

Picking Icons:

picking_atom.jpg (3945 bytes)    Select an atom. Pressing the Shift key together adds the atom to the current selection, pressing the Ctrl key removes it. Dragging the mouse while maintaining the left mouse button down will generates a squared lasso on screen. All atoms in the square will be selected on mouse up. The Shift key and the Ctrl key control the lasso selection as well. The lasso effect is better visible in the 'show selection' view mode.

picking_group.jpg (5723 bytes)    Select a group (a residue). Use Shift key and Ctrl Key to modulate the selection.

picking_chain.jpg (5250 bytes)    Select a chain. Use Shift key and Ctrl Key to modulate the selection.

    Select a molecule as active. This option works only when multiple molecules are loaded.

picking_center.jpg (5291 bytes)    Move the center to the clicked atom. If the Ctrl key is pressed together, the center is further moved to the center of the screen.

    Select or modify bonds. Pressing the Shift key together increase the bond order (create a single bond, single to double bond, double bond to triple bond); inversely pressing the Ctrl key decreases the bond order or delete the bond. The bond created or modified is selected for bond rotation.

    Rotate a selected bond.

picking_monitor.jpg (4022 bytes)    Add monitors. See the RasMol parameter 'picking'.

picking_label.jpg (4870 bytes)    Add or remove labels.

picking_distance.jpg (4596 bytes)picking_angle.jpg (4847 bytes)picking_torsion.jpg (4757 bytes)    Measure distances, angles, or torsions, respectively; see the RasMol parameter 'picking'.


up.gif (892 bytes)Selection Toolbar

 

    Change coordinate system from molecular to world and absolute coordinates successively.
    Toggle world axes on and off.
main_color.jpg (5126 bytes)    Toggle color palette.
selection_show.jpg (6726 bytes)     Show the selected atoms. Edit>Select>Show menu shortcut.

selection_all.jpg (4855 bytes)     Select all atoms.  Edit>Select>All menu shortcut.
selection_previous.jpg (6576 bytes)     Go back to the previous selection. Edit>Select>Previous menu shortcut.
selection_inverse.jpg (6436 bytes)     Select the inverse selection. Edit>Select>Inverse menu shortcut.
selection_edit.jpg (6302 bytes)     Select an expression. Edit>Select>Expression menu shortcut.

Selection boxes:

selection_box.jpg (5794 bytes)

There are three selection boxes: the element box, the property box, and the user set box. The element box is dedicated to single elements such as carbon or oxygen and predefined set of atoms such as rna or dna; the property concerns atom or group property such as hydrophobic or aromatic amino acids. The user set box contains user-defined atom sets that are declared at run time using the RasMol command 'define' (Edit>Define menu shortcut). New identifiers are added at the bottom of the drop-down list as new sets are created.

The last element selected in one of the three boxes modifies the current selection using 5 basic operation:

selection_new.jpg (5624 bytes)    Create new atom selection, discard current selection.
selection_add.jpg (6359 bytes)    Add atom set to current selection.
selection_remove.jpg (5696 bytes)    Remove atoms in common with current selection.
selection_extract.jpg (5580 bytes)    Select atoms in common with current selection.
selection_exclude.jpg (5624 bytes)    Exclude current selection from atom set.


up.gif (892 bytes)Color Palette

color_palette.GIF (2973 bytes)The drop-down menu lists the different RasMol elements. Click any color icon to fill them with color. See details in the RasMol command 'colour'. The icon labeled with a <+> activates a Windows color picker; the <-> label corresponds to the command 'color none', i.e. the elements take the color of the supporting atoms. Note that not all elements support the none color.

 


up.gif (892 bytes)Control Panel

From left to right:

World check box:  When checked (" world on") all loaded molecules rotate and move together. This is the default setting even when only one molecule is loaded. Uncheck only when you want to adjust a molecule position in a multiple molecule environment (see the command 'rotate all'.

Rotate check box:   When checked, command the three interactive scrollbars to rotate the molecule along the x, y, or z axis, respectively.

Translate check box:   When checked, command the three interactive scrollbars to translate the molecule in the x or y plane, or to zoom the molecule. When the world is active, the zooming effect is centered in the middle of the canvas, otherwise the rotation center is used.

Spin button:   Rotate automatically the molecule. Clicking in the left or the right cursor of the scrollbars adjusts the rotation speed and axe.

Reset button:   Restore the original viewing transformation and center of rotation. See the RasMol command 'reset'.

DepthCue button:   Activate depth queuing for spheres, cylinders, and ribbons. See the RasMol command 'set depthcue'.

Slab button:   Switch on and off the slab. See the RasMol command  'slab'.

Slab cursor:   Adjust slab plane in slab mode. See RasMol command 'slab'. The value indicated in the buddy window depends of the coordinate system in use.

Depth button:   Switch on and off the back-clipping plane. See the RasMol command 'depth'.

Depth cursor:   Adjust back-clipping plane. See RasMol command 'depth'.

Light cursor:   Adjust ambient lighting. See the RasMol parameter 'ambient'.

Specular cursor:   Adjust specpower. See RasMol parameters 'specpower' and 'specular'.

Shade cursor:   Adjust shadepower. See RasTop parameter 'shadepower'. Note that the range has changed starting version 2.0, and RSM file made with previous version may display a wrong setting.

Information line:  Display varied information, comments, or warnings generated by RasMol or by RasTop.  Right-click the mouse to copy its content.

Status light:   Take different colors according to RasTop status.

Light Grey:   Standby or RasTop ongoing operation.

Dark blue:   Ongoing calculation by "RasMol molecular engine."

Yellow:       Same as light grey, but a script is running.

Orange:      Pause in a script. Press any key to continue the script or the Esc key to interrupt the script.

Red:           Lost focus. The script keeps paused even when pressing keys.  Click once in the graphic window to get the input focus; then press any key or Esc to interrupt the script.

Dark blue lighting replaces the waiting cursor in RasMol. If RasTop does not respond, but the status light if dark, it means that the program is probably engaged in a time-consuming operation such as file loading or calculation of a molecular transformation.


up.gif (892 bytes)Status bar

Display information regarding the current atom pointed by the cursor. Toggle off in View>Status Bar menu command. The active coordinate system is indicated in the right end panel.


up.gif (892 bytes)Preferences

Starting version 2.0, preferences are stored in a script file, by default named 'rasmolprefs' and located in the folder "C:/Program Files/RasTop. You must create this folder if you want the preferences to work; a simple way is to put the RasTop folder in the Program Files folder. Use the menu File>Load Prefs to load a specific preference file. To create a preference file, just duplicate an existing one.

dotnul.gif (807 bytes) dotnul.gif (807 bytes)
Clipboard factor: The clipboard factor is an enlargement factor applied to images copied to the clipboard. A value of 2 often improves image resolution. Factors above 4 generate large, if not huge, image files and must be used with a lot of caution if not at all. Using a high image resolution may decrease the size of some objects; adjust the dot size and draw bonds as cylinders if necessary. Be aware that using a graphical output such as a printer or a screen at a resolution lower than the resolution of your graphic file may impair image quality.
Sequence output: One letter or three letters code output for the molecule>sequence menu command.
Coordinate System Clip plane values and atom coordinates depend of the chosen system.
Default Representation Indicate a script file that runs automatically after a molecular file is loaded. The first time you start RasTop, browse your directory and select the file 'default.src' in the RasTop folder.
Help source: Indicate where RasTop will find this web site when activating the help>help RasTop menu command. The first time you start RasTop, browse your directory and select the file 'index.html' in the folder help located in the RasTop folder.  URLs (http:\\www...) are also accepted.

 

dotnul.gif (43 bytes)
RasTop Help Site - home | notice | copyright
(c) CopyRight Philippe Valadon 2000-2001
All publishing rights reserved. 
Last updated on Tuesday, January 01, 2002