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1. SCIENTIFIC USE AND TEACHING 

Ocean Data View can be used free of charge for non-commercial, non-military research and 
teaching purposes. If you use the software for your scientific work, please cite Ocean Data View 
in your publications as follows: Schlitzer, R., Ocean Data View, http://odv.awi.de, 2009. 

2. COMMERCIAL AND MILITARY USE 

For the use of Ocean Data View or any of its components for commercial or military applications 
and products, a special, written software license is needed. Please contact the address below for 
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3. REDISTRIBUTION 
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address below for further information. 

4. WARRANTY DISCLAIMER 

THE ODV SOFTWARE IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER 
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MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.  THE ENTIRE RISK AS TO 
THE QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU.  SHOULD THE 
SOFTWARE PROVE DEFECTIVE, YOU ASSUME THE COST OF ALL NECESSARY SERVICING, 
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INCIDENTAL OR CONSEQUENTIAL DAMAGES HOWEVER CAUSED AND ON ANY THEORY OF 
LIABILITY ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE (INCLUDING BUT 
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SUSTAINED BY YOU OR THIRD PARTIES, A FAILURE OF THE SOFTWARE TO OPERATE WITH 
ANY OTHER SOFTWARE OR BUSINESS INTERRUPTION). 
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1 General Overview 

Ocean Data View (ODV) is a computer program for the interactive exploration and 
graphical display of oceanographic and other geo-referenced profile, trajectory or time- 
series data. The software is available for Windows, Mac OS X, Linux, and UNIX systems. 
ODV data collection and view files are platform independent and can be exchanged be-
tween all supported systems. ODV lets you maintain and analyze large sets of station 
data on inexpensive and portable hardware.  You can produce high-quality station 
maps, general property-property plots of one or more stations, scatter plots of selected 
stations, section plots along arbitrary cruise tracks and property distributions on gen-
eral isosurfaces. ODV supports display of original scalar and vector data by colored 
dots, numerical data values or arrows. In addition, there is choice between three differ-
ent gridding algorithms, providing estimates on automatically generated grids, and al-
lowing color shading and contouring of fields along sections and on isosurfaces. A large 
number of derived quantities can be calculated on the fly. These variables may be dis-
played and analyzed in the same way as the basic variables stored on disk.  

This version, ODV4, is based on a completely new object oriented software code and 
overcomes many limitations of previous ODV versions. To ensure backward compatibil-
ity, ODV4 supports existing collections and configuration files (now called views) 
created under previous ODV versions. All newly created collections, however, now use a 
new and much more general data model and internal storage format. As before, ODV4 
data collections maintain platform independence and may be moved between all sup-
ported systems. Among the noval features of the new data model are more flexible me-
tadata schemes, support for an unlimited number of collection variables, user specified 
data types, and custom quality flag schemes for meta- and collection variables. 

1.1 Ease of Use 

ODV is designed to be flexible and easy to use. Users need not know the details of the 
internal data storage format nor are they required to have programming experience. 
ODV always displays a map of available stations on the screen and facilitates navigating 
through the data by letting the user select stations, samples, sections and isosurfaces 
with the mouse. The screen layout and various other configuration settings can be mod-
ified easily, and favorite settings can be stored in view files for later use. ODV can create 
and manage very large data collections containing millions of stations on relatively in-
expensive and portable hardware. Existing data collections can be extended easily if 
new data become available. With its wide range of plot types and flexible interactive 
controls, ODV greatly facilitates data quality control and is particularly useful for train-
ing and teaching. 

1.2 Dense Data Format 

The ODV data format is optimized for variable length, irregularly spaced profile, trajec-
tory, and time-series data. It provides dense storage and allows instant access to the 
data of arbitrary stations, even in very large data collections. The data format is flexible 
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and accepts data for an unlimited number of variables. The metadata and collection va-
riables are defined by the user at collection create time, and different ODV collection 
may be created to store the values of different data types, such as profiles, trajectories 
or time-series data. ODV maintains quality flags for all individual data values. These 
quality flags may be used for data quality filtering to exclude, for instance, bad or ques-
tionable data from the analysis. Numerical values and quality flags may be edited and 
modified. All modifications are logged in the collection’s log-file, allowing unintentional 
changes to be reversed, if necessary. 

1.3 Extensibility 

ODV allows easy import of new data into collections and also allows easy export of data 
from a collection. Oceanographic data in the following widely used formats can directly 
be read into the ODV system: 

• ODV spreadsheet data,  
• Argo profile and trajectory data,  
• World Ocean Database data,  
• World Ocean Atlas data,  
• WOCE WHP data,  
• NODC SD2 data, 
• Java Ocean Atlas spreadsheet data. 

1.4 Derived Variables  

In addition to the basic measured variables stored in the data files, ODV can calculate 
and display a large number of derived variables. Algorithms for these derived variables 
are either coded in the ODV software (potential temperature, potential density, dynam-
ic height (all referenced to arbitrary levels), neutral density, Brunt-Väisälä Frequency, 
sound speed, oxygen saturation, etc.) or are defined in user provided macro files or ex-
pressions. The macro language is easy and general enough to allow a large number of 
applications. Use of expressions and macro files for new derived quantities broadens 
the scope of ODV considerably and allows easy experimentation with new quantities 
not yet established in the scientific community. ODV provides a built-in macro editor 
that facilitates creation and modification of ODV macros.  

Any basic or derived variable may be displayed in one or more data windows. In addi-
tion, any variable can be used to define isosurfaces, such as depth horizons, isopycnals, 
isothermals, or isohalines. Property minimum or maximum layers like, for instance, the 
intermediate water salinity minimum layer, can be selected as isosurface by finding 
zero-values of the vertical derivative variable of these variables.  

1.5 Plot Types 

ODV displays data in two basic ways: (1) either by showing the original data at the data 
locations as colored dots of user-defined size (see Figure 1-1a), numeric values, or ar-

http://www.argo.net/�
http://www.nodc.noaa.gov/OC5/WOD05/pr_wod05.html�
http://www.nodc.noaa.gov/OC5/WOA05/pr_woa05.html�
http://whpo.ucsd.edu/�
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rows (see Figure 1-2); or (2) by projecting the original data onto equidistant or variable 
resolution rectangular grids and then displaying the gridded fields (see Figure 1-1b). 
Method 1 produces the most elementary and honest views of the data, instantly reveal-
ing occasional bad data values and regions of poor sampling. In contrast, method 2 pro-
duces nicer plots and avoids the overlapping of the colored dots that occurs whith me-
thod 1, especially for large dot-sizes. It has to be noted, however, that the gridded fields 
of method 2 are data products and that small scale or extreme features in the data may 
be lost due to the gridding procedure. For both display modes, ODV allows the export of 
window data to ASCII files or the clipboard for subsequent use outside ODV.  
 

 
Figure 1-1: Data displayed as (a) colored dots and (b) gridded field. 

 

In addition to scalar property fields, ODV also supports the display of vector fields for 
datasets providing the X and Y vector components as distinct variables (see Figure 1-2).  

 

 
Figure 1-2: Arrow plot of historical wind field. 
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1.6 Window Scopes 

The ODV application window always displays a map of available stations. In addition, 
the user may define an unlimited number of other windows for the display of the actual 
data. Each of these data windows can have one of the following scopes: STATION, 
SCATTER, SECTION, or SURFACE. Each window has its own scope, and the scopes of the 
different data windows may be different. 

1.6.1 STATION Scope 

A STATION scope window (see Figure 1-3) provides an X/Y plot showing only the data 
of stations in the map’s pick list. You can add the current station to the pick list by 
pressing ENTER, or you can remove it by pressing the Delete button.You can edit the 
station pick list using the Manage Pick List>Edit Pick List option of the map popup menu. 
Among other things, this lets you adjust the graphics style for each individual picked 
station. As for all other data window types, STATION windows allow you to assign arbi-
trary collection variables (basic or derived) on the X and Y axis. For easy identification, 
picked stations are marked in the map using the same symbol and color as in the data 
windows. If the map has station annotation switched on, the picked stations positions 
are also labeled with the station label. 

 

 

Figure 1-3: Example window layout with an orthographic map and six data windows using STATION scope. 
The pick list stations are marked in the map for easy identification. 
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1.6.2 SCATTER Scope 

SCATTER scope windows (see Figure 1-4) display the data of all stations currently 
shown in the map, thereby providing overviews over potentially very large data sets. 
SCATTER windows are particularly useful for data quality control. Like for all subse-
quent scopes, SCATTER windows support a Z variable, in addition to variables on X and 
Y. Values of the Z variable determine the colors drawn at given X/Y data locations. Plots 
with Z-variables (for SECTION and SURFACE modes as well) can be displayed in two 
ways: (1) by placing colored dots or the actual data value at the X/Y locations (default) 
or (2) as continuous gridded fields, estimated on the basis of the observed data. Gridded 
fields can be color shaded and/or contoured.  

 
Figure 1-4: Example window layout with two data windows using SCATTER scope.The data of one station 

are highlighted using symbolset graphics objects. 

 

1.6.3 SECTION Scope 

SECTION scope windows (see Figure 1-5) display the data of all stations belonging to 
the section currently defined in the map, e.g., all stations inside the red section band. 
Sections are defined or modified using the Manage Section options of the map popup 
menu. SECTION windows also support Z variables and the display of original data or 
gridded fields. SECTION windows are most useful to display along-track property dis-
tributions or property/property plots for the stations of a given expedition following a 
given track. 
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Figure 1-5: Example window layout with two data windows of scope SECTION (1 and 2) and one SCATTER 
data window (3). Note that the SCATTER window 3 displays all data of all stations in the map, while the 

SECTION windows 2 and 3 only show the data of the stations inside the section band. 

 

 

 

Figure 1-6: Example window layout with two data windows of scope SURFACE showing property distribu-
tions on isosurfaces. 
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1.6.4 SURFACE Scope 

In addition to metavariables and collection variables, ODV defines a third set of va-
riables, isosurface variables. Isosurface variables provide values of a given collection 
variable (e.g. Temperature or Depth in Figure 1-6) on specific isosurfaces. Isosurfaces 
are layers of constant values of another collection variable, such as, constant depth or 
density layers.  

SURFACE scope windows show isosurface values of all stations in the map. SURFACE 
windows support X, Y and Z isosurface variables. If Longitude and Latitude isosurface 
variables are assigned to the X and Y axis, the window will become a map displaying the 
selected Z variable (see Figure 1-6). Such map data windows use the projection and lay-
ers settings of the station map. It is also possible to assign other isosurface variables to 
the X and Y axis of the SURFACE data window, resulting in general isosurface variable 
correlation plots, possibly colored using another isosurface variable as Z variable. 

1.7 Graphics Output 

Printouts of the ODV graphics canvas can easily be obtained using the File>Print Canvas 
option. As an alternative, you can also write the entire graphics canvas, individual data 
windows or the map to png, jpg, gif or PostScript files. These files can subsequently be 
included in electronic documents and web-pages. The resolution of the image files can 
be specified by the user and is not limited by the graphics resolution of the screen. 

1.8 Data Statistics 

Statistics information for the X, Y, Z data of a data window or the position and date/time 
metadata of the stations in the map can easily be obtained by pressing F4 while the 
mouse is over the respective data window or the map. A dialog will appear showing 
mean, standard deviation, number of data points as well as minimal and maximal values 
for X, Y and Z variables separately. In addition, histograms of X, Y and Z data as well as 
X/Y data distribution plots can be obtained by simple button clicks. For the map you 
can also obtain station coverage histograms over time or season. 

1.9 Estimation and Averaging 

ODV can be used to estimate values of any basic or derived variable at arbitrary longi-
tude-latitude-depth points (3D point estimation). 3D point estimation is implemented 
as a fast weighted averaging procedure and uses the currently valid station and sample 
set together with user specified longitude, latitude and depth averaging length scales. 
The coordinates at which estimation is requested are provided in ASCII files. The points 
can be irregularly spaced or may form a uniform or non-uniform, rectangular or curvi-
linear grid. You invoke 3D point estimation from the main menu through Tools>3D Es-
timation. 

For data windows with a Z variable, another method, 2D point estimation, can be used 
to estimate Z values at arbitrary X/Y points. As for 3D estimation, the X/Y coordinates 
are provided in ASCII files. The points can be irregularly spaced or may be on a uniform 
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or non-uniform, rectangular or curvilinear grid. Choose Extras>2D Estimation from the 
respective data window popup menu to invoke 2D point estimation. 

A third estimation method, 1D Estimation, is available for data plots that have the pri-
mary variable on their X or Y-axis. For every station contained in the plot, this option 
allows estimation of the other variable at user-specified values for the primary variable. 
These user-specified coordinates have to be provided in ASCII files, one coordinate per 
line. The results of the estimation (one requested station after the other) are written to 
ODV spreadsheet format files, e.g., these files themselves can be imported easily and 
visualized with ODV. You can use the 1D Estimation option to obtain, for instance, stan-
dard depth (pressure) profiles of a variable stored in your collection. Choose Extras>1D 
Estimation from the respective data plot popup menu to invoke 1D Estimation. 

In addition to the various point estimation methods described above, ODV can also be 
used to calculate averages and standard deviations for user-specified longi-
tude/latitude/depth boxes. All currently valid samples inside a given box are used for 
the averaging. Box-averaging differs from point estimation: whereas all point estima-
tion methods always yield a value (potentially of poor quality, if no data are found 
nearby), the box averaging procedure only returns results, if data values are actually 
found inside the box. 

1.10 NetCDF Support 

In addition to native data collections, ODV can also access and visualize data in netCDF 
files, widely used for platform independent storage of original data or model output. 
ODV requests user help for the identification of key coordinates and variables in the 
netCDF by means of an easy-to-use netCDF emulation wizard. The content of the 
netCDF file is then presented to the user as if the netCDF file was a native ODV collec-
tion. All ODV analysis and visualization options are available for the exploration of the 
data in the netCDF file. NetCDF files are platform independent and can be used on all 
ODV supported systems. 
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2 First Steps 

2.1 Installing Ocean Data View 

You must install ODV on your computer before you can use the software. The latest ODV 
installation files for Windows, Mac OS X, Linux, and UNIX systems can be downloaded 
from http://odv.awi.de/en/software/download/. Note that you have to register and 
use your personal login data to get access to the download pages. Detailed installation 
instructions are provided in INSTALL.txt files. Please see the License Agreement for 
ODV usage rules. 

IMPORTANT NOTE: The ODV user directory has been moved from odv_local in the us-
er’s home directory in previous ODV versions to sub-directory ODV in the user’s docu-
ment directory. Private palette, macro, gazetteer, command or graphics objects files 
created by the user have to be manually copied to the new user directory to make them 
available to ODV4. The same applies to reference datasets saved with previous ODV 
versions. The full user directory path as well as other ODV settings can be obtained via 
Help>About ODV or odv4>About  odv4 on Mac OS X systems. 

2.2 Installing Optional Packages 

Complementary high resolution coastline and topography files or ready-to-use data 
collections are available as optional packages from http://odv.awi.de/en/software/ 
and http://odv.awi.de/en/data/. Again, see the INSTALL files for installation instruc-
tions and further information. 

2.3 Running Ocean Data View 

Once ODV is installed on your system you can start the program in a number of ways.  

On Windows, the installation procedure will create an ODV icon on your desktop and 
will automatically associate .odv and .var collection files with the ODV application. To 
launch ODV, you can double-click .odv or .var files, or the ODV desktop icon.  

Any ODV supported file can be dragged onto the ODV icon. This will start ODV and open 
the dragged file in a single operation. When ODV is running, you can drag an ODV sup-
ported file onto the ODV window to open this file. Supported file types include ODV col-
lections (.odv and .var), netCDF files (*.nc, *cdf), ODV spreadsheet files (.txt) and others. 

On Mac OS X, Linux, and UNIX systems you can create aliases or icons for the ODV ex-
ecutable odv4 or the ODV startup script file run_odv using methods specific to your op-
erating system. The ODV executable odv4 is located in the bin_... directory of your ODV 
installation (e.g., bin_macx on MacOS X, bin_linux-i386 on Linux systems, etc.). Once a 
desktop or taskbar/dock icon is created, you start ODV by double or single-clicking on 
the ODV icon. On most systems you can also drag-and-drop ODV collection .odv and .var 
files, netCDF files or any supported data import file onto the ODV icon. 

ODV can also be started from DOS boxes or terminal windows by entering the path-

http://odv.awi.de/en/software/download/�
http://odv.awi.de/en/software/�
http://odv.awi.de/en/data/�
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name of the executable and optional arguments. On some systems a script file run_odv is 
available to start ODV from the command line. If you start ODV from the command line 
the following arguments are supported. Note that file and path names including spaces 
must be enclosed within quotation marks “ “. 

There are two ways of starting ODV from the command line: 

odv4  file  [ -view view_file ] 

or 

odv4  -x cmd_file  [ -q ] 

The first case opens an ODV collection (.odv or .var collection files) or netCDF .nc or .cdf 
file file and loads the view from view file view_file. The -view view_file argument is op-
tional. If it is not provided a default view or the most recently used view is used initially. 
If the ODV binary directory is not in your PATH you have to specify the full pathname of 
the ODV executable, e.g., “c:\Program Files\Ocean Data View (mp)\bin_w32\odv4” on 
Windows or “/Applications/ODV/bin_macx/odv4” on Mac OS X systems. file has to be 
an absolute pathname, or a path relative to the current directory. view_file has to be an 
absolute pathname, or a path relative to the directory containing file. 

The second case opens the ODV command file cmd_file and executes the commands con-
tained in the file. If the optional argument -q is provided, ODV is automatically closed 
after all commands have been processed. cmd_file has to be an absolute pathname, or a 
path relative to the current directory. 

On some platforms ODV prompts for the following Quick Installation information when 
running for the first time: 

1. The full path-name of the directory that contains the bin directory 
(ODVMPHOME environment variable). 

2. The full path-name of a directory on your disk which will be used by ODV during 
runtime to write temporary files (ODVMPTEMP environment variable). Note 
that you must have write permission for this directory. You can use the system 
tmp directory, or you can create a special directory on a local disk (e.g., /odvtmp) 
for this purpose. The use of directories on network drives is not recommended 
because of potentially pour performance. 

3. The name of your computer. 

4. Your user or login name. 

Press OK to finish the Quick Installation. Then customize ODV font and external pro-
grams settings using the View>General Settings dialog.  

Once ODV is running, you open a data collection, netCDF file or any of the supported 
import data files using the File>Open option. A standard file open dialog will appear, and 
you can choose the appropriate file type and file name to be opened. If you open a sup-
ported import data file, ODV will automatically create a new collection in the directory 
of the selected file, import the data from the file, and open the newly created data col-
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lection.  

Note that after opening a collection, ODV loads the most recent view settings of the col-
lection. These view settings may include station and sample selection filters, and, as a 
consequence, only a subset of the stations and data values in the collection may be 
shown in the map and data windows. Use View>Station Selection Criteria or 
View>Sample Selection Criteria to reset or modify the selection criteria. 

You may load other, previously saved, view files using View>Load View, you may change 
the window layout with View>Window Layout, load one of the pre-defined layout tem-
plates with View>Layout Templates>…, or change the various settings interactively us-
ing the View menu options or the popup menus that appear when right-clicking the 
mouse while over the canvas area, the map, or one of the data windows. 

2.4 Getting Help 

Pressing F1 or using option Help>User’s Guide opens the ODV User’s Guide (this docu-
ment). Note that a pdf version of the User’s Guide is available on the ODV website. Con-
text sensitive help is provided by pressing the Help button on many ODV dialogs. This 
will invoke the web browser specified under View>General Settings>Program Locations, 
and the browser will jump to a particular chapter in the User’s Guide. On Windows, con-
text sensitive help works best with the Firefox browser. When using Internet Explorer it 
may be necessary to click into address field and to press ENTER. On Mac OS X and some 
Linux systems a running web browser may have to be closed before ODV context sensi-
tive help will be displayed.  

2.5 Application Window 

The ODV4 application window consists of the following elements (see Figure 2-1): 

Menu Bar: The menu bar provides access to main menus. 

Canvas: The graphics canvas contains a map (always present) and an unlimited number 
of data windows. The canvas, the map, and the data windows may contain an 
unlimited number of graphics objects, such as text annotations, symbols or user-
defined shapes. 

Status Bar: Three panes providing (1) status information, (2) coordinates at current 
mouse position or a progress bar, and (3) the number of currently selected sta-
tions, the total number of stations in the collection, and the name of the current 
view. 

Current Station Window: Metadata values and quality flags of the current station 
(marked in the map with a red cross).  

Current Sample Window: Data values and quality flags of the current sample (marked in 
data windows with a red cross). Only data satisfying the current sample selection 
criteria are shown. 

Isosurface Data Window: Isosurface values of the current station.  

http://odv.awi.de/en/documentation/�
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Figure 2-1: Elements of the ODV application window. 

 

Left-clicking on station or data marks in the map or any of the data windows selects the 
respective station or sample. Right-clicking on most window elements brings up con-
text menus with different, element-specific options. Resting the mouse over data listing 
items brings up popup windows with detailed data information.  

The map displays stations that satisfy the current station selection criteria. It maintains 
a pick station list and may have a section. Data windows have one of the following 
scopes: (1) STATION, showing X/Y data of the picked stations, picked stations are 
marked in the map using the same marks as in the data windows; (2) SCATTER, show-
ing X/Y/Z data of all selected stations shown in the map; (3) SECTION, showing X/Y/Z 
data of all stations inside the section band; and (4) SURFACE, showing isosurface X/Y/Z 
data of all selected stations shown in the map. The current window layout and parame-
ter settings are collectively called a view. Views can be stored in files for later use. 

Some of the ODV window elements and popup menus are described in more detail be-
low. 

2.6 Menu Bar 

The main menu provides basic functionality: 

File: Open or create a collection; open netCDF file; open a ODV supported data file, 
execute ODV commands in batch mode; print the current ODV graphics canvas; 
produce GIF, PNG, JPG or PostScript files of current ODV graphics canvas; exit 
ODV. 
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Collection: Copy, rename, delete collection; sort and condense data collection; delete 
current station or valid station subset; view collection info, inventory, and log 
files; add a comment to the collection log file. 

View: Change station and sample selection criteria; define derived variables; define 
isosurface variables; change map and data window layout; change variable la-
bels, numeric format and display order in listing windows; load and save confi-
guration settings, define general ODV settings. 

Import: Import data into current collection (supported are various WOCE data 
streams, World Ocean Atlas, World Ocean Database, NODC SD2 format, ODV 
spreadsheet formats, two ODV list formats). 

Export: Export data of currently selected stations; export window X, Y, Z data to 
ASCII files; export window X, Y, Z data as reference dataset. 

Tools: Perform 3D estimation; calculate box average values; find outliers and dupli-
cate stations; invoke the macro editor; invoke the palette editor (Windows only). 

Help: Invoke ODV help system; visit the ODV web page; send bug reports; show ODV 
version. 

2.7 Metadata and Data Windows 

The Current Station Window contains the metadata values and associated quality flags 
of the current station (marked in the map with a red cross), the Current Sample Window 
contains the data values and associated quality flags of the current sample (marked in 
data windows with a red cross), and the Isosurface Data Window contains the isosurface 
values of the current station.Different colors are used to display metadata and data val-
ues to instantly reveal the quality of individual values. 

Right-clicking the mouse button on a list window brings up window specific popup me-
nus letting you edit the metadata or data, or allowing modifications of variable proper-
ties. This includes changing the variable labels, the numeric format and the display or-
der in the data values list.  

Popup windows containing the full variable label and quality flag text appear automati-
cally when resting the mouse over one of the list items. 

2.8 Graphics Canvas 

The canvas is the painting area of ODV and contains the station map and zero or more 
data windows. You can adjust the size of the canvas via View>General Settings>Canvas. 

2.9 Popup Menus 

Clicking the right mouse button (on Mac OS X system with a single-button mouse hold 
down the Alt key and click the mouse) while over the canvas, the map, a data window, a 
graphics object or a data list window invokes different popup menus providing element 
specific options. Most of the ODV functionality is available via these popup menus. 
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Figure 2-2: The canvas popup menu 

The canvas popup menu offers the following 
options: 
 
• 1: Redraws the entire canvas and all its windows.  
• 2: Saves the entire canvas and all its windows in 

gif, png, jpg, or PostScript file. 
• 3: Prints the entire canvas and all its windows. 
• 4: Adjusts the axis ranges of all windows to full-

scale. 
• 5: Allows undo of the most recent view changes. 
• 6: Allows adding or managing the graphics objects 

of the canvas. 
• 7: Changes the properties of the map and data 

windows.  
• 8: Changes the map and data window layout and 

implements window layout templates. 
• 9: Saves or loads a view to or from a file. 

 

 

 

 

 
Figure 2-3: The map popup menu 

The map popup menu offers the following options: 
 
• 1: Redraws the map and all data windows.  
• 2: Saves the map in gif, png, jpg, or PostScript file. 
• 3: Manually zoom in or out the map domain. 
• 4: Zoom in to the point of the mouse right-click. 
• 5: Automatically zoom out. 
• 6: Chooses native map domain of the collection. 
• 7: Chooses global map domain. 
• 8, 9: Selects a new current station by name or inter-

nal number. 
• 10: Changes the station selection criteria. 
• 11: Changes the sample selection criteria. 
• 12: Lets manipulate the map’s station pick list. 
• 13: Lets define a section and modify its properties. 
• 14: Access to the map’s Extras menu.  
• 15: Allows modifying the properties of the map.  
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Figure 2-4: The data window popup 

menu 

The data window popup menu offers the following 
options: 
 
• 1: Redraws the data window.  
• 2: Saves the data window in gif, png, jpg, or PostScript 

file. 
• 3: Manually zoom in or out the data window domain. 
• 4: Zoom into the window’s color bar to modify the Z-

range. 
• 5: Zoom in to the point of the mouse right-click. 
• 6: Automatically zoom out. 
• 7: Adjusts the axis ranges of this window to full-scale. 
• 8: Sets axis ranges manually. 
• 9: Selects new variables on X, Y, or Z axis. 
• 10: Access to the data window’s Extras menu.  
• 11: Allows modifying the properties of this data win-

dow.  
 

 

2.10 Status Bar 

The ODV status bar displays help, status and progress information. The right-most pane 
of the status bar indicates the number of currently shown stations in the map, the total 
number of stations in the collection, and the name of the current view file. Resting the 
mouse over this pane brings up a popup window with more detailed information on the 
current state. 

2.11 Current Station and Sample 

ODV always points to a current station. This station is marked in the map with a red 
cross, and its metadata are listed in the Current Station Window. You can select a new 
current station by clicking with the left mouse button on a station mark in the map. If 
you suspect more than one station at the same location, for instance, because of re-
peated observations at the same site, you can hold down the SHFT key while clicking on 
the station position. If there are indeed multiple stations at the clicked position, a list of 
these stations is shown, and you can select the new current station from the list.  

You can also use keyboard keys to select new current stations: the right arrow key will 
select the next station (according to the station order in the collection), while the left 
arrow key will select the previous one.  
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Choosing option Current Station by Name from the map popup menu lets you specific 
cruise label, station label and station type making the matching station the current sta-
tion.  
Choosing option Current Station by ID from the map popup menu (or simply pressing 
the # key while the mouse is over the map) lets you select a new current station by en-
tering its internal ID number (not to be confused with the station label). 

One of the samples of the current station is the current sample. The current sample is 
marked in the data windows by a red cross, and its data values as well as its quality 
flags are shown in the Current Sample Window. To select a new current sample (and 
possibly new current station) left-click with the mouse on any data point in any of the 
data windows. The down arrow key will select the next sample (in ascending order of 
primary variable values), while the up arrow key will select the previous one. Pressing 
the PgUp or PgDn keys will move the current sample forward or backward in larger 
steps. 

2.12 Map and Data Window Drawing 

The map and data windows automatically draw or redraw themselves at program start, 
or whenever a view is loaded or one of the many layout or display properties is mod-
ified. Data windows of scope STATION or SECTION remain empty if the list of picked 
stations is empty and no section is currently defined. 

To add a station to the pick list either double-click on the particular station mark in the 
map or click on the mark to make the station the current station and then press ENTER. 
Repeat this procedure for other stations that you want to add to the pick list. The pick 
list can hold an unlimited number of stations. You delete a station from the pick list by 
making it the current station (e.g., click on one of its data points in a STATION window) 
and pressing the Delete button. You can edit the properties of pick list entries via the 
Manage Pick List>Edit Pick List option of the map popup menu.  

To define a section or change section properties use options from the Manage Section 
menu of the map popup menu. Once a section is defined the along-section coordinate is 
available as a derived variable. This can be either Section Longitude, Section Latitude, or 
Section Distance, depending on you choice of the Section Coordinate. If you want to pro-
duce property distributions along the section, put the section coordinate on the X axis of 
the plot. 
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3 ODV Collections 

ODV uses a special data format that can handle very large sets of data efficiently. This 
collection format is optimized for irregularly spaced, variable length data and provides 
dense storage and fast data access. The data model is quite general and accomodates 
profile, trajectory and time series data from various fields of environmental sciences, 
including oceanography, meteorology, glaciology and geology.  In addition to observed 
data, ODV can also be used to analyze and visualize gridded data or numerical model 
output. Such data may be provided in ODV native collection format or as netCDF data-
sets.  

ODV4 defines a new collection data format (ODVCF5) that is more general than its pre-
decessor format ODVGENERIC used by previous versions of ODV. ODVCF5 overcomes 
many limitations of ODVGENERIC. In particular, there is now support for a much wider 
range of metadata variables, an unlimited number of collection variables and a virtually 
unlimited number of samples per station. For the first time ODVCF5 now supports data 
quality flags for metavariables, and, for meta- and collection variables alike, the user 
may now adopt custom quality flag schemes from a set of the 14 most popular schemes 
in the oceanographic community. Collections with more than 50 variables and custom 
datatypes ranging from double precision (8 bytes) to single-byte integers are now poss-
ible with ODVCF5. Metavariables may be numeric (1 to 8 bytes per value) or of type text 
with user specified text length. 

ODV4 fully supports ODVGENERIC collections and .cfg configuration files created with 
previous versions of ODV. When creating new collections, however, ODV4 will use the 
new ODVCF5 format providing all the new features and allowing for more flexibility in 
the definition of meta- and collection variables.  

3.1 Data Model 

ODV can handle a very wide range of data types, such as profile data (ocean, atmos-
phere, lakes, marine and lacustrine sediments, ice sheets, etc.), or time series data from 
fixed or drifting stations in the ocean, on ice floats or on land.  

The fundamental data entity handled by ODV is the station, representing the data of a 
specific sampling event at a given geographical location and date and time. ODV orga-
nizes the data of a potentially very large number of stations in ODV data collections. 
Users typically open a data collection and work with the station data in this collection. 
Collections are expandable, and new data can be appended at any time. 

Stations are described by a number of  metadata entities, including cruise and station 
names, space and time coordinates, and possibly a number of additional descriptive 
parameters. Each station contains data for one or more samples, and each sample can 
have values for two or more variables (collection variables). One of the collection va-
riables, the primary variable, is special and serves as ordering variable for the samples 
of a station. The sets of meta- and collection variables are defined when the collection is 
created. 
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For each station, ODV maintains data values for all metavariables and also for all collec-
tion variables and all samples. In addition, ODV also maintains quality flag values asso-
ciated with every individual metadata and data value. There are additional quality flags 
describing the overall quality of a station (station quality flag) and of each individual 
sample (sample quality flags). Quality flag values reflect the degree of confidence in the 
data and constitute an extremely valuable part of the data set.  

ODV supports all widely used quality flag schemes in the oceanographic community. 
ODV also defines its own simple quality flag scheme that is applicable for oceanographic 
and most other kinds of environmental data. ODV can use data quality flag information 
for data filtering. Data quality flag values of collection variables can directly be worked 
with by means of quality flag derived variables. 

Individual meta- and collection variables may use different quality flag schemes. Meta-
variable as well as sample data values may be missing. 

Schematic summaries of station metadata and data arrays maintained by ODV are 
shown in Tables 3-1 and 3-2. 

 
Table 3-1: Station metadata values v and quality flags q maintained by ODV. Metavariable values may be 

either text or numeric.  The total number of metavariables m is unlimited. 

Metavar1 Metavar2 … Metavarm Station 
QF 

v1 q1 v2 q2 … vm qm q 

 
Table 3-2: Station data values and quality flags maintained by ODV. Values of collection variables must be 

numeric, text entries are ignored.  The minimum number of collection variables is two; the total number n is 
unlimited. The number of samples k is unlimited.One of the collection variables is defined as primary varia-

ble. Samples are sorted in ascending order of primary variable values.  

 Var1 Var2 … Varn 
Sample 

QF 

Smpl1 v1,1 q1,1 v1,2 q1,2  v1,n q1,n q1 

Smpl2 v2,1 q2,1 v2,2 q2,2  v2,n q2,n q2 

.         

.         

.         

Smplk vk,1 qk,1 vk,2 qk,2  vk,n qk,n qk 

 

3.1.1 Metavariables 

ODV requires availability of some types of metadata for its basic operation. The geo-
graphic location of a station, for instance, must be known to be able to plot the station in 
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the station map.  Date and time of observation, or the names of the station and cruise 
(or expedition) it belongs to are needed to fully identify the station and to be able to 
apply station selection filters that only allow stations of given name patterns are from 
specific time periods. Because of this fundamental importance, ODV defines a set of 
mandatory metavariables providing name, location and timing information of a given 
station (see Table 3-3). 

Other suggested metavariables are optional, and still others may be added by the user, 
as necessary. Metavariable values can be either text or numeric, and the respective byte 
lengths can be set by the user. The value type (text or numeric) of the mandatory meta-
variables may not be changed, while the byte length may. As an example, the data type 
of the longitude and latitude metavariables may be set as 8 bytes double precision to 
accommodate better than cm-scale precision of station location. Metavariables with 
values in the ranges [0 to 255] or [-32,768 to 32,767] may be represented by 1 or 2 byte 
integers, respectively, to conserve storage space. 

 
Table 3-3: Mandatory and optional ODV metavariables. 

Metavariable Recommended Label 

Mandatory 

Cruise label (text). Cruise 

Station label (text). Station 

Station type (text). Type 

Date and time of observation (numeric year, month, day, hour, 
minute and seconds). 

yyyy-mm-ddThh:mm:ss.sss 

Longitude (numeric). Longitude [degrees_east] 
Latitude (numeric). Latitude [degrees_north] 

Optional 

SeaDataNet station identifier (text). LOCAL_CDI_ID 

SeaDataNet institution identifier (numeric). EDMO_code 

Bottom depth at station, or instrument depth (numeric). Bot. Depth [m] 

…  

Additional user defined metavariables (text or numeric).  

 

3.1.2 Collection Variables 

The collection variables represent the parameters for which data have been obtained 
on the samples of the stations. The total number n of collection variables Vari (see Table 
3-2) and their particular meaning are arbitrary. All collection variables must have nu-
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meric values; text values are currently not supported. One of the collection variables 
(the primary variable) is special and is used for sorting the samples in ascending order 
of primary variable values. Usually, the first collection variable Var1 serves as primary 
variable, but any other variable can be chosen for this purpose. The primary variable is 
defined when the collection is created. 

3.2 Example Collection Types 

The ODV data model described above is flexible enough to support a wide range of dif-
ferent data types from various fields of geosciences and environmental research. The 
following examples cover some of the main applications. Other, more exotic cases not 
listed here may also be within the scope of the ODV data model.  

3.2.1 Profile Data 

This category covers a wide range of observations, including, for example, oceano-
graphic profiles made at fixed positions or along steered or passive (current following) 
tracks by moored or drifting instruments, or from ships. In all these cases each individ-
ual profile should be treated as an individual station, using the metavariable and collec-
tion variable assignments from Table 4. Profile data in the atmosphere, ice sheets or 
sediments can be organized in similar ways, the only difference being in the choice of 
the primary variable (e.g., height in the atmosphere, or depth in the ice or sediment 
core). 

 
Table 3-4: Recommended meta- and collection variable assignments for profile data. 

Metavariables Values 

Cruise Cruise, expedition, or instrument name 
Station Unique station identifier 
Type B for bottle or C for CTD, XBT or stations with >250 samples 
yyyy-mm-ddThh:mm:ss.sss Date and time of station (instrument at depth) 
Longitude [degrees_east] Longitude of station (instrument at depth) 
Latitude [degrees_north] Latitude of station (instrument at depth) 
  
Bot. Depth [m] Bottom depth of station 
Unlimited number of other 
metavariables 

Text or numeric; user defined text length or 1 to 8 byte integer 
or floating point numbers 

  
Collection Variables Comment 

Depth or pressure in water 
column, ice core, sediment 
core, or soil; elevation or 

To be used as primary variable 
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height in the atmosphere; 
etc. 
Unlimited number of other 
measured or calculated va-
riables 

Must be numeric; 1 to 8 byte integer or floating point numbers 

 

3.2.2 Time Series Data 

This category covers observations at a given (fixed) location that are repeated over 
time. Examples are measurements of currents and hydrographic parameters on moored 
oceanographic sensors, sea level height measurements at coastal stations or meteoro-
logical observations on land stations.  In all these cases the entire time series of a given 
instrument or station should be treated as an individual station, using a decimal time 
variable as primary collection variable and the other metavariable and collection varia-
ble assignments from Table 3-5.  

 
Table 3-5: Recommended meta- and collection variable assignments for time series data. 

Metavariables Values 

Cruise Cruise, expedition, or instrument name 
Station Unique station identifier 
Type B for bottle or C for CTD, XBT or stations with >250 samples 
yyyy-mm-ddThh:mm:ss.sss Deployment date and time of instrument 
Longitude [degrees_east] Deployment longitude of instrument 
Latitude [degrees_north] Deployment latitude of instrument 
  
Bot. Depth [m] Bottom depth at station 
Unlimited number of other 
metavariables describing 
the instrument and its dep-
loyment depth 

Text or numeric; user defined text length or 1 to 8 byte integer 
or floating point numbers 

  

Collection Variables Comment 

Continous, decimal time 
variable or ISO8601 dates 
of the form 2003-02-
17T13:57:12.3 in a single 
column with column label 
time_ISO8601. 

To be used as primary variable 

Unlimited number of other 
measured or calculated va-
riables 

Must be numeric; 1 to 8 byte integer or floating point numbers 
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3.2.3 Trajectory Data 

This category covers observations made from a moving platform (e.g., ship, drifter, 
float, glider, airplane, etc.) that are repeated over time. Examples are underway mea-
surements of hydrographic parameters at a given depth made during a ship expedition 
and from actively moving or passively drifting Lagrangean instruments.  In all these 
cases each individual measurement made at a given location and time should be treated 
as an individual station, using the depth or elevation of the measurement as primary 
collection variable and the other metavariable and collection variable assignments from 
Table 3-6. Trajectory data of this form have exactly one sample per station. The number 
of stations equals the number of observation along the trajectory, which is usually large. 

 
Table 3-6: Recommended meta- and collection variable assignments for trajectory data. 

Metavariables Values 

Cruise Cruise, expedition, or instrument name 
Station Unique station identifier 
Type B 
yyyy-mm-ddThh:mm:ss.sss Date and time of the measurement 
Longitude [degrees_east] Longitude of the measurement 
Latitude [degrees_north] Latitude of the measurement 
  
Bot. Depth [m] Bottom depth or elevation at station 
Unlimited number of other 
metavariables describing 
the individual measurement 

Text or numeric; user defined text length or 1 to 8 byte integer 
or floating point numbers 

  

Collection Variables Comment 

Continous, decimal time 
variable  

To be used as primary variable 

Unlimited number of other 
measured or calculated va-
riables 

Must be numeric; 1 to 8 byte integer or floating point numbers 

 

3.3 Creating Collections 

You create a new ODVCF5 collection by choosing File>New from the menu bar. You then 
select a directory in which the collection should be created and specify a name1

                                                 
1 The following characters should not be used in collection names: \ / : * ? “ < > | SPACE 

 for the 
new collection. ODV then lets you define the variables that will be stored in the collec-



ODV User’s Guide  
 

    23 

tion. Collection variables can be specified in a number of ways. You may use variable 
names from a supported template file (.txt, .odv, .var, or an ASCII spreadsheet file with 
arbitrary extension), you may enter the variable labels manually, or you may use pre-
defined sets of variables suitable for various published oceanographic datasets. ODV 
will present a dialog offering all these choices and a long list of pre-defined collection 
variable sets. These include variable sets for ARGO profile and trajectory data, variables 
for the World Ocean Database published by the U.S. NODC, variable sets for various da-
tatypes from the World Ocean Circulation Experiment (WOCE) and various variable 
sets for data from the Medatlas project. 

If you requested to use a template file for the variable definition a file open dialog ap-
pears, and you should navigate to and select the template file you want used. You will 
then be prompted with a Metavariables dialog (Figure 3-1) that lets you manipulate the 
list of metavariables and edit the properties of each of these metavariables. Note that 
the first eleven metavariables (up to and including Second) are mandatory. You may 
change properties of mandatory metavariables (select the variable and press Edit), but 
you may not delete or reorder them. Other metavariables may be reordered, deleted, or 
their properties may be edited. To add additional metavariables press New and define 
the properties of the new metavariable (see Properties dialog below). The total number 
of metavariables is unlimited. 

 

 
Figure 3-1: Dialog for the definition of metavariables.  

 

If you want to inspect or modify the properties of a metavariable select it and press 
Edit. A Properties dialog (Figure 3-2) appears that lets you specify label and units of the 
variable, the number of significant digits used to display values in the current station 
window (if numeric), the quality flag scheme to be used for this variable, and the data 
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type and byte length (if text). 

When entering a label or units for the metavariable you may use formatting control se-
quences to create subscripts, superscripts, and special symbols. Labels and units may 
not contain ; or TAB characters. If you need better than about 100 m precision for 
station positions, make sure to use datatype DOUBLE for longitude and latitude. Also 
make sure not to use datatype TEXT for longitude, latitude, or any of the time 
metavariables. For a description of the supported quality flag schemes and the 
mappings between the schemes see file ODV4_QualityFlagSets.pdf. 
 

 
Figure 3-2: Properties dialog for meta- and collection variables. 

 

 
Once the metavariables are defined, a similar dialog appears for the setup of the list of 
collection variables (Figure 3-3). On this dialog you may reorder or delete variables, 
you may add new variables, or you may edit the properties of existing variables using a 
dialog similar to Figure 3-2. When entering a label or units for the variable you may use 
formatting control sequences to create subscripts, superscripts, and special symbols. 
Labels and units may not contain any of the following characters: ‘;’ ‘TAB’. For a 
description of the supported quality flag schemes and the mappings between the 
schemes see file ODV4_QualityFlagSets.pdf. 
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Figure 3-3: Dialog for the definition of collection variables. 

 

As last step in the definition of new collections you have to specify the field and type of 
data to be stored in the collection, you have to identify the primary variable to be used 
to sort the samples, and you have to specify the quality flag schemes to be used for sta-
tion and sample quality flags (Figure 3-4).  

ODV then creates the collection and draws a global map on the canvas. Note that at this 
stage the collection is still empty and does not contain any station data. You must im-
port data into the collection using options from the Import menu on the menu bar. Note 
that all dialogs that appear during collection creation contain meaningful initial set-
tings. If you don’t have special requirements you can simply press OK on all these di-
alogs to generate perfectly valid collections. 

 

 
Figure 3-4: Dialog for the definition of collection properties. 
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3.4 Collection Files 

This section provides an overview over the directory structure and the various files that 
make up an ODVCF5 or ODVGENERIC collection, repectively. The information is pro-
vided for expert users and may be useful in case of problems or unexpected behavior. 
Normally, a user need not be concerned with the collection file structure.  

3.4.1 ODVCF5 

The information about meta- and collection variables is stored in file <col>.odv. This is 
the definition file of collection <col>, and this file has to be selected when opening a col-
lection. On Windows the .odv filetype is associated with the ODV executable, e.g., double 
clicking on a .odv file will start ODV and open the collection. The directory containing 
the .odv file is the collection’s root directory. All other files of the collection are con-
tained in a subdirectory of the collection’s root directory named <col>.Data (collection 
base directory).  

The collection base directory contains the collection’s metadata and data files as well as 
other subdirectories for specific file types, such as views and sections or graphics ob-
jects. xview files store view settings that define the way the user "looks" at the data in a 
collection. View settings include items such as map domain, station and sample selec-
tion criteria, window layout and many other parameters.  

To copy or move a ODVCF5 collection you must copy or move the .odv file and the 
<col>.Data directory, including all its subdirectories. ODV collection files should not be 
edited manually. 

 

Table 3-7: Summary of ODVCF5 collection files. Collection names <col> may not contain / or \, and should 
not contain spaces for platform independence.  

File Format Comment 

   

Collection files 

<col>.odv ASCII Defines meta- and collection variables, collection field and type. On 
Windows this file type is associated with the ODV executable, e.g. 
double-clicking on the .odv file will start ODV and open the collection.  

   

Subdirectory <col>.Data 
metadata binary Stores the station metadata (name, position, date, etc.).  
data binary Stores the station data and quality flags. 
   
info ASCII Description of the collection (free form text format; file is optional).  
inventory binary Collection’s inventory listing by cruises. 
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logfile ASCII Collection’s log file. Keeps records of data changes. 
settings ASCII Contains settings, such as key variable identifications, name of most 

recently used view file, or recent import and export directories.  
 
 
Table 3-8: Summary of ODVCF5 view and section files. File names <name> are arbitrary. Default location of 
xview and sec files is directory <col>.Data/views, but these files may also be stored in any other directory. 

Extension Format Comment 

<name>.xview ASCII View files storing layout, value ranges, derived and isosurface variable 
selections, and many other settings. The name of the collection that 
owns a configuration is recorded inside the xview file. Certain restric-
tions apply, if a different collection uses the xview file.  

< name >.sec ASCII Stores section outlines and characteristics. 
 

3.4.2 ODVGENERIC 

The information about collection variables, station metadata and actual station data are 
stored in separate files (.var, .hob and .dob, respectively). cfg files store view settings 
that define the way the user "looks" at the data in a collection. View settings include 
items such as map domain, station selection criteria, window layout and many other 
parameters. The required .var, .hob and .dob files of a collection must all be located in 
the same directory (collection directory). cfg files may be stored anywhere on the disk.  

ODVGENERIC collections are supported by ODV4 for reasons of backward compatibility. 
All new collections created by ODV4 are ODVCF5 collections. ODV collection files should 
not be edited manually. 

 

Table 3-9: Summary of ODVGENERIC collection files. Collection names <col> may not contain / or \, and 
should not contain spaces.  All files must be located in the same directory (collection directory). 

File Format Comment 

   

Basic files  Must be present.  
<col>.var ASCII Defines collection variables, stores collection name and number of 

stations. On Windows this file type is automatically associated with 
the ODV executable, e.g. double-clicking on the .var file starts ODV and 
opens the respective collection.  

<col>.hob binary Stores the station meta-data (name, position, date, etc.). 
<col>.dob binary Stores the actual station data and quality flags. 
   

Info File  Optional 
<col>.info ASCII Description of the collection (in freeform text format). ODV automati-
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cally creates an .info file containing information on dimensions and 
variables, when opening a netCDF file. 

   

Auxiliary 
Files 

 Automatically created if not present 

<col>.inv ASCII Collection inventory listing by cruises. 
<col>.cid binary Cruise ID numbers 
<col>.log ASCII Collection log file. Keeps records of data changes. 
<col>.idv ASCII Lists IDs of key variables used as input for derived variables (depth, 

temperature, oxygen, etc.) 
<col>.cfl ASCII Contains names of most recently used configuration file and output 

directory. 
 
 

Table 3-10: Summary of ODVGENERIC view and section files. File names <name> are arbitrary. cfg and sec 
files may be located in any directory. 

Extension Format Comment 

<name>.cfg binary Configuration files storing layout, value ranges, derived and isosurface 
variable selections, and many other settings. The name of the collec-
tion that owns a configuration is recorded inside the cfg file. Certain 
restrictions apply, if a different collection uses the cfg file. 

< name >.sec ASCII Stores section outlines and characteristics. 
 

3.5 Platform Independence 

Data collections and view files produced with ODV are platform independent and can be 
used on all supported systems (Windows, Mac OS X, Linux, and UNIX) without modifica-
tion.  
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4 Importing Data 

ODV can import new data and append the imported data to existing collections or add 
the data to newly created collections. Support is provided for a large variety of file for-
mats, including many of the important oceanographic data formats as well as a wide 
range of column oriented spreadsheet files. Data imports can be done one file at a time, 
or, alternatively, by handling a potentially large number of import files in one import 
procedure. The import files may be selected manually via file selection dialogs or by 
providing a list of file names in a separate file. The make_lst utility is provided to facili-
tate the creation of import file lists on Windows (see make_lst.README in the bin_w32 
directory of your ODV installation). On Linux, UNIX or OS X you use the system’s ls 
command to generate file lists. 

4.1 ODV Spreadsheet Files 

ODV can read and import data from a variety of spreadsheet-type ASCII files. If the for-
mat of the import file is ODV generic spreadsheet format compliant, the data import will 
be fully automatic and no user interaction is required. ODV generic spreadsheet files 
can be opened using File>Open or they can be dropped on the ODV window or icon. 
Other spreadsheet data files can also be read and imported by ODV, however, the im-
port of these files usually requires input by the user, usually by identifying the particu-
lar columns in the import file that provide the data for meta- and data variables in the 
collection (e.g., longitude, latitude, date, etc.) 

It is possible to import spreadsheet files with or without station metadata information 
and with or without column labels. ODV spreadsheet files may contain comments, and 
the column separation character may be TAB or semicolon ;. Missing data may be indi-
cated by special numeric or text indicators or by empty data fields. The spreadsheet 
files may contain data for many stations from one or more cruises. Each station may 
contain an unlimited number of samples (one line per sample). The samples of a station 
must be in consecutive order but need not necessarily be sorted.  

When reading a spreadsheet file, ODV breaks the data into stations whenever one or 
more of the entries for Cruise, Station, and Type change from one line to the next. A sta-
tion break also occurs if the date changes by more than one day or the time changes by 
more than 12 hours, even if Cruise, Station, and Type remain unchanged. If Station in-
formation is not provided in the data file, the Date, Time, Longitude and Latitude values 
are checked, and a station break occurs whenever one or more of these values change. 
All metadata of a station, such as date, time, longitude, and latitude, are taken from the 
first sample line of the station in the import file. 

Imported data from the file are added to the currently open data collection, or, if no col-
lection is currently open, are added to a newly created collection. 

To import data from a spreadsheet file into the currently open collection choose Im-
port>ODV Spreadsheet and use the standard file-select dialog to identify the data file. 
Specify import options and press OK to start the data import.  Spreadsheet files can also 
be dragged and dropped onto the ODV icon or an open ODV window. 
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If the file is not a generic ODV spreadsheet file, a Spreadsheet File Properties dialog box 
appears and lets you specify the column separation character and one or more missing 
data values. Note that multiple missing data values must be separated by one or more 
spaces. Fields in the import file that are empty or contain one of these values are consi-
dered missing data. You can also specify the first data line and the line containing the 
column labels. ODV provides reasonable defaults for all items and only a few changes 
should be necessary in most cases. For the Column separator choose the character that 
will give a vertical list of labels in the Column labels box. Press OK when all spreadsheet 
file properties are set, or press Cancel to abort the import. 

 

 
Figure 4-1: The spreadsheet file properties dialog. 

 

If the labels for the metadata columns differ from the recommended labels defined in 
the ODV generic spreadsheet format (see below), a Metavariable Association dialog box 
appears. This dialog lets you associate input columns with the collection metavariables, 
or it lets you set defaults for those metavariables not provided in the input file. Already 
associated variables are marked by asterisks (*). See chapter Metavariable Association 
Dialog for more details. 

4.2 World Ocean Database Data 

You can use ODV to import original hydrographic data from the US NODC World Ocean 
Database (WOD) into existing or new data collections. ODV currently supports WOD 
versions 2005, 2001 and 1998, and you can use data files either from the WOD CD-
ROMs or downloaded from the WOD web site. To import WOD data into an existing col-
lection, open the collection. To import into a new collection, create the collection and 
make sure you choose World Ocean Database variables when defining the collection 

http://www.nodc.noaa.gov/OC5/WOD05/pr_wod05.html�
http://www.nodc.noaa.gov/OC5/WOD05/pr_wod05.html�
http://www.nodc.noaa.gov/OC5/WOD05/pr_wod05.html�
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variables. To manually select one or more WOD data files for import into the currently 
open collection choose Import>U.S. NODC Formats>World Ocean Database. Use the 
standard file open dialog to select one or more WOD .gz data files to be imported. 
Choose file-type All Files (*.*) if you want to select WOD files that are already unzipped.  

Then specify station selection criteria to be satisfied by WOD stations (simply press OK 
to import all stations falling into the current map domain), specify import options and 
press OK to start the data import. ODV will read the selected WOD data files and import 
all stations that satisfy the station selection criteria. The cruise labels of the imported 
stations consist of the WOD identifier (WOD05, WOD01 or WOD98) followed by the two 
characters NODC country-code. The unique OCL profile number is used by ODV as sta-
tion number. ODV recognizes and uses the NODC data quality flags found in the import 
files (see below). Quality flags provided by the data originators are ignored. ODV rep-
laces invalid day information in the date of observation with the mid-month value 15. 

As an alternative to manual selection of import files using the file open dialog, you can 
prepare an ASCII file containing the names of all the files that you want to import and 
then select the list file on the file open dialog. This is useful if you want to import many 
files from more than one directory, or, simply, if you plan to repeat the import and don’t 
want to manually select a large number of files again. The filenames in the list file must 
be absolute pathnames, one filename per line. Default extension of ODV list files is .lst. 
On Windows you can use the make_lst utility to create import file lists (see 
make_lst.README in the bin_w32 directory of your ODV installation). On Linux, UNIX or 
Mac OS X you use the system’s ls command to generate file lists. 

Once the list file is created you choose Import>U.S. NODC Formats>World Ocean Data-
base and select the previously created list file. As before, you then specify station selec-
tion criteria (simply press OK to import all stations falling into the current map do-
main), specify import options and press OK to start the data import. ODV will read all 
the files listed in the list file and will import all stations satisfying the station selection 
criteria. 

Note that ODV only imports stations falling into the current map domain. To ensure that 
all data from the WOD files are imported you should choose Global Map from the map 
popup menu before starting the import.  

Also note that WOD data often contain a significant amount of data that have been 
flagged by data originators or by the U.S. NODC as being of poor or questionable quality. 
ODV imports and maintains the data quality information in the WOD files, and automat-
ically maps WOD quality flags to the quality flag scheme used in the target data collec-
tion. If the target collection was created using World Ocean Database variables, the col-
lection variables use the WOD quality flag scheme, and the original WOD quality flags in 
the import files will be maintained in the ODV collection. When viewing the data, you 
may want to apply data quality filters via option View>Sample Selection Criteria to ex-
clude questionable and bad data from the analysis.  

4.3 World Ocean Atlas Data 

You can use ODV to import original hydrographic data directly from the distribution 
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CDs of the World Ocean Atlas 1994 by choosing Import>World Ocean Atlas 94>Single 
File. Use the standard Windows file-select dialog to identify the data file (*.ol) of the 
WOA94 data set that you want to import. Specify station selection criteria to be satisfied 
by WOA94 stations (simply press OK to import all stations falling into the current map 
domain), specify import options and press OK to start the data import. ODV will read 
the selected WOA94 data file and import all stations that satisfy the station selection 
criteria.  

You can import data from multiple WOA94 files using the same station selection criteria 
and import options in a single import operation. To do so, prepare an ASCII file (default 
extension .lst) containing the names of the files to be imported (full pathnames, one per 
line). Choose Import>World Ocean Atlas 94>Multiple Files, specify station selection cri-
teria to be satisfied by WOA94 stations (simply press OK to import all stations falling 
into the current map domain), specify import options and press OK to start the data 
import. ODV will read all the files listed in the ASCII file and will import all stations that 
satisfy the station selection criteria. 

Note that ODV only imports stations falling into the current map domain. To ensure that 
all data from the WOD files are imported you should choose Global Map from the map 
popup menu before starting the import.  

4.4 ARGO Float Data 

You can use ODV to import float profile and trajectory data from single or multiple 
ARGO netCDF version 2.2 or 2.1 format files into ODV float profile or trajectory data 
collections. ARGO files can be downloaded from the Coriolis and GODAE data centers at 
http://www.coriolis.eu.org/cdc/argo.htm and 
http://www.usgodae.org/argo/argo.html.  

ARGO profile or trajectory data should be imported into data collections using the 
ARGO profile or trajectory variables. If you don’t already have such a collection open, 
create one using the File>New option. When prompted to define the collection variables 
choose ARGO profile variables or ARGO trajectory variables depending on the type of 
data that you want to import. To initiate the data import choose Import>ARGO For-
mats>Float Profiles (netCDF v2.2 or v2.1) or Import>ARGO Formats>Float Trajectories 
(netCDF v2.2 or v2.1). ODV then presents a standard file open dialog and lets you select 
one or more ARGO netCDF data files in a given directory. Alternatively, you may select 
an ASCII file containing the list of file names to be processed. This list file has to be pre-
pared before you start the import. It must contain one filepath entry per line, and the 
file paths must be either absolute pathnames or pathnames relative to the currently 
open collection. The list file must have extension .lst. On Windows you can use the 
make_lst utility to create import file lists (see make_lst.README in the bin_w32 directory 
of your ODV installation). On Linux, UNIX or Mac OS X you use the system’s ls command 
to generate file lists. 

ODV then displays the import options dialog. If you import into a collection created for 
ARGO float profile or trajectory data (see above) you may simply press OK to start the 
data import. 

http://www.coriolis.eu.org/cdc/argo.htm�
http://www.usgodae.org/argo/argo.html�
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The variables in ARGO profile or trajectory collections include pressure, temperature, 
salinity and oxygen. These variables come in three versions: (1) the real-time or raw 
data (first group), (2) the delayed-mode or adjusted data (second group; suffix (adj.) in 
the variable label), and (3) the adjustment errors (third group; suffix (adj. error) in the 
variable label). Note that in real-time data files there are no data for groups 2 and 3.  

ARGO data quality flags in the netCDF file are recognized and converted to the quality 
flag schemes of the target variables during import. If the target collection is an ARGO 
profile or trajectory collection created by ODV4 or later, no quality flag conversion oc-
curs, and the original ARGO quality flag values are stored in the collection. For details of 
the quality flag mapping see the file ODV4_QualityFlagSets.pdf. Any Depth values in 
ARGO profile files are converted to pressure during import. 

For ARGO profile data, the ODV station name consists of cycle number, profile direction 
(if available; A ascending, D descending), the data mode (R real time data, D delayed 
mode data, A real time data with adjusted values), and the project name (if available).  
The ARGO platform number is used for Cruise. 

When importing ARGO trajectory files, ODV averages pressure, temperature, salinity 
and oxygen values for given float cycles (pressure>100 dB required), and uses these 
average values in the collections. Only records with valid geographical position are im-
ported. 

Once imported, you may filter the data and exclude bad data from the analysis by set-
ting appropriate quality flag selection criteria via the View>Sample Selection Criteria 
option. 

4.5 WOCE Hydrographic Data 

You can use ODV to import original hydrographic data in WHP exchange format into 
existing or new data collections. WHP exchange format data files can be found at the 
WHP DAC (http://whpo.ucsd.edu/) or on the final WOCE data release on DVD-ROM. To 
import the data into an existing collection, open the collection. To import into a new 
collection, create the collection and make sure you choose either WOCE WHP Bottle va-
riables or WOCE WHP CTD variables when defining the variables to be stored in the col-
lection.  

To import WHP exchange format bottle data into the currently open collection choose 
Import>WOCE WHP Bottle (exchange format)>Single File from ODV’s main menu. Use 
the standard file-selection dialog to select the WHP data set. Note that the default ex-
tension of WHP exchange files is .csv. If your data file has a different extension, choose 
file-type All Files in the file-selection dialog. Then specify import options and press OK 
to start the data import. ODV will read and import all stations in the data file. ODV iden-
tifies and imports the WOCE data quality flags in addition to the actual data values. 
These quality flags can later be used to filter the data by excluding, for instance, bad or 
questionable data from the analysis. You can modify the data quality filter by choosing 
selection criteria from the map popup menu (choose the Sample Selection tab). 

To import CTD data into the currently open collection, choose Import>WOCE WHP CTD 

http://whpo.ucsd.edu/exchange/index.htm�
http://whpo.ucsd.edu/�
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(exchange format)>Single File from ODV’s main menu and select the .zip file that con-
tains the CTD data to be imported. Then specify vertical sub-sampling parameters or 
keep the default setting, which is no sub-sampling. ODV will then unpack the .zip file 
and import all CTD stations into the currently open collection.  

You can import data from multiple WHP exchange files in a single import operation. In 
such a case the same import options are used for all files imported during the operation. 
For multi-file data import you have to prepare a ASCII file with default extension .lst 
that contains the names of the files to be imported. Use full pathnames, and specify one 
file name per line. Then choose either Import>WOCE WHP Bottle (exchange for-
mat)>Multiple Files or Import>WOCE WHP CTD (exchange format)>Multiple Files, specify 
import options and press OK to start the data import.  

Note that ODV can handle up to 20,000 samples per station. CTD stations with more 
samples are truncated. Also note that ODV automatically converts pressure in the 
source files to depth in the collection. If you need pressure as a variable, you should es-
tablish the derived variable Pressure(Depth). 

During import, ODV maps WHP or IGOSS quality flags found in the WOCE import files to 
corresponding ODV quality flags. For details of the quality flag mapping see the Appen-
dix. You may exclude questionable and/or bad data from the analysis by setting appro-
priate quality flag selection criteria via the Configuration>Selection Criteria>Quality op-
tion. 

4.6 SD2 Hydrographic Data 

You can use ODV to import original hydrographic data from NODC SD2 files into exist-
ing or new data collections. To import into an existing collection, open the collection. To 
import into a new collection, create the collection and make sure you choose NODC SD2 
variables when defining the variables stored in the collection. To import SD2 data into 
the currently open collection choose Import>NODC SD2 Format>Single File. Use the 
standard file-selection dialog to identify the data file to be imported. Specify import op-
tions and press OK to start the data import. 

If you want to import multiple SD2 files in one import operation, put all the SD2 files in 
a single directory and produce a file containing the list of SD2 file-names that you want 
to import (default list-file extension .lst; one file-name per line). Choose Import>NODC 
SD2 Format>Multiple Files and select the list-file. 

4.7 Medatlas Format Data 

The Medatlas format was used to create the MEDAR/Medatlas 2002 data compilation, 
containing water column data for the Mediterranean and Black Sea (MEDAR Group, 
2002 - MEDATLAS/2002 database, Mediterranean and Black Sea database of tempera-
ture salinity and bio-chemical parameters. Climatological Atlas. IFREMER Edition (4 
CDs)). The Medatlas format is also used for various types of time series data, ranging 
from current meters, thermistor chains, sea level gauges, meteorology buoys to sedi-
ment traps.  
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ODV lets you import all these diverse data types. Because variable sets for the different 
data types differ greatly, it is essential to ensure that the receiving data collection uses a 
matching set of variables. There are predefined variable sets for Medatlas bottle and 
CTD profile data, as well as two variable sets for time series data (one for sediment trap 
data and one for all other time series data). When creating new collections for Medatlas 
data the user should choose the appropriate variable set (see below). 

Medatlas formatted data can be imported into arbitrary ODV data collections; however, 
manual associations of Medatlas import variables with the collection target variables 
are usually required. To facilitate data import and avoid manual variable associations 
you should create target collections using the appropriate Medatlas variables sets. To 
create such collections use the File>New option. When prompted to define the collection 
variables choose Medatlas Bottle variables for Medatlas bottle data, Medatlas CTD va-
riables for Medatlas CTD, XBT or MBT data, Medatlas Sediment Trap variables for Medat-
las sediment trap data, or Medatlas Time Series variables for all other Medatlas time se-
ries data (e.g., data from current meters, thermistor chains, sea level gauges, or meteor-
ology buoys).  

To initiate the data import choose Import>Medatlas Formats>Profile Data for bottle, 
CTD, XBT or MBT data or Import>Medatlas Formats>Time Series Data for any kind of 
time series data. Both import types allow selection of one or more Medatlas data files to 
be imported. Alternatively, you may also select a text file containing the list of file 
names to be processed. This list file has to be prepared before starting the import. It 
must contain one file entry per line, and the file names must be either absolute path-
names or pathnames relative to the currently open collection. The list file must have 
extension .lst. On Windows you can use the make_lst utility to create import file lists 
(see make_lst.README in the bin_w32 directory of your ODV installation). On Linux, 
UNIX or Mac OS X you use the system’s ls command to generate file lists. ODV then 
shows the import options dialog and then starts the data import. 

Note that Medatlas time series and sediment trap data collections created by ODV4 or 
later contain a metavariable Instrument Depth that contains the deployment depths of 
the respective instruments, such as current meters, thermistors, sea level gauges, mete-
orology buoys or sediment traps.  

Multiple variables in Medatlas profile data files of the same type but in different units 
are merged during import, possibly involving unit conversions and/or offset correc-
tions. 

The following merging operations are performed: 
Salinity [psu] = 

1 *   (PSAL PRACTICAL SALINITY P.S.U.)    + 0 

1 *   (SSAL SALINITY (PRE-1978 DEFN) P.S.U.)   - 0.004 

Oxygen [ml/l] = 

1 *   (DOX1 DISSOLVED OXYGEN ml/l)    + 0 

  0.02297 *  (DOX2 DISSOLVED OXYGEN micromole/kg)   + 0 

  0.02241 *  (DOXY DISSOLVED OXYGEN millimole/m3)   + 0 
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Silicate [millimole/m3] = 

1 *   (SLCA SILICATE (SiO4-Si) CONTENT millimole/m3)  + 0 

1.025 *  (SLCW SILICATE (SiO4-Si) CONTENT micromole/kg)  + 0 

Nitrate + Nitrite [millimole/m3] = 

1 *   (NTRZ NITRATE + NITRITE CONTENT millimole/m3)  + 0 

1.025 *  (NTZW NITRATE + NITRITE CONTENT micromole/kg)  + 0 

Phosphate [millimole/m3] = 

1 *   (PHOS PHOSPHATE (PO4-P) CONTENT millimole/m3)  + 0 

1.025 *  (PHOW PHOSPHATE (PO4-P) CONTENT micromole/kg)  + 0 

Alkalinity [millimole/m3] = 

1 *   (ALKY ALKALINITY millimole/m3)     + 0 

1.025 *  (ALKW ALKALINITY micromole/kg)     + 0 

 

In each case the list of alias variables is traversed until a (possibly converted) value is 
found. Note that the density ρ of the sample at laboratory conditions is needed for the 
conversion from volumetric units (e.g., millimole/m3) to per unit mass units (e.g., 
micromole/kg)2

The GTSPP quality flags in Medatlas data files are recognized and converted to the qual-
ity flag schemes of the target variables during import. If the target collection is a Medat-
las profile, time-series or sediment trap collection created by ODV4 or later, no quality 
flag conversion occurs, and the original GTSPP quality flag values are stored in the col-
lection. For details of the quality flag mapping see the file 

. This information, however, is not included in the Medatlas files, and an 
approximate conversion formula has to be applied. Using a constant density value of 
ρ=1.025 [kg/l] as above introduces errors smaller than 0.2% and seems permissible. 

ODV4_QualityFlagSets.pdf.  

4.8 Other Hydrographic Data 

In addition to the specific import formats described above, ODV also supports the im-
port of data from a variety of other formats, including Java Ocean Atlas spreadsheet 
format as well as the netCDF formats of most WOCE data streams. To import data in one 
of these formats into the currently open collection select the appropriate option from 
the Import menu. Note that for many import routes there is a choice between selecting 
one or more import files on file dialogs and providing a list file containing the names of 
the files to be imported. In all cases the user has to specify appropriate import options. 
During import, ODV maps data quality flags found in the import files to corresponding 
ODV quality flags of the meta- and collection variables. For details of the quality flag 
mapping see file ODV4_QualityFlagSets.pdf. ODV also supports a wide variety of other 
spreadsheet formats, including simple three column files with XYZ data.  
                                                 
2 Gordon, L. I., J. Joe C. Jennings, A. A. Ross, and J. M. Krest, 1993: A Suggested Protocol for Continuous Flow Automated Analysis of 
Seawater Nutrients (Phosphate, Nitrate, Nitrite and Silicic Acid) in the WOCE Hydrographic Program and the Joint Global Ocean Fluxes 
StudyWHPO 91-1, 55 pp (see page 48f). 
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4.9 Associate Metavariables Dialog 

When importing data, ODV will try to automatically detect the sources in the import file 
for mandatory metadata, such as cruise and station names, date of observation and 
geographical location. If this automatic association of metavariables is not successful 
the Associate Metavariables dialog appears (see Figure 4-2), asking the user to identify 
the sources of metadata manually.  

To define a new association select items in the Source Variables and Metavariables lists 
and press Associate. To invoke a conversion during import press Convert and choose 
one of the available conversion algorithms. To delete an existing association, select the 
respective variables and press Undo. If the import file does not contain information for a 
given metavariable you can specify a default value as follows: (1) select the respective 
metavariable; (2) press Set Default and (3) enter the default value. Note that the speci-
fied default settings are used for all data lines in the file. Press OK when done or Cancel 
to abort the import procedure. Finally specify import options and press OK to start the 
data import.  

Note that associations or conversions of composite source variables, such as the ISO 
8601 date and time specification YYYY-MM-DDTHH:MM:SS.SSS will automatically connect 
with multiple metavariables (e.g., Year, Month, Day, etc.). 

 

 
Figure 4-2: The Associate Metavariables dialog 

 

4.10 Import Options Dialog 

When importing data, ODV will present an Import Options dialog that lets you control 
the actions taken during data import (see Figure 4-3). 

Import Mode 
Add/Replace Station Data: Choose this option if you want to add data from the im-
port file to the collection. If the Check for existing stations box is checked, ODV 
searches the collection for stations with the same name, date and position and (if 
found) asks for permission to replace the existing station in the collection with the 
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new version from the import file (see Cruise Label Association below for a descrip-
tion of the station search procedure). 
 
Merge Data (selected variables): Choose this option if you want to add data for one 
or more variables (merge variables) and leave existing data for other variables 
unchanged. A merged value of a merge variable at a given sample depends on ex-
isting and new variable values according table 4-1. Note that the Check for existing 
stations box cannot be unchecked for this mode. Before adding data, ODV searches 
the collection for matching stations (see Cruise Label Association below for a de-
scription of the station search procedure) and if found, reads the original station 
from the collection, adds the data for the selected variables and replaces the origi-
nal station with the updated version. If no matching station is found, the user is 
notified. 
 

Table 4-1: Results of merging existing and imported values. 

Existing value New value Merged value 
yes yes Average of existing and new values 
yes no Existing value 
no yes New value 
no no Missing value 

 
 
Update Data (selected variables): Choose this option if you want to update data for 
one or more variables (update variables) and leave existing data for other va-
riables unchanged. An ”updated” value of an ”update variable” at a given sample 
only depends on the new variable values and existing values are discarded. Note 
that the Check for Existing Stations box cannot be unchecked for this mode. Before 
updating data, ODV searches the collection for matching stations (see Cruise Label 
Association below for a description of the station search procedure) and if found, 
reads the original station from the collection, updates the data for the selected va-
riables and replaces the original station with the updated version. If no matching 
station is found, the user is notified. 
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Cruise Label Association 
When replacing or merging data, ODV first searches the target collection for an ex-
isting station matching the given station to be imported. This search is made by 
comparing cruise name, station name, station type, longitude, latitude and date. 
For a successful match, station name and station type are required to be identical. 
Longitudes and latitudes must agree within a 0.2° tolerance, and the dates may 
deviate by at most one day. For cruise names, you can establish alias names using 
the Target and Source combo-boxes. If, for instance, in the existing collection a set 
of stations is named 06MT15/3 and in the import file the same stations are named 
METEOR15/3 you can set up an alias name by first choosing 06MT15/3 from the 
Target combo-box and then typing METEOR15/3 in the source field. Exact cruise 
name matches are required if no aliases are defined.  

 

 
Figure 4-3: The Import Options dialog 

 
 

Variable Association 
Usually the number, order and meaning of variables stored in the import file differ 
from the number, order and meaning of variables stored in the collection. There-
fore you must establish a source/target association of variables. ODV automatical-
ly associates variables with matching labels (name and units). Note that asso-
ciated variables are marked with a *. You can click on such a variable to identify 
its associated variable.  
 
To establish a variable association manually click on the respective source varia-
ble, then click on the target variable to be associated with the source variable and 
either press the Associate or Convert buttons. Use Associate if the data values in 
the import file should be imported without modification, but use Convert if you 
need to transform units during import. When using Convert, you can choose be-
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tween predefined, commonly used transformations and you can establish your 
own general linear transformation formula.  
 
For ODV Spreadsheet imports you can set default values for target variables for 
which no corresponding source variable is provided in the import file. This is use-
ful, for instance, if you import longitude/latitude maps of some quantity Z from 
ASCII files containing three columns X, Y, Z, but not containing data for the specific 
surface or depth level. To set a default value for a target value, first select a the va-
riable in the Target Collection list, then press the Use Default button and enter the 
desired default value for this target variable. Note that this target variables is now 
marked with a + sign. The specified value will be used for every sample of every 
station imported during this operation. 
  
Source variables not associated with a target variable will not be imported into 
the collection. If you merge data into the collection, establish associations only for 
those variables that you want to add to the collection. Note that the primary vari-
able of the collection must be associated in any case. 
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5 Exporting Data  

5.1 Spreadsheet Files 

You can export the data of the currently selected stations into a single ASCII ODV gener-
ic spreadsheet file by choosing Export>ODV Spreadsheet from ODV's menu bar. Then 
choose target directory and filename, select the variables to be included in the export 
file (default: all basic variables) and specify additional properties of the export file to be 
written. Note that spreadsheet files can be re-imported into ODV using the Import>ODV 
Spreadsheet option or by simply dropping the file onto the ODV icon. Note that output 
filenames may not contain any of the following characters “\”  “/”  “:”. They should not 
contain spaces. 

5.2 ODV Collection 

You can export the data of the currently selected stations into a new ODV collection by 
choosing Export>ODV Collection from ODV's main menu. Then select the variables to be 
included in the new collection (default: all variables) and specify destination directory 
and file-name using the standard file-select dialog-box. Note that valid ODV collection 
names may not contain spaces or any of the following characters: \ / :. 

5.3 Exporting X, Y, Z Window Data 

You can export the data values displayed in ODV plot windows to separate ASCII files by 
choosing Export>X, Y, Z Window Data from the ODV menu bar. Enter a descriptive text 
identifying the data of this export in the ID String field and click OK. ODV will create a 
sub-directory in the local ODV directory (normally <home>\odv_local) named export\< 
ID String>. All exported files will be written to this directory. If it already exists, ODV 
asks for your permission to delete all files from the directory before continuing. Note 
that the names of the exported files start with win?, where ? represents the respective 
window number. The actual X, Y, Z data are found in files win?.oai (one data point per 
line; fourth column always 1). 

For windows with gridded fields, ODV also exports the results of the gridding operation 
(files win?.oao). The format of the .oao files is as follows: 

 
0     (ignore) 

nx  ny     (no of x and y grid-points) 

... nx X-grid values ...  (X-grid positions) 

... ny Y-grid values ...  (Y-grid positions) 

... nx*ny gridded values ... (estimated field, line by line starting at first Y-grid value) 

... nx*ny gridded values ... (estimation quality, line by line starting at first Y-grid value) 
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5.4 Exporting Reference Datasets 

You can save the original data of the current plot windows in separate ASCII files and 
use these data later as reference datasets by choosing Export>X, Y, Z Window Data as 
Reference from ODV’s menu bar. Enter a descriptive text identifying the reference data 
in the ID String field and click OK. ODV will create a sub-directory in the local ODV direc-
tory (normally <home>\odv_local) named reference\< ID String> and writes all files to 
this directory. If the directory already exists, ODV asks for your permission to delete the 
current contents before continuing. Reference data are used by ODV for defining differ-
ence variables. 

5.5 Exporting Isosurface Data 

You can export the isosurface data of all stations currently shown in the map by select-
ing Export>Isosurface Variables and choosing a target directory and output filename. 
The output file includes the metadata of the stations and is ODV generic spreadsheet 
format compliant. 
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6 Derived Variables 

In addition to the basic variables stored in the collection files, ODV can calculate a large 
number of derived variables which (once defined) are available for analysis and use in 
the data plots in the same way as the basic variables. There are three types of derived 
variables: 

• built-in derived variables including many commonly used parameters from 
physical and chemical oceanography. 

• macro files of user defined expressions stored in files for use with arbitrary ODV 
collections. 

• expressions defined by the user on-the-fly for the current collection only. 

To define or delete derived variables choose the Derived Variables option from the cur-
rent sample window popup menu or View>Derived Variables from the menu bar. To add 
a macro, choose Macro File from the Choices list; to add a user defined expression 
choose Expression. To add a built-in derived variable choose any other item in the 
Choices list. 

6.1 Built-in Derived Variables 

Algorithms for many physical oceanographic parameters, such as potential tempera-
ture, potential density (relative to arbitrary reference pressures), neutral density, 
Brunt-Väisälä Freq., and dynamic height, are built into the ODV software. In addition, 
various parameters of the carbon dioxide system in seawater, the saturation concentra-
tions and partial pressures of many gases and many other variables from chemical 
oceanography are also available as easily selectable derived variables. Some useful ma-
thematical expressions, such as the ratio of two arbitrary variables as well as vertical 
integrals and derivatives, are also available. A list of built-in derived variables is shown 
below.  All these variables can be requested by the user, they are then calculated by 
ODV on-the-fly, and they can be analyzed and visualized in the same way as the basic 
variables stored in the collection files. 

To define or delete built-in derived variables choose the Derived Variables option from 
the current sample window popup menu. ODV will show lists of available and already 
defined derived variables. To add a derived variable select an item from the Choices list 
and press Add. If you define a derived variable that needs additional parameters (e.g., 
potential temperature and potential density requiring the reference pressure) you have 
to provide this information on dialog boxes that appear automatically. Many derived 
variables also require identification of the input variable(s) needed for the calculation 
of the derived variable. Note that this identification of key variables has to be done only 
once and that the associations are remembered by ODV. Use option Collection>Identify 
Key Variables to verify and modify key variable associations. Note that the calculated 
values of derived variables may be wrong, if key variable associations are not correct. 

To delete a derived variable select this variable in the Already Defined list box and press 
Delete or simply double-click on the item to be deleted. Note that when deleting a varia-
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ble that is required as input by other derived variables, these child variables are deleted 
as well. To edit the parameters of a derived variable, or the expressions of ODV macros 
and expressions (for more information on these special derived variables see below) 
select the respective variable in the Already Defined list box and press Edit. 

Table 6-1: List of built-in derived variables 

Variable Comment 

AOU [µmol/kg] Apparent oxygen utilization 
Brunt-Väisälä Freqency [cycl/h] EOS80 
CFC-11 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
CFC-12 Saturation [%] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
CFC-10 Saturation [%] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 
CFC-113 Saturation [%] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 
CH4 Saturation [%] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 
CO*2(TCO2,TALK) [µmol/kg] (details) 
CO32-(TCO2,TALK) [µmol/kg] (details) 
Day of Month(station date) Day of the Month derived from station date 
Day of Month (time variable) Day of the Month derived from a time variable 
Day of Year(station date) [days] Day of the Year [days] derived from station date 
Day of Year(time variable) [days] Day of the Year [days] derived from a time variable 
Difference from Reference Data (details) 
Dynamic Height [dyn m] EOS80 (any reference pressure) 
fCO2(TCO2,TALK) [µAtm] (details) 
Freezing Temperature [°C] F. Millero, UNESCO Tech. Papers in the Marine Science, No. 28., 29-35, 

1978 
HCO3-(TCO2,TALK) [µmol/kg] (details) 
Latitude Decimal latitude derived from station latitude 
Longitude Decimal longitude derived from station longitude 
Month of Year(station date) Month of Year derived from station date 
Month of Year(time variable) Month of Year derived from a time variable 
Neutral Density [kg/m3] Jackett & McDougall, J. Phys. Ocean., 237-263, 1997 (more) 
OmegaA(TCO2,TALK) (details) 
OmegaC(TCO2,TALK) (details) 
Oxygen Saturation [%] Weiss, Deep Sea Res., 17, 721-735, 1970 
pCFC-11 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
pCFC-12 [pptv] Warner & Weiss, Deep Sea Res., 32,1485-1497,1985 
pCFC-10 [pptv] Bullister & Wisegarver, Deep Sea Res., 45,1285-1302,1998 
pCFC-113 [pptv] Bu & Warner, Deep Sea Res., 42,1151-1161,1995 
pCH4 [ppbv] Wiesenburg & Guinasso,  J. Chem. Eng. Data,24,356-,1979 
pCO2(TCO2,TALK) [µAtm] (details) 
pHtot(TCO2,TALK)  (details) 
Potential Density [kg/m3] EOS80 (any reference pressure) 
Potential Temperature [°C] Bryden, Deep Sea Res.,20,401-408, 1973 (any reference pressure) 
Potential Vorticity [10-12 m-1 s-1] Planetary potential vorticity (derived from Brunt Vaissala Frequency 

Q=f/g*N2) 
Pressure [db] Saunders, J. Phys.  Ocean., 1981 
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Quality Flag Any variable 
Ratio Any two variables 
Revelle Factor(TCO2,TALK) (d fCO2 / d TCO2) / (fCO2 / TCO2). (details) 
Sound Speed [m/s] Fofonoff & Millard, Unesco Tech. Pap. in Mar. Sci._, No. 44, 53 pp, 1983 
Specific Heat Cp  [J/(kg °C)] F. Millero et al, J. Geoph. Res., 78, 4499-4507, 1973 
Specific Volume Anomaly  [mm3/g] EOS80 (any reference salinity and temperature) 
Time(station date&time) [yr] Decimal time [yr] derived from station date and time 
Time(time variable) [yr] Decimal time [yr] derived from a time variable 
Vertical Derivative Any variable 
Second Vertical Derivative Any variable 
Vertical Integral Any variable 
Year(station date) Year derived from station date 
Year(time variable) Year derived from a time variable 

 

Brunt-Väisälä Freqency 

Brunt-Väisälä Freqency is calculated as follows: For a given profile, ODV first establish-
es a sequence of standard depths and projects the observed pressures, temperatures 
and salinities onto these standard depths. Then Brunt-Väisälä Freqency is calculated for 
every standard-depth interval and assigned to the interval mid-point. Finally the mid-
point Brunt-Väisälä Freqency values are projected back to the original pressure (or 
depth) values of the profile. Projection of values is done using linear least-squares in-
terpolation. 

 

Parameters of the carbon dioxide system in sea water 

The following parameters of the carbon dioxide system in sea water are provided as 
derived variables:  

1. pH (total scale),  
2. Fugacity and partial pressure of CO2 (fCO2  and pCO2 ),  
3. Concentrations of CO*2, CO32-, and HCO3-,  
4. Revelle, or homogeneous buffer, factor,  
5. Solubility ratios [CO32-]*[Ca2+] / Ksp for calcite and aragonite, OmegaC and Ome-

gaA.  
 
All these quantities are calculated as functions of in-situ depth (or pressure), tempera-
ture, salinity, total inorganic carbon (TCO2), total alkalinity (TALK), phosphate and sili-
cate. If phosphate and/or silicate data are not available, concentration values of zero 
are assumed. ODV uses the alkalinity definition of Dickson (1981) and treats all terms 
except HS, S and NH3. pH is calculated using an iterative Newton method. 

The choice of equilibrium constants follows Dickson&Goyet (1994): K1, K2 are from Roy 
et al. (1993), K0 is from Weiss (1974), KB is from Dickson (1990), KS is from Dickson 
(1990), KF is from Dickson&Riley (1979), KW is from Millero (1995), K1p, K2p, K3p  and KSi 
are from Millero (1995), and the solubility products Ksp of calcite and aragonite are 
from Mucci (1983). The pressure dependence of the equilibrium constants is from Mil-
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lero (1995). Typographical errors in various publications (as summarized in Lew-
is&Wallace (1998)) are considered. 

The carbon chemistry implementation in ODV (versions 2.1 and later) has been checked 
by comparing with other, independent software output, and ODV results have been 
found to be in very good agreement with output from the CO2SYS.EXE application of 
Lewis&Wallace (1998). Note that pre-2.1 ODV versions calculated "potential" pH and 
carbon system parameters, e.g., the values a water parcel would have if raised to the 
surface adiabatically. These values are different from the in-situ values obtained by ODV 
versions 2.1 and later. 
DOE (U.S. Department of Energy). 1994. Handbook of methods for the analysis of the various parameters 
of the carbon dioxide system in sea water. Version 2. ORNL/CDIAC-74. A. G. Dickson and C. Goyet (eds.), 
Carbon Dioxide Information Analysis Center, Oak Ridge National Laboratory, Oak Ridge, Tenn. 

Lewis, E., and D. W. R. Wallace. 1998. Program Developed for CO2 System Calculations. ORNL/CDIAC-105. 
Carbon Dioxide Information Analysis Center, Oak Ridge National Laboratory, U.S. Department of Energy, 
Oak Ridge, Tennessee. 

 

Vertical Integral 
Select the variable for which the vertical integral is to be calculated (designated A in the 
following; any basic or already defined derived variable can be used) and specify the 
starting depth z0 for the integral (default: 0 m). For each sample of a given station, ODV 
will calculate the integral A*dz from z0 to the respective level. The units of the integral 
are the units of the quantity A times the units of depth (note that ODV4 uses m whereas 
previous ODV versions used km). For variables with volumetric concentration units 
(e.g., moles per cubic meter) the calculated integral is equivalent to "standing stock per 
square meters". Note that by definition the value of the integral at z0 is zero. (Example: 
To obtain the salt content in the top 500 m of the water column, select salinity as varia-
ble for the integral and use 0 as start value. Then look up the value of the vertical 
integral at 500 m (by interpolating between neighboring points) or in SURFACE mode 
define the integral at depth=500 as an isosurface variable.) 

6.2 Macros 

You can implement new derived variables not included in the list of built-in derived 
quantities provided that the value of your new derived variable for a specific sample 
only depends on other variable values of the same sample. In these cases you specify 
the input variables and the expression of the new derived quantity in a macro file. Ma-
cro files must have the extension .mac, they must be located in the ODV macros directo-
ry (<home>\odv_local\macros) and their format must follow the specifications given 
below. You can use the ODV Macro Editor (invoked by: Tools>Invoke Macro Editor) to 
facilitate macro definition. Use the example macro files distributed with ODV as sample 
files for your own definitions. 

You activate a macro derived variable by selecting Derived Variables from the current 
sample window popup menu and choosing Macro File from the list of available quanti-
ties. Then select one of the macro files found in the ODV macros directory 
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<home>\odv_local\macros and identify the variables needed to calculate the new quan-
tity. If one of the required variables is not available, press Not Available to abort setup 
of the macro file. 

6.2.1 Macro Editor 

You can create and edit Ocean Data View macro files using the Tools>Macro Editor op-
tion. Select an existing macro file or choose a new macro name and define the macro 
following the instructions below. When done press Save As and specify a name for the 
macro. 

 
Figure 6-1: The macro editor dialog 

 

Macro Variable 
Label:  Enter the label of the macro variable. Use formatting control sequences 

for greek symbols, exponents or indices. 

Units:  Enter the units of the macro variable. Use formatting control sequences 
for greek symbols, exponents or indices. 

Digits: Enter the number of significant digits for the display of values in the cur-
rent sample window. 

Comments 
Enter one or more comments lines describing the macro variable. 

Input Variables 
List of input variables needed for the macro variable. To add an input variable, enter its 
label and units into the New field and press the << button (note that you can use format-
ting control sequences). If you want to delete a defined input variable, select it in the 
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Defined list-box and press the >> button. The number of input variables is unlimited. 

Expression 
In the Expression field you specify the algebraic operations to be performed when the 
macro variable is evaluated. You can use the operators + - * / ** for the basic arithmetic 
operations, sqrt for the square root, min and max for minimum and maximum of two 
operands, ln and exp for the natural logarithm and exponential, sin and cos for sine and 
cosine (arguments in radians), abs for the absolute value, and int, floor, ceil for integer 
parts of the argument, respectively. You specify the macro formula using the Reverse 
Polish Notation, where operands precede operators. You use, terms of the form #1, #2, 
etc. to reference the values of the input variables.  

Use the symbol %H for the elevation at the station position (given in meters above sea 
level; positive for land and negative for ocean), %t  for the time of observation (in years 
since 1900 calculated from station date and time metadata; e.g., %t=84.4877 for 
Jun/27/1984), %d for the day of the year  (also calculated from station date metadata), 
%x  for the (east-) longitude and %y for the (north-) latitude, respectively. Note that 
the elevation variable %H is only available if the GEBCO1 and/or ETOPO2 optional 
packages are installed. 

You can store intermediate results of the calculations in internal variables %0, %1, etc. 
using the operators =%0, =%1, etc. Stored values can be used later in the calculation by 
typing %0, %1, etc. Note that the =%n operators consume their operands, e.g., the re-
spective value is taken off the stack. Operands and operators must be separated by one 
or more spaces. You may continue the definition of the macro expression on following 
lines, if necessary.  

The evaluation of macro formulas is implemented using a simple stack-based scheme:  

1. operands (constants or variable values, e.g., #1, #2, etc., %0, %1, etc., %H, %t, 
%d, %x, and %y) are added at the top of the stack as they appear, 

2. operators (+,  -,  *,  / , **, ln, etc.) take their operands from the top of the stack 
and push the result of the operation back at the top of the stack. 

At the end of a successful calculation the only element remaining on the stack is the fi-
nal result. 

  
Table 6-2: Example expressions 

Expression Meaning 

135 #1 *  #2 + PO = 135 * PO4 + O2  (with: PO4 as #1 and O2 as #2) 

%t 80 - 17.6 / exp #1 * 6.17)1980( −⋅ tec  (tritium decay correction to 1980; c as #1) 

#1 ln ln(#1) (natural logarithm) 

#1 ln 0.43429 * log(#1) (base-10 logarithm) 

http://en.wikipedia.org/wiki/Reverse_Polish_notation�
http://en.wikipedia.org/wiki/Reverse_Polish_notation�
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0 #1 max max(0,#1) (maximum value) 

 

6.3 Expressions 

Expression derived variables are similar to macros. They can be defined and edited 
with the ODV macro editor and they use the same syntax and operator set. To set up an 
expression, select Derived Variables from the current sample window popup menu, 
choose Expression from the Choices list and press Add. ODV will show a dialog similar to 
the macro editor dialog. You should enter the label of the new variable and the corres-
ponding units in the Label and Units fields. Then, select the input variables required by 
the new variable, e.g., select a variable in the Choices list and press <<. Finally, specify 
the expression to be evaluated for the new quantity. See the paragraph Expression un-
der Macro Editor for a description of supported operators and general syntax guide-
lines. Press OK to finish the setup of the new expression.  

You can edit ODV macros and expressions by using the Derived Variables option from 
the current sample window popup menu. Then select the respective variable in the Al-
ready Defined list box and press Edit. You can save an expression in an ODV macro file 
by pressing Save As on the Edit Expression dialog. 

 

 
Figure 6-2: The edit expression dialog 
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6.4 Difference Variables 

You can compare property distributions of the currently selected stations with pre-
viously saved reference data and produce difference fields by defining property differ-
ences as derived variables. Choose View>Derived Variables or press Alt+D and select 
Difference from Reference. Then choose the ExportID.txt file of the reference dataset that 
you want to use in one of the subdirectories of reference data directory tree. ODV will 
show a list of available reference data files from that directory. Select an .oal file that 
has the variable for which you want to produce the difference field as Z variable and 
appropriate X and Y variables (e.g., for producing longitude vs. depth sections, make 
sure the reference data file has longitude as X and depth as Y variable). Then identify 
the Z, X and Y variables in the current collection (if longitude or latitude are required, 
define them as derived variables prior to invoking the Difference from Reference option) 
to complete the definition of the difference variable. Note that the name of the new va-
riable is composed of the name of the Z variable and the identification string of the ref-
erence data set. Once defined, you can use the difference variable in any data plot. 

6.5 Using Patches 

You can define water-mass patches by specifying polygons in the X/Y space of any data 
plot currently displayed on the screen. To do so, move the mouse over the data plot that 
you want to use for definition (e.g., theta/S plot) and click the right mouse button. From 
the popup menu choose Define Patch (note that the cursor changes to a cross-hair) and 
define the nodes of the patch-polygon by clicking the left mouse button at the node po-
sitions (you delete points by moving the mouse close to them and clicking the right but-
ton). Terminate definition of the polygon by pressing Enter or double-clicking the left 
mouse button. Note that the polygon is automatically closed by ODV. ODV then prompts 
you for a patch name (no extension) and writes the patch definition to a file in the col-
lection directory. 

Once you have defined one or more water-mass patches for a collection, you can use 
them to compose and activate the derived variable Patches. Choose View>Derived Va-
riables and select Patches from the Choices list. You can compose the Patches variable by 
selecting one or more of the available water-mass patches (defined previously as de-
scribed above) into it. Press OK when you are done. To evaluate the Patches variable for 
a given sample, ODV determines whether the sample is inside one of the patch-polygons 
selected into the variable, and (if found) assigns the number of the respective patch as 
Patches value. If the sample is outside all the selected patches, its value is set to the 
missing data value.  

Like all other variables (basic or derived) you can use the Patches variable on any axis 
of any data window. Use it, for instance, as Z-variable along sections or for isosurface 
variables in order to display the spatial extent of specific water masses (see Figure 6-3). 
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Figure 6-3: Using patches to identify the extent of water masses 
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7 Isosurface Variables 

There is frequent scientific need to calculate and display the distribution of a variable 
(basic or derived) on a specific isosurface, defined by a constant value of another basic 
or derived variable.  The concept of isosurfaces is quite general and, in the case of ocea-
nographic water column data, includes constant depth, pressure, or density surfaces. In 
the case of geologic sediment core data with known down-core age estimates, isosur-
face variables could be used to obtain the distribution of a given variable at a constant 
sediment age. 

Isosurface variables can be defined using View>Isosurface Variables or by right-clicking 
on the Isosurface Data Window and choosing Isosurface Variables. ODV will show the 
Isosurface Variables Dialog (Figure 7-1) that lets you define new isosurface variables, 
modify existing ones or delete some of the currently defined isosurface variables. To 
delete one or more existing isosurface variables select them in the Already Defined list 
and press Delete. To add a new isosurface variable first construct the new variable in-
side the New box and then press Add. Constructing an isosurface variable requires that 
you specify the variable that you want to display on a given surface (display variable), 
the variable that defines the surface (surface variable) and a numeric value for the sur-
face variable. For first or last property distributions choose the primary variable as sur-
face variable and enter first or last instead of a numeric value (a f or l as first character 
is sufficient). If you want to use derived variables, such as potential density, as display 
or surface variables, make sure that they are defined before you invoke the Isosurface 
Variables dialog. Note that you can define an unlimited number of isosurface variables. 
Isosurface variable values for the current station are shown in the Isosurface Data Win-
dow. 

 

 
Figure 7-1: The isosurface variables dialog box 

 

If an isosurface variable is selected in the Already Defined box you can synchronize all 
other variables to use the same surface by clicking on the S-Sync button (surface syn-
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chronization). You can synchronize all other variables to use the same display variable 
by clicking on the V-Sync button (variable synchronization).  

Note that in addition to the isosurface variables that you define explicitly, additional 
parameters, such as decimal time, the day-of-the-year, as well as longitude and latitude 
of the station are provided as automatic isosurface data. 

7.1 Drawing Isosurface Variables 

Once you have defined isosurface variables, you can use these variables on Y, Y and Z 
axes of data windows with SURFACE scope. If plotting gridded fields on depth levels, the 
closest isobath will be used automatically as an overlay layer. If original data points are 
plotted, a gray-shaded ocean bathymetry is used as background. 
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8 Selection Criteria 

8.1 Station Selection Criteria 

While drawing the station map, ODV checks every station in the collection and deter-
mines whether it satisfies the current station selection criteria. Only stations that pass 
this test are considered valid. Only these stations are marked in the map and only this 
station subset is available for subsequent browsing and plotting.  

You can modify the station selection criteria by using Station Selection Criteria from the 
Current Station Window popup menu or View>Station Selection Criteria from the main 
menu. Choose the category that you want to modify by clicking on the respective tab, 
e.g., Name/Range, Date/Time, Domain, or Availability, and modify the items of interest.  

 

  

  
 

Figure 8-1: The station selection criteria pages 

 

On the Name/Range tab you can select stations by cruise label, station label range, sta-
tion type, range of internal ID numbers and ranges for the station bottom depths and 
deepest observations. For the cruise label selection you may select a specific cruise la-
bel from the list or you may specify a regular expression (wildcard pattern) in the 
Cruise Label field. In the latter case, any cruise label that matches the regular expression 
will be considered valid. Example regular expressions that can be used for cruise labels 
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are summarized in Table 8-1. 
Table 8-1: Regular expression syntax for cruise labels 

Character Meaning 

Arbitrary character Any character represents itself apart from those mentioned below. 
Example: c matches the character c. 

? This matches any single character. 
Example:  SAVE_LEG? matches SAVE_LEG1, SAVE_LEG9, SAVE_LEGa, etc. 

* This matches zero or more of any characters.  
Examples: I01_*  matches any label that has I01_ at the beginning; 

*06AQ* matches any label that has 06AQ in the middle. 

[...] Sets of characters can be represented in square brackets. Within the 
character class, like outside, backslash has no special meaning. The 
dash (-) is used to indicate a range of characters; the caret (^) negates 
the character set if it occurs as the first character, i.e. immediately after 
the opening square bracket. 
Examples: I05[EW] matches I05E and I05W; LEG[0-2] matches LEG0, 

LEG1, LEG2; SAVE_LEG[^3] matches all SAVE_LEG? cruises ex-
cept SAVE_LEG3. 

 

The Date/Time tab lets you specify a valid time interval (Period), a valid calendar inter-
val (Season), and a valid day time range (Day Time). A station must satisfy all three cri-
teria to be considered valid. The Season and Day Time ranges may span consecutive 
years or days, e.g. [Oct/20 - Feb/03] or [21:09 - 04:15] are acceptable season and day 
time ranges.  

In the Domain category you can define a rectangular subdomain of the map by specify-
ing respective longitude/latitude values or you can press the Zoom button to define a 
rectangle by zooming. You can define a polygon as the valid domain by pressing the Po-
lygon button and then entering the vertices of the polygon with the mouse. Note that 
the polygon is closed automatically.  

In the Availability category you can mark one or more variables for which data must be 
available for a station to be considered valid.  

On the Invert tab you can invert the station selection, e.g., all stations that do NOT satis-
fy the criteria will be selected if the Invert Selection box is checked.  

Note that the selection criteria on the different pages are combined using the logical 
AND operator, e.g., a station is considered valid, only if it satisfies all station selection 
criteria. Press OK when you are done. ODV will rebuild the station map using the new 
selection criteria. 

8.2 Sample Selection Criteria 

A given sample of a valid station is considered valid only if it satisfies the current sam-
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ple selection criteria. Only valid samples are shown in the Current Sample Window or in 
the different data windows. 

You can modify the sample selection criteria by using Sample Selection Criteria from the 
Current Sample Window popup menu or View>Sample Selection Criteria from the main 
menu. Choose the category that you want to modify by clicking on the respective tab, 
e.g., Quality or Range, and modify the items of interest.  

 

  

Figure 8-2: The sample selection criteria pages 

 

On the Quality tab select the variable for which you want to establish a data quality fil-
ter, and then select the quality flags to be accepted. Click on Apply to all variables to ap-
ply the same quality filter for all variables using the same quality flag schema as the se-
lected variable. Click on Relax this quality filter if you want to accept all quality flags for 
the selected variable. Then also click on Apply to all variables if you want to relax all 
quality filters of all variables using the same quality flag schema as the selected varia-
ble. 

Use the selection criteria on the Range tab, if you want to see only samples that have 
values (for one or more variables) in specific value ranges. For instance, if you are stud-
ying the upper water column and only want to see samples between 0 and 500 m depth, 
choose the depth variable and enter the desired range under Acceptable Range. You can 
specify range filters for more than one variable at a time. 
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9 Station Map 

9.1 Map Properties 

The properties of the station map can be modified via the Properties option of the map’s 
popup menu or via View>Window Properties>Map. This includes changing the map do-
main and projection, the appearance of ocean bathymetry, coastlines, and land topo-
graphy, the style of the station dots, as well as general properties such as graphics font 
size or the axis labeling color and style (Figures 8-1 and 8-3). 

 

  

  

Figure 9-1: The various pages of the Map Properties dialog (part 1 of 2). 

 

General  

On the General page you can define the color palette used by the map, the background 
color of the map window, a base font size and font size factor and the color of the axis 
and axis annotations. Grid-lines can be switched on or off. 

Display Style  

On the Display Style page you define the color and the size of the station marks in the 
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map. Choosing (automatic) for the color will cause different colors for the different 
cruises in the data collection. 

Projection  

On the Projection page you choose the map projection and the longitude and latitude of 
the projection pole (position of the viewer).  The following projections are currently 
available: (1) Default Projection, (2) Orthographic (North Polar), (3) Orthographic 
(Equatorial), (4) Orthographic (South Polar), (5) Orthographic (Oblique), and (6) Moll-
weide. The default projection is linear in longitude and latitude directions. The ortho-
graphic projections are hemispheric, while the default and Mollweide projections are 
global in extent. All projections allow zooming-in with the mouse or the definition of 
sub-regions using the Domain page of the map Properties dialog (see below). For the 
Orthographic (Oblique) projection you can specify an arbitrary longitude/latitude eye 
position (pole), from which the globe is then viewed. For the other projections the pole 
latitude is fixed and the user may only vary the pole longitude. 

Note that for projections (2) to (6) the definition of sub-domains by zooming can be 
tricky. If you need accurate results, either use the Domain page of the map Properties 
dialog (see below) or switch to default projection temporarily, then zoom (thereby de-
fining the sub-region) and finally switch back to the desired map projection. 

Layers  

On the Layers page you select the bathymetry/coastline/topography Series and specify 
the layers within the different Layer Set categories. You also switch on or off the draw-
ing of the map’s color bar by checking or unchecking the Draw color bar box.  

A number of intermediate or high-resolution bathymetry/coastline/topography pack-
ages (Series) are available for ODV. Some are already installed during the ODV installa-
tion (GlobHR), many others may be added at any time by installing the respective op-
tional packages. You may select any of the installed series by clicking into the Series 
combobox. Please note that some series are regional and that you may have to adjust 
the map domain to the respective series domain. Once a series is chosen, you may de-
fine the layers in the various Layer Set categories (see below). When the map is drawn, 
the layer sets (and the layers within the sets) are drawn in the given order. 

To obtain information on a selected layer set (e.g., Ocean Bathymetry), click on the Layer 
Set Info button.To define the layers of a selected layer set, click on the Compose but-
ton.Note that default layers are defined for all categories; if the resulting map display 
suits your needs you don’t have modify any layer set.  

If you pressed the Compose button, the layer definition dialog (Figure 8-2) appears.You 
add layers by selecting them in the Available list and pressing the << button.Layers can 
be removed by selecting them in the Selected list and pressing the >> button. Depending 
on the properties in the Line and Fill boxes, a given layer may filled and/or its outline 
may be stroke. The default color settings are (automatic) in which case an appropriate 
color will be chosen automatically (recommended). You may override these settings 
and choose specific colors by clicking into the respective combobox. Choose (none) if 
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you don’t want filling and/or stroking.Note that you may change the properties of a giv-
en layer in the Selected list by clicking on it, then modifying the settings under Line and 
Fill, and, finally, clicking << to implement the changes. 

 

 
Figure 9-2: The map’s layer definition dialog. 

 

Domain  

On the Domain page of the map’s property dialog you may specify the map domain by 
providing east and west longitudes and south and north latitudes. You may also choose 
the domain spanned by the stations in the collection (native domain) by clicking on Full 
Domain or a global domain by clicking on Global Map. 

 

  

Figure 9-3: The various pages of the Map Properties dialog (part 2 of 2). 

 

Annotations 

On the Annotations page you may specify whether you want the picked stations (see 
below) annotated in the map or not. Choose Station labels if you want the station labels 
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of the picked stations drawn next to the station positions, choose Cruise and station la-
bels if the annotations should also include the cruise label, or choose No annotations if 
you don’t want annotations. Note that you can change the position of the annotation 
relative to the station position using the Pick List Editor (see below). 

9.2 Picked Stations 

The station map maintains a list of picked stations. The data of the picked stations are 
drawn in STATION data windows, and the picked stations are also marked in the map, 
using the same color and symbol as in the data windows. You can add a station to the 
pick list by making it the current station (for instance by left clicking on that station) 
and pressing ENTER. Double-clicking a station with the left mouse button will also add 
the station to the pick list. Note that the data of the newly added pick station are added 
to all STATION data windows and that it is also marked in map. To delete a station from 
the pick list make it the current station (for instance by clicking on one of its data points 
in one of the STATION data windows) and press the Del button.  

You may edit the entire pick list using option Manage Pick List>Edit Pick List from the 
map popup menu. The Pick List Editor dialog will appear letting you edit the properties 
and graphical appearance of every station in the pick list. You may also change the or-
der in the list or delete individual stations from the list, or empty the list altogether. 

 

 
Figure 9-4: The Pick List Editor dialog. 

 

9.3 Defining a Section 

You must define a section in the station map before SECTION data windows can be plot-
ted. To define a new section or use a previously defined section right-click on the map 
to invoke the map popup menu. Choose Manage Section>Define Section if you want to 
define a new section or Manage Section>Load Section if you want to load a previously 
defined one. In the latter case simply select a section file from the file open dialog (e.g., 
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by double-clicking on it). If you create a new section, ODV temporarily switches to a full 
page map for easier definition of the section spine. Note that the mouse cursor changes 
to a cross hair indicating that the user is expected to enter a sequence of points defining 
the centerline of the section. 

 
Figure 9-5: The GEOSECS western Atlantic section 

You enter a point by moving the cross hair to the desired location and clicking the left 
mouse button. To remove a point, move the mouse close to it and click the right mouse 
button. To accept the set of points press ENTER or specify the last point with a double-
click of the left mouse button. Note that you may construct rather complicated sections 
following arbitrary cruise tracks as shown in Figure 9-4. 

After specifying the section spine, ODV assigns a default width for the section band and 
selects distance from the starting point (the first point entered) as the default along sec-
tion coordinate. A dialog box appears that lets you change the default characteristics of 
the section. You can change the characteristics of the section at any time by choosing 
Manage Section>Section Properties from the map popup menu. Choose among Distance, 
Longitude and Latitude as along section coordinate, set the width of the section band, 
choose a color for the section bathymetry and specify a title for the section. For the sec-
tion bathymetry you may use station bottom depths or depths from the GEBCO1 or 
ETOPO2 global bathymetric datasets. You may also choose to draw no section bathyme-
try at all. The GEBCO1 and ETOPO2 entries are available in the Bathymetry combobox 
after installing the GEBCO1 and/or ETOPO2 optional packages. 

You can save the current section in a file by choosing the Manage Section>Save Section 
As option. You can use saved sections later, by choosing Manage Section>Load Section. 
To undefine a section, select Manage Section>Undefine Section.  

Note that all stations inside the section band marked in the map belong to the section. 
The data of all these stations are plotted in SECTION data windows. 
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9.4 Station Distributions 

You can produce plots of the spatial and temporal distributions of the stations in the 
map by choosing Extras>Statistics from the map popup menu or by pressing F4 while 
the mouse is over the map. The Map Statistics dialop will appear that lets you view the 
distributions of the currently selected stations in the map versus time or season (press 
buttons Time Histogram or Season Histogram, respectively). The histograms are shown 
in separate dialog windows (see Figure 9-6). You may save the graphics in GIF, PNG, JPG 
or Encapsulated PostScript files by pressing Save As and choosing the appropriate file 
type. To print the graphics press Print. 

 

  

Figure 9-6: Example time and season histograms of stations in the map. 

 

Pressing X/Y Distribution on the Map Statistics dialog produces a plot showing the data 
density in the entire map domain via the number of stations within small tiles. This dis-
tribution plot allows easy identification of areas of dense station coverage, especially in 
cases with very large numbers of stations and many repeat stations plotting at the same 
location in the station map. You may zoom into the map and repeat the above proce-
dures to obtain station density information with higher spatial resolution (see Figure 9-
7). 
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Figure 9-7: Example station map and station distribution plots with different levels of spatial resolution.  
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10 Data Windows 

10.1 Data Window Properties 

The properties of data windows may be modified by right-clicking on the respective 
window and choosing the Properties option. Alternatively, you may also use 
View>Window Properties>Window x, where x is the number of the window. Some of the 
window settings, such as value ranges or variables on the X, Y, and Z axis of the window 
may also be modified using the Set Ranges and X-, Y-, and Z-Variable options of the data 
window popup menu. 

 

   

Figure 10-1: The various pages of the Data Window Properties dialog (part 1 of 2). 

 

The data window Properties dialog consists of five separate pages (Figures 10-1 and 10-
4). 

General  

On the General page you can define the color palette used by the data window, the 
background color of the data window, the highlighting style of the current station, a 
base font size and font size factor and the color of the axis and axis annotations. Grid-
lines as well as the automatic variable labels on the axes can be switched on or off.You 
may customize the text on the axes by switching off the automatic axis labels and creat-
ing your own annotation graphics objects. 

Data  

On the Data page you can define the scope of the data window, the variables on X, Y, and 
Z, as well as various axis properties. Normal axis orientation is to have increasing val-
ues from left to right for X, bottom to top for Y, and bottom to top in the colorbar for Z. 
You may reverse the orientation on one or more axes, for instance, to create depth in 



Version 4.0 

 68 

the ocean values decreasing upward, by checking the respective Reverse range box. 

To modify X, Y, and Z axis properties click on X-Axis Settings, Y-Axis Settings, or Colorbar 
Settings. The axis properties dialog (Figure 10-2) will appear, letting you specify the 
value range on the respective axis, the spacings of tic marks with or without labels and 
the position of the labeled axis. Choosing (automatic) for the tic mark spacings lets ODV 
determine the location and frequency of the marks automatically. The Position entry 
allows a choice of axis position (left or right; bottom or top) or lets you switch off the 
labeling of the respective axis altogether. 

 

 
Figure 10-2: The Axis Properties dialog. 

 

Display Style  

On the Display Style page you can switch between the two fundamental plot types of 
ODV, Original data and Gridded field by clicking on the respective item. 

For Original data you may select display types Dots, Numbers, or Arrows to obtain co-
lored dots, numerical values or arrows at the measurement locations. Specify the size 
and color of the dots or the font size and color for the numerical values in the two fields 
under Symbol size. Note that the selected color is only honored in SECTION, SCATTER, 
and SURFACE data windows without a Z-variable. In data windows with Z-variable the 
color of the dots is determined by the Z-values. In STATION windows the different 
picked stations use different colors. These colors are assigned automatically, but may be 
modified by the user at any time. The Line width entry is only honored in STATION data 
windows. 

If you choose Arrows the Arrow Properties dialog (Figure 10-3) will appear, letting you 
select the variables providing x- and y-components of the arrows, as well as an arrow 
scale, line width and color for the arrows. If you choose Color (automatic) the arrow 
color is determined by the value of the Z-variable at the arrow location. Make sure that 
a Z-variable is defined if using (automatic) color. To bring up the Arrow Properties di-
alog again and modify the arrow settings click on the Arrows entry under Original data. 

Instead of showing colored dots at the sample positions you can also produce gridded 
property fields for any data window that has a Z-variable (property distributions along 
sections or on isosurfaces are examples) by clicking on Gridded field. Then choose one 
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of the available gridding methods, Quick Gridding, VG Gridding and DIVA Gridding. Note 
that DIVA Gridding is only available if you have installed the DIVA integration optional 
package. Then specify appropriate averaging length-scales for the X- and Y-axis, respec-
tively. Note that length- scale values are in per mille of the full axis range and that large 
values result in smooth fields. You should experiment using different length-scale val-
ues until an acceptable compromise between preservation of structure in the data and 
smoothness is achieved. Note that gridded fields may be poor representations of the 
data if performed improperly. 

 

 
Figure 10-3: The Arrow Properties dialog. 

 

All ODV gridding methods assign for every estimate at a given grid point (x, y) a dimen-
sionless quality value. Quality values are based on the distances from the estimation 
point (measured in units of respective averaging scale lengths) of all data points used 
for the estimate. Quality values larger than about 2.5 or 3 should normally be consi-
dered as problematic, indicating that the nearest measurement is more than two 
length-scales away from the estimation point.  You can choose to hide bad estimates 
with large quality values by checking the Hide bad estimate box and specifying an ap-
propriate Quality limit value.  

The gridded field is color shaded by ODV if Do color shading is checked. The positions of 
the actual data points are marked in the plot if Draw marks is checked and appropriate 
size and color are specified for the dots. Contouring (see below) and color shading of 
the property fields is supported for all gridding modes.  
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Figure 10-4: The various pages of the Data Window Properties dialog (part 2 of 2). 

 

Contours 

The Contours page of the data window properties page allows you to define contour 
lines for the plot. This page is only enabled if Gridded field is choosen as display style 
(see above). To add sets of contour lines specify Start, Increment and End Z-values in 
the New group. Choose appropriate line and label properties and press the << button to 
add the set of contour lines to the Already Defined list. If necessary, repeat this proce-
dure with different Start, Increment and End values and possibly different line and label 
properties. You can modify the properties of an existing contour line by selecting it in 
the Already Defined list, modifying the properties in the New group and pressing the << 
button to implement the changes.  

In addition to stroking the contour line associated with a given Z-value z you can also 
ask ODV to fill the region defined by Z-values larger than z using an automatic or user 
specified color by choosing the color under Fill. Figure 10-5b was produced by using 
(automatic) under Fill for all contour lines. 

Color Mapping  

The Color Mapping page lets you manipulate the mapping between Z-variable values 
and associated color. This page is only enabled for data window with a Z-variable (e.g., 
color sections or color distributions on isosurfaces). Press the Auto Adjust button to es-
tablish a possibly non-linear mapping, automatically constructed on the basis of the 
distribution of Z-values. Pressing the Linear Mapping button will restore the default, 
linear color mapping. You may establish customized color-mappings by moving the Me-
dian trackbar to the Z-value to receive the highest color-resolution and increase the 
non-linearity using the Nonlinearity trackbar.  
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Figure 10-5: Comparison of (a) continously shaded and (b) contour shaded fields. 

 

10.2 Zooming and Automatic Scaling 

You can change the variable ranges of any data plot by moving the mouse over this 
window, clicking the right mouse button to invoke the data window popup menu and 
choosing either Full Range or Zoom. For Full Range, the X- and Y-Ranges of the current 
window are adjusted to accommodate all plotted data values in this window. If you use 
Full Range (All) on the canvas popup menu you can auto-scale all data plots on the 
screen in one operation. 

If you select Zoom, a red zoom-frame appears around the current window. To manipu-
late this zoom-frame move the mouse over its edges, corners or interior, press the left 
mouse button and drag the edges, corners or the entire frame to the desired locations. 
Note that the x/y coordinates of the lower/left and upper/right corners are indicated in 
the middle part of the status bar. To accept the current setting of the zoom-frame and 
adjust the variable ranges accordingly double-click the left mouse button or press 
ENTER. If you want to abort the zoom operation and keep the original variable ranges, 
press ESC or click the right mouse button. 

In addition to the normal zoom procedure described in the previous paragraph there is 
an additional zoom method (quick-zoom) that may be even easier and quicker to use in 
many situations. While the mouse is over a data window or the map press and hold 
down the Ctrl key (on Macintosh systems use the Apple key), then press and hold down 
the left mouse button and move the mouse to open a zoom box. Releasing the left mouse 
button applies the zoom box settings to the window from which the quick-zoom was 
initiated. 

10.3 Z-Zooming 

All data windows with a color bar allow modifications of the Z-variable range by zoom-
ing into the color bar (Z-zooming). To invoke Z-zooming move the mouse over such a 
data window and click the right mouse button to bring up the data window popup 
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menu. Selecting Z-Zoom will draw a red zoom-frame around the color bar of the respec-
tive window. Manipulate and drag this zoom-frame as described above. To accept the 
current setting of the zoom-frame and adjust the Z-variable range accordingly, double-
click the left mouse button or press ENTER. If you want to abort the zoom operation and 
keep the original Z-variable range, press ESC or click the right mouse button. 

10.4 Changing Window Layout 

The position and size of the station map as well as the number, position and size of zero 
or more data windows can easily be modified using View>Window Layout from the main 
menu, the Window Layout option of the canvas popup menu or by pressing the shortcut 
key Alt-W. ODV will outline the current layout and lets you move, resize, delete or create 
windows. To perform one of these operations on a window, move the mouse over this 
window, click the right mouse button and select the appropriate option.  

If you choose Move/Resize a red zoom-frame appears around the respective window. 
You move and/or resize this zoom frame by moving the mouse over a corner, edge or 
the interior, press and hold down the left mouse button and move the mouse. To accept 
the new size and position for the window double-click the left mouse button or press 
ENTER. To abort the Move/Resize operation leaving the window position unchanged 
press ESC. Note that overlay windows (see below) can not be moved or resized. 

You create new windows by moving the mouse over one of the existing windows, right-
clicking and choosing option Create New Window or Create Overlay Window. In both 
cases the initial properties of the new window are derived from the existing one. If you 
use Create New Window, the new window will be placed in the middle of the ODV 
graphics canvas and you have to position and resize it using the Move/Resize option 
described above. If you use Create Overlay Window, some properties required for over-
lay windows will be set automatically, and the new window will be properly aligned 
with the existing one. You modify the properties of an existing or new window by right-
clicking on this window and choosing option Properties. To select new variables on X-, 
Y- and Z-axis of the window, select the Data page of the Properties dialog and choose 
appropriate variables in the combboxes of the different axes. Note that by default varia-
ble values increase to the right and upwards. If you want to reverse the direction (e.g., 
depth in depth profiles) check the respective Reverse range box. Press OK to accept the 
new properties. Note that the properties of the map or any data window may also be 
changed any time after leaving Window Layout mode (see above).  

In addition to manual arrangement of map and data windows,  you may also implement 
a predefined window layout by choosing from a wide range of layout templates (choose 
Layout Templates from the View menu or the canvas or window layout popup menus 
and select one of the templates). 

To leave Window Layout mode and accept the new window layout, right-click the mouse 
and choose Accept. If you want to discard the modification and keep the original win-
dow layout, choose Cancel.   
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10.5 Graphics Output 

Printing 

Choose Print Canvas from the File or canvas popup menus to print the contents of the 
entire canvas.  

PostScript Files 

To produce Encapsulated PostScript .eps files for the entire screen or any individual 
data window or the map, right-click on the canvas or the respective data window or 
map and choose Save Canvas As, Save Plot As or Save Map As (alternatively, you can also 
press Ctrl-S while the mouse is over the canvas, data window or map), choose PostScript 
(*.eps) for the file type and specify the name and destination of the output file. ODV then 
presents the PostScript Settings dialog that lets you specify the orientation and size of 
the PostScript output. The resulting Encapsulated PostScript files can be printed by 
sending it to a PostScript printer, or it can be imported into LaTex or Word documents, 
or may be opened with external graphics software, such as Adobe Illustrator or Corel 
Draw, for editing and processing. If you intend to include the ODV .eps output files in 
other documents, make sure to uncheck the Show Collection Info box on the PostScript 
Settings dialog. 

GIF, PNG and JPG Files 

You can save the entire canvas, individual data windows or the map in GIF, PNG or JPG 
files by choosing Save Canvas As from the canvas popup menu, Save Plot As or Save Map 
As from a data window or map popup menu and selecting the respective file type. These 
options can also be invoked by shortcut key-strokes:  (1) pressing Ctrl-S while the 
mouse is over the canvas area saves the ODV graphics canvas while (2) pressing Ctrl-S 
with the mouse over the map or a data window will save the respective data plot. ODV 
will present a file save dialog that lets you choose the appropriate output file type (GIF 
(*.gif), PNG (*.png) or JPG (*.jpg)). Note that the default output filename is derived from 
the current view name. If required, you can choose any other name or destination. ODV 
then lets you define the resolution of the output image. Note that the maximum achiev-
able resolution is limited by the available memory on your system. 

10.6 Data Statistics 

You can obtain statistics information for the data shown in a given data window by 
right-clicking on the window and choosing Extras>Statistics or by pressing F4 while the 
mouse is over the window. The window’s statistics page will appear (see Figure 10-6) 
and show mean, standard deviation, number of data points as well as minimum and 
maximum values for the X, Y, and (if present) Z variables of the respective window. 
Note that mean, standard deviation, and number of data points are based on the cur-
rently visible data only, while minimum and maximum are using all available data.  
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Figure 10-6: The statistics dialog box (right) for a SCATTER data window showing oxygen data from the 
northeast Pacific versus depth (left). 

 

ODV will also allow you to fit three types of curves through the data: (1) least-squares 
lines, (2) piece-wise least-squares lines, and (3) moving average curves. You may 
choose one of theses curve types from the top combobox of the Fitted Curves group. 
Then choose an orientation for the fit (in the example of Figure 10-6 we want oxygen as 
a function of depth, e.g., X ( Y )). For curve types (2) and (3) you may also specify the 
number of points at which the curve will be evaluated (default 30; choose a larger value 
for smoother curves). For moving average curves (type  3) you may specify an averag-
ing length scale (in permille of the axis range of the variable between paranthesis, e.g. 
Y=Depth in Figure 10-6). Large averaging length scales will result in smooth, small val-
ues will preserve more of the structure in the data. Press Construct Curve to have the 
curve calculated and the results displayed in the box to the right. These results may be 
copied to the clipboard (by pressing Clipboard Copy) and then pasted into other docu-
ments or applications for external use. 

You may also add the constructed curve to the data window by pressing Show Curve. 
Note that the curve is added as a polyline graphics objects, which means that you can 
edit or delete the object at any time using the normal graphics object’s procedures. 

10.7 Data Distributions 

You obtain distribution histograms of the X, Y, and (if present) Z data by pressing on the 
respective Histogram button. An example histogram is shown below. Note that the his-
togram is based on the currently visible data only. You obtain a plots of the data distri-
bution in X/Y space by pressing the X/Y Distribution button. All histogram and distribu-
tion plots may be send to the printer or they may be saved in GIF, PNG, JPG or Encapsu-
lated PostScript files. 
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Figure 10-7: The data distribution histogram for oxygen (left) and the oxygen/depth data distribution 
(right) for the data from Figure 10-6.  
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11 Graphics Objects 

You can add text annotations, symbols, lines and other geometric objects to the canvas, 
the map or any data window. The following graphics objects are supported: (1) text 
annotations, (2) straight lines, (3) rectangles and squares, (4) ellipses and circles, (5) 
polylines (straight-line segments or Bezier smoothed), (6) filled polygons (straight-line 
segments or Bezier smoothed), (7) symbols, (8) symbol sets and (9) legends. Detailled 
descriptions of these objects follow below. 

A graphics object is owned by the canvas, the map or a specific data window on which 
the object was created. All graphics objects of the canvas, the map or a data window are 
drawn, whenever the respective parent window is drawn.  

The coordinates of a graphics object are either specified in the coordinate system of the 
owner window or of the canvas. Canvas coordinates are in cm from the lower left cor-
ner. Using window coordinates for a graphics objects has the advantage that the objects 
remains at its position in the window, even if the parent window is moved or resized. 
However, map’s using default or non-default projections may require that Canvas coor-
dinates are used for graphic objects. This applies to line, polylines or polygons extend-
ing across the Greenwich meridian (any projection), or to objects to be placed outside 
the map area.  

The initial ownership and coordinate system of an object are derived from the window, 
from which creation was initiated (see below). Like most other properties of a graphics 
object, ownnership and the coordinate system may be edited and modified at any time. 
By default, graphics objects are clipped to the parent window. If you create objects out-
side the window’s viewport make sure to uncheck the Clip to window box on the object’s 
Properties dialog (see below).  

Graphics objects are part of the current view and are saved in view files. 

Creation 

Except for legends, which are created automatically, you create and add any other 
graphics object by choosing Extras>Add Graphics Object>... (”...” represents the desired 
object type) from the map or data window popup menus or by choosing Add Graphics 
Object>... from the canvas popup menu. After initial creation, dialog boxes appear that 
let you define various properties of the object. These properties may later be changed 
again at any time (see Edit below). A graphics object is owned by the window (or can-
vas) from which the creation was initiated, and the coordinates of the graphics object 
are in the respective window coordinate system. As a consequence, all objects of a win-
dow follow automatically when the respective window is moved or resized. 

Graphics objects can also be created as copies of existing objects via the Copy Object 
option of the graphics object context menu, or the Copy button of the graphics objects 
management dialog (see below). You may also import graphics objects from ODV .gob 
files, previously created by exporting existing graphics objects. Other window objects, 
such as bathymetry polygons in section plots, contour lines in data windows showing 
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gridded field, colored data dots in data windows showing original data, or the station 
selection polygons in the station map, may also be exported to .gob files. All these ex-
ported objects may later be imported and added as graphics objects to the canvas, the 
map or any data window. 

Edit and Delete 

The properties of a given object can be modified by moving the mouse over it (for sym-
bol sets move the mouse over one of the symbols), clicking the right mouse button and 
choosing Properties from the popup menu. Some graphics objects, such as axis labels, 
unit arrow boxes or legends, are created and deleted automatically (automatic graphics 
objects). These objects may not be edited or deleted manually (automatic axis labels are 
switched on/off on the General page of the window’s Properties dialog). 

Dialog boxes (different for the different objects) appear and let you change properties 
easily and quickly. Graphics objects may be clipped to their parent window (check the 
Clip to window box), and they may be drawn before the data of the window are drawn 
(check the Pre-data plot box).You delete an object by moving the mouse over it, clicking 
the right mouse button and choosing Delete Object. 

Dragging 

If the attribute Allow dragging of a graphics object is set, the object can be re-positioned 
by simply dragging it to a different location. To drag an object, move the mouse over it, 
click and hold down the left mouse button and move the mouse. By default, dragging is 
switched on initially for all graphics objects except symbol sets, which are linked to ac-
tual data values. You can change the Allow dragging  attribute at any time using the ob-
ject’s Properties dialog (see above). 

Managing Graphics Objects 

You can manage the graphics objects of the canvas, map or any data window using the 
respective Extras>Manage Graphics Objects option. This includes changing the object’s 
properties (Edit), exporting, copying, deleting or changing the order in which the ob-
jects are drawn. 

11.1 Annotations 

You can add annotations by choosing (Extras>)Add Graphics Object>Annotation from the 
canvas, map or data window popup menus. A cross-hair cursor will appear, which you 
should move to the location where the annotation is to appear and then click the left 
mouse button. Note that the window from which the creation was initiated will own the 
respective object. When adding (or editing) annotations you may set the position, orien-
tation (degrees, counter-clockwise), font size (pt), color and alignment parameter of the 
annotation text. Annotations can have a frame, and the annotation rectangle can be 
filled before drawing the text. You can choose different colors for all these items. In ODV 
annotions, you can use various formatting control sequences as well as functions for 
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auto-text substitution.  

Like all graphics objects, you can drag an annotation to a different position by moving 
the mouse cursor over it, pressing and holding down the left mouse button and moving 
the mouse. You can edit an annotation by moving the mouse over it, clicking the right 
mouse button and choosing Properties from the popup menu. To delete an annotation 
(all annotations) choose Delete Object (Delete All Objects) from its popup menu. 

Note that the axis labels of the data plot windows are implemented as automatic anno-
tations. They are created automatically when the plot window is drawn and they are 
deleted when the respective data plot window is deleted. You may not edit or delete 
automatic axis labels. If you want to change an axis label permanently, you should 
switch off automatic axis labels (see General page of the window’s Properties dialog) 
and create an annotation manually by choosing Extras>Add Graphics Object>Annotation 
from the canvas popup menu.  

11.2 Lines and Polygons 

You add straight lines, polylines and polygons to the map, data windows or the canvas 
by choosing (Extras>)Add Graphics Object>Line, ...>Polyline or ...>Polygon from the map, 
data window or canvas popup menus. In all three cases the cursor changes to a cross 
hair, and you should proceed by specifying the nodes of the object. For a Line graphics 
object you must define starting- and endpoint: move the cross-hair to the start of the 
line and click the left mouse button, then move to the end-point and click the left button 
again. For Polyline or Polygon graphics objects you may define up 1000 nodes. Note that 
polygons are closed automatically by ODV. If you want to delete a point, move the cross 
hair close to it and click the right mouse button. You end the definition of polygon or 
polyline points by pressing ENTER. 

Once you have specified the nodes of the line, polyline or polygon, ODV presents a di-
alog box that lets you define color, width and type of the (poly)line and the fill color of 
the polygon (ignored for Line and Polyline; choose (none) as fill color to avoid filling of 
the polygon). Also note that lines wider than 1 pixel are always solid on many screen 
and printer devices. However, the requested line-type is always honored in ODV 
PostScript files. Polylines and polygons may be smoothed by checking the Bezier 
smoothing box. 

11.3 Rectangles and Ellipses 

You add rectangles (squares) and ellipses (circles) to the map, data windows or the 
canvas by choosing (Extras>)Add Graphics Object>Rectangle, or ...>Ellipse from the map, 
data window or canvas popup menus. A red zoom rectangle will appear that represents 
the bounding box of the new rectangle or ellipse. The zoom rectangle can be moved and 
resized, then press ENTER to accept a setting or ESC to abort creation of the object. A 
dialog box appears that lets you define properties of the rectangle or ellipse (for details 
see Lines and Polygons). 
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11.4 Symbols 

You add symbols (dots, squares, diamonds, triangles, inverted triangles, stars, crosses, 
pluses) to the map, data windows or the canvas by choosing (Extras>)Add Graphics Ob-
ject>Symbol from the map, data window or canvas popup menus. A cross-hair cursor 
will appear, and you should move it to the location where the symbol should appear. 
Then click the left mouse button. The Symbol Properties dialog box appears and lets you 
set various symbol properties.  

11.5 Symbol Sets and Legends 

You can highlight a subset of the data points in a data window or a subset of stations in 
the map by assigning a symbol to the selected data points (symbol set). To create a 
symbol set for a data window or the map, move the mouse over this window and 
choose Extras>Add Graphics Object>Symbol Set. The Symbol Set Selection dialog appears 
and lets you select the subset of data points (select one or more cruises in the Cruises 
list, stations in the Stations list, and/or individual samples in the Samples list). Then 
press the << button to add the selected data points to the Selected list. Press OK once all 
desired points are selected. The Symbol Set Properties dialog appears, which lets you 
define the symbol and line characteristics. A symbol set can have a descriptive text (le-
gend), which will automatically be added to the legends of the respective window 
(check the Add to legends box). Unlike other graphics objects, symbol sets cannot be 
dragged, because of their association with the selected data points. You can change all 
symbol set properties at any time by moving the mouse over any one of its symbols, 
clicking the right mouse button and choosing Properties. 

 

 
Figure 11-1: Sample SCATTER plot using symbol sets and legends to highlight the data of a particular station  

 

If a data window or the map contains symbol sets, and the Add to legends option is 
switched on, a legend box containing the symbol and legend text of all symbol sets for 
this window appears automatically. Legend sets can be dragged to different locations 
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and their properties (the size of the legend box is modified by changing the font size for 
the legend text) can be modified at any time (move mouse over legend set, click right 
mouse button and choose Properties). 

11.6 Managing Graphics Objects 

You can obtain full lists of all graphics objects of the canvas, the map or any data window by 
right-clicking on the respective area and choosing Manage Graphics Objects or Extras> 
Manage Graphics Objects. 

 

 
Figure 11-2: The Graphics Objects dialog. 

 

The Graphics Objects dialog (Figure 11-2) appears, letting you select individual objects, sub-
groups of objects, or the entire list of objects.If you have selected one or more objects you 
may delete all selected objects by pressing Delete or you may export all selected objects to a 
file for subsequent re-use by pressing Export.If you have selected just one object you may 
also copy the object (by pressing Copy) or change the properties of the object (by pressing 
Edit). You may also change the drawing order and bring the object closer to the foreground 
(Foreground or Up) or background (Background or Down). 
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12 Working with Collections 

12.1 Copying, Renaming and Deleting Collections 

You can create a copy of the currently open collection using Collection>Copy, you re-
name (and possibly move) the currently open collection using Collection>Move/Rename, 
and you delete the currently open collection using Collection>Delete. Note that view and 
section files associated with a deleted collection may have to be deleted manually. 

12.2 Sorting and Condensing 

The station search and selection algorithms of ODV work most efficiently if the stations 
in a collection are ordered by cruises. Therefore, it is recommended that you sort and 
condense your collections after importing, replacing, merging or deleting large numbers 
of stations. You invoke the sort and condense procedure by choosing Collection>Sort 
and Condense.  

12.3 Deleting Stations 

You can delete the currently selected stations from the collection by choosing Collec-
tion>Delete Station Subset from ODV’s main menu. To delete the current station only, 
choose Collection >Delete Current Station. Note that the data space of the deleted sta-
tions in the collection disk files is not freed until you sort and condense the collection. 

12.4 Key Variable Associations 

Many derived variables require identification of the input variable(s) needed for the 
calculation of the derived variable. This identification of key variables is done during 
the first definition of the derived variable, and the selected variables are remembered 
as part of the properties of the collection. If the derived variable is requested again at a 
later time, the stored key variable information is used, and the user is not prompted 
again. 

You can inspect and modify the current key variable associations using Collec-
tion>Identify Key Variables. The Identify Key Variables dialog will appear, showing lists 
of key variables on the left and collection variables on the right. Associated items are 
marked with an asterisk (*). You can click on such items in any of the lists and ODV will 
show the associated item in the other list. You may break the association by pressing 
Undo; pressing Undo All will break all association and leave all key variables undefined. 
You establish an association by selecting the relevant items in the two lists and pressing 
Associate. Items in the key variable list that are not included in the list of collection va-
riables may be marked as not available by pressing the Not Available button. Such items 
are marked in the key variable list by a minus sign (-). 
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Figure 12-1: The Identify Key Variables dialog. 

 

Important Note: Errors made in the key variable associations can lead to desastrous and 
sometimes hard to track errors of the values of affected derived variables. For instance, 
imagine the key variable Salinity [psu] was erroneously associated to collection variable 
Oxygen [µmol kg-1]. This would cause all derived variables requiring Salinity [psu] as 
input variable, such as potential temperature, potential density, and many others, to 
return wrong values. You should verify the validity of key variable associations from 
time to time using option Collection>Identify Key Variables. 

12.5 Good Coverage Criteria 

Some ODV operations, such as the interpolation to standard depths or the calculation of 
various derived variables require that there are sufficient input data available. Calcula-
tion of dynamic height, for instance, requires full profiles of temperature and salinity 
data, and gaps between the data points should not be too large. Using Collection> Good 
Coverage Criteria you may specify the criteria that must be satisfied to consider the data 
of a given variable sufficient. These criteria are applied to any variable required for a 
specific operation. If one or more required variables fail the test, the respective opera-
tion is not performed. 

 # Obs  Number of required observations per station. 

 Fraction > Percentage of samples that must contain data for a given variable. 

 gap(Z).. Specifies the depth dependent tolerable gap between data points. 

12.6 Browsing Collection Information 

Collection Info  

Every collection may have a free-text description of the data in the collection. This in-
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formation is stored in the collection’s info file. You may view or edit the info file of the 
currently open collection by choosing Collection>Browse Info File.  

Cruise Inventory  

You can view the cruise inventory table of the currently open collection by choosing 
Collection>Browse Cruise Inventory. The following information is provided for every 
cruise: cruise ID, number of stations, number of samples, station IDs, longitude and lati-
tude ranges, time period, and data availability indicators for each of the basic variables. 
Data availability indicators are single digit numbers, with, for instance, 9 indicating that 
more than 90 % of the samples containing data for the particular variable. 

Collection Logfile 

All actions that modify the contents of a collection (creation, import of data, station de-
letionns, editing of metadata or data, etc.) are logged in the collection’s logfile. You can 
view the contents of the logfile by choosing Collection>Browse Log File. 

12.7 Variable Properties 

You may modify properties of meta- and collection variables by right-clicking on the 
current station or current sample list windows and choosing the Properties option. 
From the list of variables choose the one you want to modify and press Edit. On the 
properties dialog of the selected variable you may edit the strings for variable label, 
units and comment. You may also modify the number of digits used to show values in 
the current station or sample windows.  

Note that other properties of the variable, such as data type, byte length and the quality 
flag schema used for the quality flags, are specified at collection creation time, and may 
not be changed later. If you want to change these parameters for an existing collection 
you have to export all data in the collection (using Export>ODV Spreadsheet), create a 
new collection using the variables from the existing .odv or .var collection, and modify 
the meta- or collection variable properties during creation. Then import the previously 
exported data using Import>ODV Spreadsheet. 

12.8 Editing Data 

You can edit the metadata as well as the actual data values and quality flags of the cur-
rent station and save the modified values in the collection data files on disk.  

Station Metadata 

To modify the metadata of the current station, right-click on the current station list 
window and choose Edit>Metadata. The Edit Station Metadata dialog appears showing 
the metadata of the current station.You can edit an individual entry by double-clicking 
into the respective value field. You modify a particular quality flag by clicking on its field 
and then clicking the Change Quality Flag button and selecting the new quality flag. 
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Press OK on the Edit Station Metadata dialog to write the new metadata to the collection 
files. Press Cancel to discard your modifications and leave the metadata of the current 
station unchanged. 

Note that edit operations are logged in the logfile of the collection. This file can be 
viewed using the Collection>Browse Log File option. 
 

 
Figure 12-2: The Edit Station Metadata dialog. 

 

Station Data 

To modify the data of a given variable at the current station right-click on the particular 
variable in the current sample list window and select Edit Data. The Edit Data dialog 
appears showing the data value and quality flags of the variable for all samples of the 
current station. You may change data values and quality flags for the current sample 
(initial selection) or for a user defined sample subset. You define a sample subset in the 
data list by pressing the standard extended selection keys Ctrl and Shft while left-
clicking the mouse. Click on Select All to select all samples, or press Invert Selection to 
invert the current selection.  

If you have selected a single data item you can change its value by clicking on the 
Change Value and entering a new numerical value. If you have selected more than one 
sample in the data list, the Change Value button is deactivated. Pressing the Delete Val-
ue(s) button removes the data values of all selected samples. You should use this button 
with great care, as the original data values will be lost permanently. Usually, you should 
leave the actual data value unchanged and modify the data quality flags of the selected 
samples instead. This is done by clicking the Change Quality Flag(s) button and selecting 
a new quality flag from the list of available flags. Pressing OK saves the changes to disk, 
pressing Cancel aborts the edit session and leaves the station data in their original form. 

Note that you can filter data based on their quality flag values. Also that edit operations 
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are logged in the logfile of the collection. This file can be viewed using the Collec-
tion>Browse Log File option. 

 

 
Figure 12-3: The Edit Data dialog. 
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13 Tools 

13.1 2D Estimation 

For data windows that currently use the VG Gridding gridding method you can perform 
estimation of  Z-values at arbitrary, user-specified X-Y points by choosing the Extras>2D 
Estimation option from the respective data window popup menu. The estimated Z-
values are weighted averages of nearby data points using the X and Y averaging length 
scales from the current VG Gridding settings. Note that the results depend on the mag-
nitudes of the averaging length scales: large length scales result in smooth fields, whe-
reas small scales allow maintaining small-scale features. Also note that the length-scales 
are specified in permille of the current X and Y ranges. Changing the axis ranges by 
zooming or enlarging will therefore change the absolute averaging length scales and 
also changes the 2D Estimation results. Use the data plots Properties dialog to adjust the 
length scales until you are satisfied with the distribution displayed in the data plot. 
Then invoke the Extras>2D Estimation option. 

ODV will prompt you for a file (called input file in the following) with the X-Y coordi-
nates of the points for which estimation is requested. This file has to be prepared prior 
to invoking the 2D Estimation option. It has to be in plain ASCII format with one X-Y 
coordinate pair per line, and the X and Y values must be separated by one or more spac-
es. The number of points (or lines) is unlimited. For each point in the input file ODV will 
estimate a Z-value, and will write the estimated values together with the respective X 
and Y coordinate to an output file. Name and location of the output file may be specified 
by the user. The default name is the input file name appended with .est, and the default 
location is in the same directory as the input file. Each line contains the X, Y, and Z val-
ues as well as an estimation quality indicator. A quality indicator value of 0 indicates an 
acceptable estimate, whereas 8 indicates a bad estimate. A Z value of -1.e10 indicates 
that the X/Y point is outside the current domain. 

13.2 3D Estimation 

You can estimate values for a basic or derived variable at arbitrary geographical loca-
tions by choosing Tools>3D Estimation. ODV will prompt you for an ASCII file that con-
tains the longitude, latitude, and depth values of the points for which Z-variable esti-
mates are to be obtained. This 3D point definition file has to be prepared prior to invok-
ing the Tools>3D Estimation option. When creating the point definition file, specify one 
point per line, and provide decimal longitude, latitude and depth values in this order, 
with one or more spaces separating the individual values. ODV will let you choose the 
variable for which the estimation should be performed and it lets you specify x, y, z av-
eraging length scales used for the estimation. Note that the length scale units for longi-
tude and latitude are in per mille of the current map ranges, whereas the unit of the 
depth length scale is in meters. Choosing large values for the averaging length scales 
will result in smooth estimates. For the 3D Estimation all original data points from all 
stations currently shown in the map will be used. The weight with which a given data 
point influences the estimate at a specific target location is inversely proportional to the 
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distance between data and target points. The output file contains one line of results for 
every longitude, latitude and depth point specified in the input file. Each line contains 
six numbers x, y, z, v, d, n with the following meaning: 

 
x, y, z  longitude,  latitude, depth (as specified in the input file) 
v  estimated value 
d normalized distance of averaged data x, y, z positions from estimation 

point (in units of averaging length scales) 
n number of data points used. 

13.3 Box Averaging 

You can use ODV to calculate averages and standard deviations for basic or derived va-
riables in given longitude-latitude-depth boxes. Only stations currently shown in the 
map are considered and only stations and data points inside the requested box are ac-
tually used for the mean and standard deviation. You can specify appropriate station 
selection criteria prior to invoking the Box Averaging option, to obtain averages for dif-
ferent station subsets, years, months, or seasons. To invoke box averaging, choose 
Tools> Box Averaging from the main menu. ODV shows the list of basic and derived va-
riables and lets you choose one or more variables for the averaging procedure. ODV 
then prompts for the ASCII box definition file containing the geometry information of 
the boxes for which output is to be produced. The box definition file has to be prepared 
prior to invoking the Box Averaging option.  

The format of the box definition file is as follows: 

• plain ASCII, one box definition per line, 6 numbers 
separated by (one or more) spaces, 

• meaning of numbers (see figure):  
lon lat dep (box center) ∆lon ∆lat ∆dep (box sizes). Lon-
gitudes and latitudes are in decimal degrees, and 
depth is in meters.  

Once you have specified a box definition file, ODV will start working. Note that while 
averaging, ODV will check for data outliers and will use only data within 3 standard 
deviations of the mean. The output will be written to the directory of the box definition 
file. The output file names consist of the box definition file name, the label of the varia-
ble that is processed and the extension .est. 

The format of the .est output file is as follows: 

• plain ASCII, one line of output per line in the box definition file, 10 values sepa-
rated by TABS, 

• meaning of values:  
lon lat dep (same as in box definition file) lon lat dep val σ nu nr. 

lon lat dep val are average longitude, latitude, depth and variable values of the data 
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used, σ is the standard-deviation of the variable values, nu is the number of data points 
used and nr is the number of data points rejected. Note that the error of the mean, val

um nσσ =

, 
can be calculated as 

  

If no data point is found within a box, val

13.4 Finding Outliers 

 is set to -1.e10; if only one data point is found, 
σ is set to 1.e10. 

Also note that all individual data values used for a given average are exported to an 
ASCII file ODVbox*.dat in ODV’s temporary files directory, where * in the file name 
represents the respective box number (e.g., line number in the box definition file). In 
the .dat files the meaning of values is as follows: #, lon, lat, dep, day-of-year, value, 
weight, used/rejected-flag. Note that ODVbox*.dat files are overwritten by subsequent 
box averaging requests. By default, ODV*.* files in ODV’s temporary files directory are 
automatically removed after three days. No ODVbox*.dat files will be written, if you re-
quest averages for 5000 or more boxes. 

You can scan the currently selected stations for samples with data values outside a user 
specified value range by choosing Tools>Find Outliers. Select the variable to be scanned 
from the list of variables and enter the minimal and maximal accepted range values. 
Press OK to start the scan. ODV will report the number of outliers found and lets you 
view the list of outliers. ODV also lets you inspect and modify the data values and/or 
quality flags of the outlier samples. 

If you check Inspect and Edit Outliers, ODV will visit all identified outliers and allows you 
to delete the respective value or to mark it as Questionable or Bad. If you press Apply to 
All, ODV applies the selected operation to all outliers, otherwise the user is prompted 
for an action for each individual outlier. Note that the currently edited outlier is marked 
in the data plots. 

13.5 Finding Duplicate Stations 

You can scan the currently selected station set for stations with identical or nearly iden-
tical positions and times of occupation (duplicate stations) by choosing Tools>Find Dup-
licate Stations. The list of duplicate stations is written to disk. Blank lines separate sets 
of duplicate stations. For each station the following information is given: (1) internal 
sequence number, (2) cruise label, (3) station label, (4) station type, (5) date and time, 
(6) longitude, (7) latitude,  (8) number of samples, (9) deepest sample, (10) availability 
indicators for basic variables 2 to nVar (e.g., 7 means that between 70 and 79% of the 
samples contain data for a given variable).To delete a duplicate station, make it the cur-
rent station using Current Station by Number or Current Station by Name from the map 
popup menu and then delete it using Collection>Delete Current Station. 
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14 More … 

14.1 General Settings 

You can customize general ODV settings such as the graphics and text fonts, the size of 
the canvas, or the browser and text file viewing commands using option View>General 
Settings. 

Font: 
Choose a font family and various font properties and set a global font scaling factor Size. 
Increase the Size value, if you want larger graphics text and axis annotations, or de-
crease it otherwise. Note that some fonts may not be supported in ODV’s PostScript 
output. Also note that Graphics Font Size adjustments may be necessary after large 
changes of the canvas size (see below). 

The Text Font Size entry determines the font size used for menus, dialogs and the cur-
rent station and sample list windows. 

Canvas: 
Adjust the width and height of the ODV graphics canvas, e.g., the white area onto which 
the map and data windows are drawn. Click on Fit to screen to establish optimal settings 
for the current screen.Note that it may be necessary to adjust the Graphics Font Size on 
the Font tab after large changes of the canvas size. 

Highlighting: 
Choose the color(s) to be used for highlighting the current station, current sample and 
data of the current station. Different colors may be chosen for the map and data win-
dows. 

Printing: 
Check the Show collection info box to include a time-stamp as well as collection, view 
and user information on printouts. Adjust the position if necessary. 

Program Locations: 
Enter the full paths of your Web browser (needed for ODV help) and text viewer 
(needed for viewing text files).  

System: 
Enter the user’s login name and the computer’s host name. 

14.2 Changing the Color Palette 

You can change the color palette of the map or any data window by right-clicking on the 
window, choosing the Properties option and selecting one of the available palette files 
from the Palette combo box on the General page. ODV will redraw the map or data win-
dow using the new palette.  

On Windows you can create new color palettes or modify existing palettes by means of 
the PalEdt.exe program in the ODV binaries directory (normally c:\Program 
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Files\Ocean Data View (mp)\bin_w32). PalEdt.exe can be invoked from ODV by choos-
ing Tools>Invoke Palette Editor. 

ODV-style color palettes define 177 colors:  
• 0-15:  basic colors  
• 16-31: gray-scale; color 31 used as background color of ODV plot windows; 
• 32-144: main palette used for color-shading; 
• 145-160: colors used for map bathymetry and continents; 
• 161-176 colors used for map land topography. 

14.3 Animations 

ODV allows lets you produce animated GIF files of the map or any data window by 
right-clicking on the respective window and choosing Extras>Animation and one of the 
sub-options Metadata Time, Metadata Time of Year, Validate Variable, or Ex-
tras>Animation>Isosurface. Then follow the instructions below. 

(1) Metadata Time: 

Specify a start date t0, the interval step dt (in days), the number of frames n to be pro-
duced and the interval type. ODV will then construct n time intervals and use the re-
spective start and end dates for the Date/Time>Period station selection criteria.  

Depending on the selected interval type, the start and end dates of interval i (i=0,…,n-1) 
are defined as follows:  

 
Interval Type Start of Interval i End of Interval i 
Zero Width dtit ⋅+0  dtit ⋅+0  

Fixed Width dtit ⋅+0  dtit ⋅++ )1(0  

Fixed Start 0t  dtit ⋅++ )1(0  

Fixed End dtit ⋅+0  dtnt ⋅+0  
 

For each such time interval, the map will be re-build, including only those stations with 
metadata dates in the respective time window. If the animation is for a data window, 
this data window will also be redrawn using data from the currently selected station set 
only. The current map or data window will then be added to the animation file.  

(2) Metadata Time of Year: 

Specify a start month and day t0, the interval step dt (in days), the number of frames n 
to be produced and the interval type. ODV will then construct n time intervals and use 
the respective start and end dates for the Date/Time>Season station selection criteria.  

Depending on the selected interval type, the start and end dates of interval i (i=0,…,n-1) 
are defined as follows:  
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Interval Type Start of Interval i End of Interval i 
Zero Width dtit ⋅+0  dtit ⋅+0  

Fixed Width dtit ⋅+0  dtit ⋅++ )1(0  

Fixed Start 0t  dtit ⋅++ )1(0  

Fixed End dtit ⋅+0  dtnt ⋅+0  
 

For each such time interval, the map will be re-build, including only those stations with 
metadata months and days in the respective time window. Note that data from more 
than one year may be used if the data collection contains stations from multiyear pe-
riod. If the animation is for a data window, this data window will also be redrawn using 
data from the currently selected station set only. The current map or data window will 
then be added to the animation file.  

(3) Validate Variable: 

This option is available for data windows only. Select a validate variable and specify a 
start value v0, the interval step dv, the number of frames n to be produced and the inter-
val type. ODV will then construct n intervals for the validate variable and use the re-
spective start and end values for the Sample Selection Criteria>Range selection criteria 
of the chosen variable. 

Depending on the selected interval type, the start and end values of interval i (i=0,…,n-1) 
are defined as follows:  
Interval Type Start of Interval i End of Interval i 
Zero Width dviv ⋅+0  dviv ⋅+0  

Fixed Width dviv ⋅+0  dviv ⋅++ )1(0  

Fixed Start 0v  dviv ⋅++ )1(0  

Fixed End dviv ⋅+0  dvnv ⋅+0  
 

For each such interval the data window will be redrawn, including only those data from 
the respective variable value interval. The current data window snapshot will then be 
added to the animation file.  

(4) Isosurface : 

This option is available for isosurface data windows only. Select a start value s0, the in-
terval step ds, and the number of frames n to be produced. ODV will then construct n 
isosurface values and will re-build the data window for each such value. The current 
data window snapshot will then be added to the animation file.  

For all animations ODV will draw an animation bar indicating the current animation 
interval. The animation bar is centered below the respective window. 
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14.4 Drag-and-Drop 

On most platforms you can drag and drop ODV supported files on the ODV window or 
icon. Depending on the extension of the dropped file, ODV will perform the following 
actions: 

.odv or .var: close current collection or netCDF file and open the dropped collection. 
 
.nc or .cdf: close current collection or netCDF file and open dropped netCDF file. 
 
.txt (ODV spreadsheet files),  
.o4x (ODV list files),   
.csv (WOCE WHP exchange files),  
.jos (Java Ocean Atlas spreadsheet files):  

import data from dropped file into currently open collection. If no collection is 
open when the file is dropped, ODV creates a new collection in the directory of 
the dropped file and imports the data into the newly created collection. 

 

On all platforms, ODV supported file names can also be used as command line argu-
ments. Start ODV from any terminal window by typing: odv4  [file name[.extension]]. 
Note that for file name you either use absolute pathnames or pathnames relative to the 
directory from which you start ODV. If you use a relative pathname, “.” and “..” are not 
allowed. You can use command line arguments to … 

1. start ODV and open an existing collection: use the collection name for file name. 
If you omit an extension, the default .odv is used. 

2. create a new collection and import data: use the name of the data file (must be 
one of ODV’s import types, e.g., .o4x, .txt, .csv, .jos) to be imported for file name. 
In this case you must provide the extension. ODV will create a new collection in 
the directory of the import file and will import the data from the file. The collec-
tion variables are determined from information in the data file. 

14.5 ODV Command Files 

You can store commands for frequently used operations, such as opening a collection, 
loading specific view files and creating graphics or data output files in ODV command 
files. ODV command files can be executed at any time (batch mode) using the 
File>Execute Command File option or using the “–x cmd_file” command line option. The 
default extension of ODV command files is .cmd. The default location is the directory 
odv_local/cmd_files in the user’s home directory. Create directory cmd_files, if it is not 
already present and place your command files in this directory. 

The following commands are currently supported in ODV command files. Note that a 
slash “/” should be used as path separation character in all filenames appearing in ODV 
command files for platform independence. Once a base directory is defined by 
set_base_directory, all subsequent relative filenames are considered relative to base di-
rectory. If no base directory is defined and a collection or netCDF file has been opened, 
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relative filenames are considered relative to the collection or netCDF directory. Multiple 
arguments must be separated by commas “,”. The window index parameter iw may have 
the following values: -1 for the graphics canvas, 0 for the map, and positive integer in-
teger values for data windows. Lines in ODV command files may not exceed 255 charac-
ters in length. Lines with # as first character are treated as comments and are not ex-
ecuted.  

set_base_directory  base_directory 

Define a base directory. All subsequent file names must be either absolute pathnames or names 
relative to base_directory. 

Example:  set_base_directory c:/ewoce/data 

open_collection  collection 

Open collection collection. 

Example:  open_collection c:/ewoce/WoceBtl.var 

load_view  view_file 

Load view file view_file. View_file can be a .xview or .cfg file. load_view is equivalent to load_cfg, 
which is still supported for backward compatibility. 

Example:  load_view c:/cfg_files/abc.xview 

set_annotation_style  ptSize, textColor, bckgrdColor, frameColor, frameWidth 

Set the style of text annotations subsequently created with create_annotation. ptSize is the font size 
in points, textColor is the color of the text, bckgrdColor is the background color of the text bounding 
box, frameColor is the frame color of the text bounding box, and frameWidth is the width of the 
frame around the text bounding box. All colors are specified as index values into the current color 
palette. Specify –1 for bckgrdColor and/or frameColor to avoid drawing of a background box or 
frame. Note that all arguments to set_annotation_style are integers. Default values are: 16, 0, -1, -1, 
0, which will produce 16pt black text without box or frame.  

Example:  set_annotation_style 24, 8, 7, 0, 1 

create_annotation iw, x, y, orientation, textAlign, “text” 

Create a text annotation text for window iw  at position x, y (window iw  coordinates) oriented 
along orientation degrees measured counter-clockwise from positive x-axis. textAlign determines 
the alignment of the text relative to (x, y): center_center 0, center_top 1, center_bottom 2, right_top 
3, right_bottom 4, left_top 5, left_bottom 6, right_center 7, left_center 8. Note that iw  and textAlign 
are integers, x, y, and orientation are floats. Note that the annotation text has to be enclosed in “” 
characters. 

Example:  create_annotation -1, 10., 8., 30., 0, “Some Text” 

export_data  data_file 

Export the data of the current station set to file data_file using the generic ODV spreadsheet for-
mat. 

Example:  export_data c:/output/odv_data.txt 
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export_graphics  iw, graphics_file, dpi 

Save graphics of window iw in file graphics_file using a resolution of dpi dots-per-inch. Use graph-
ics_file extensions .eps, .gif, .png or .jpg for PostScript, GIF, PNG or JPEG output, respectively. Al-
though the dpi argument is not used for PostScript output, it must still be provided.  

Example:  export_graphics –1, c:/output/odv_graph.eps, 300 

quit 

Terminate and exit ODV. 

Example:  quit 

Following below is an example ODV command file that opens a collection, loads a view, 
adds an annotation, writes two image files of the entire canvas and of data window 1, 
respectively, exports the data of the currently selected stations to an ODV spreadsheet 
file, and finally shuts down ODV. 
set_base_directory c:/rschlitz/data/eWOCE/data/whp/bottle 
set_annotation_style 18, 0, 7, 0, 1 

open_collection WoceBtl.var 

load_cfg        cfgAtlanticSections/A15_OXYGEN.cfg 
create_annotation 1, -13.18,65.83,0, 6, "Test" 

export_graphics -1, c:/atmp/A15_OXYGEN.png, 100 
export_graphics  1, c:/atmp/A15_OXYGEN_1.png, 200 
export_data     c:/atmp/A15_OXYGEN.txt 

quit 

14.6 Gazetteer of Undersea Features 

ODV can be used to identify undersea features like seamounts, ridges, fracture zones, 
troughs, basins, etc. To invoke the gazetteer option, choose Extras>Gazetteer from the 
map popup menu. The gazetteer dialog box is shown, which lets you select a specific 
database, lets you specify feature selection criteria as well as size and color of the gazet-
teer marks drawn by ODV. When you press the Switch On button (or Update, if you have 
modified the gazetteer settings), the information from the selected gazetteer database 
is loaded, and the feature positions are marked in the map. Moving the mouse close to a 
feature point invokes a popup window displaying the name of the feature. To switch off 
the gazetteer marks, invoke the gazetteer dialog box again and press the Switch Off but-
ton.  

A number of gazetteer files are provided with the ODV distribution. These include: (1) 
GazetteerGEBCO.gzt from the International Hydrographic Bureau (IHB), (2) Gazet-
teerBGN.gzt from the US Defense Mapping Agency, and (3) WHP_Sections.gzt, which is a 
compilation of the sections occupied during the WOCE Hydrographic Programme. You 
can select feature subsets by specifying a feature type and/or feature name sub-string 
using the gazetteer dialog box. Note that the name and type selections are case-
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insensitive. Use the gazetteer feature selection if you know the name of a feature (or 
part of the name) and want to identify its location (note that you might have to open the 
map to global extent in order to see the feature mark). Gazetteer settings are not saved 
in configuration files. Whenever you open a collection, the gazetteer option is switched 
off initially. 

Gazetteer files can be edited and extended. You can also create your own, new gazetteer 
databases. In order to use a private gazetteer with ODV, the file must have the extension 
.gzt, it must be located in the ODV gazetteer directory (<home>\odv_local\gazetteers, 
where <home> represents your home directory) and its format must satisfy the specifi-
cations below: 

The first line of the file must start with % GZT01: followed by the name of the file.  

Then there are 7 lines starting with % and containing arbitrary comments.  

The next line must be: Feature;Type;No;East-Longitude;North-Latitude; there has to 
be  one blank line following.  

The rest of the file contains the actual item definitions. Each feature is listed on a 
separate line. 

The name of the feature, its type, the number of longitude/latitude points and the longi-
tude/latitude entries are separated by semicolons ”;”. Longitude is specified in degrees 
East (0-360). The number of longitude/latitude points can be up to 1500, and the length 
of a line may be up to 200,000 characters. 

 



Version 4.0 

 100 



ODV User’s Guide  
 

    101 

15 Tips and Tricks 

15.1 Data Quality Control with ODV  

ODV facilitates quality control of multi-parameter datasets by providing a range of au-
tomatic and visual checks for easy identification and flagging of outliers and suspicious 
data. There is support for automated range checks of any basic variable (use option 
Tools>Find Outliers (Range Check)) as well as automatic statistical outlier checks for any 
data window currently applying the VG gridding method (use option Extras>Find Out-
liers (Field Check) of the data window’s popup menu). In both cases, ODV generates lists 
of suspicious data points and allows user controlled (point by point) or automatic flag-
ging of the identified data. 

In addition to automatic quality control procedures, ODV also provides a wide range of 
easy-to-use visual and interactive methods for the identification and editing of outliers. 
For instance, you can plot all data from a given region or along a given section using 
data windows of SCATTER or SECTION scope, easily revealing outliers and questionable 
data in the entire dataset. Flagging or editing the numerical values of the spurious data 
is as easy as clicking on such a data point in one of the data windows and invoking the 
Edit Data option of the variable that you want to modify. Note that all changes made to a 
data collection are logged in the collection logfile. The log record includes information 
about the sample that was changed, the date and time of the modification, the user who 
made the change and the computer on which the operation was performed. You can 
browse the collection logfile at any time using option Collection>Browse Log File.  

In the example below, outliers for salinity and oxygen can easily be spotted in the plots 
showing the data of an entire cruise. Clicking on such an outlier point selects it as cur-
rent sample, which can then be edited and/or flagged.You can hide and exclude bad or 
questionable data from the analysis by establishing data quality sample filters. 

 

 
Figure 15-1: Identification of outliers for a zonal section in the North Atlantic 
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15.2 Visualizing Data from XYZ ASCII Files  

Irregularly spaced or gridded data for some quantity Z at given X and Y coordinates are 
commonly provided in files using three-columns for the X, Y and Z values, respectively. 
Examples of such XYZ datasets are (1) maps of a given Z variable (X represents longi-
tude, Y represents latitude), (2) vertical sections (X=along section coordinate, Y=depth) 
or (3) time-evolution plots (X=some geographical coordinate, Y=time or vice versa). 

You can load all these XYZ files into ODV and you can analyze and display the Z data us-
ing the full suite of ODV functions. Note that the procedures described below can also be 
applied to data files with multiple Z variables, e.g., files with more than three columns.  

Here is how to proceed if the XYZ file represents a map: 

1. Create a new collection (choose a destination directory and collection name) 
with just two variables Depth [m] and Z-variable (use a descriptive label and ap-
propriate units for the Z-variable), 

2. Import the XYZ file by choosing Import>ODV Spreadsheet and selecting the XYZ 
file (note that you have to choose file-type All Files, if the extension of the XYZ file 
is not .txt).  

3. On the Spreadsheet File Properties dialog specify (1) the column separation cha-
racter (the items from the header line should appear on separate lines in the 
Column Labels list), (2) the line number containing XYZ labels (keep 1, if no la-
bels are provided), and (3) the line number of the first data line, 

4. On the Metadata Variable Association dialog associate the X-variable with Longi-
tude [degrees_east] and the Y-variable with Latitude [degrees_north], 

5. On the Import Options dialog associate the Z-variable (source) with the second 
collection variable (target). Then click on the first collection variable (target), 
click on Use Default and specify the default depth value (use 0, if in doubt). 

ODV will import the data from the XYZ file, and lets you operate on the data in the usual 
way. To create a page with a map of the Z-variable create a data window with SURFACE 
scope. Modify the data window’s properties as usual, if this is necessary. 

15.3 Overlaying a Property Distribution with Contour Lines of another Property 

With ODV, you can produce section or isosurface plots where the distribution of one 
property (color shaded and/or contoured) is overlaid with contour lines of another 
property. Useful applications, of this technique are, for instance, density contours on 
top of any property section or depth contours on isosurface or isopycnal distributions.  

To produce such plots, follow these steps: 

• Switch to window layout mode via View>Window Layout.  

• Setup the window for the underlying distribution (window a: define size and posi-
tion; select a Z-variable for that window (property A) using the Properties option). 

• Create an overlay window for window a by moving the mouse over window a, click-
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ing the right mouse button and selecting Create Overlay Window. Now select the Z-
variable for the overlay window b (property B). Leave Window Layout mode by 
choosing Accept from the Window Layout context menu. 

 

 
Figure 15-2: Oxygen contour lines on top of color shaded phosphate distribution 

 

• ODV will draw a default set of white contour lines for property B on top of the color 
distribution of property A. You may add or delete lines or modify properties of the 
contour lines of B by right-clicking on the overlay window by choosing Proper-
ties>Contours. 

• If you are satisfied, save the view for later use (View>Save View As). 

Note that for a window entirely overlain by another window (like window a), the only 
way to access and modify its properties is via the View>Window Properties option from 
the main menu.  

15.4 Pre-computing and Storing Neutral Density Values in Collections 

Compared to most other derived variables, such as potential temperature, potential 
density, or Brunt-Väisälä Frequency, that can be calculated easily and quickly on-the-fly, 
the calculation of neutral density is computationally expensive. While this is not a prob-
lem for small data collections or when plotting only a small number of stations, using 
on-the-fly neutral density calculations with large collections and on long sections can be 
slow and inefficient. If you are working with large datasets and need neutral density 
regularly, you should consider to pre-compute neutral density and store the results in 
collection files on disk. You can then use the pre-computed values from the disk files. 
The disadvantage of pre-computing and storing these values is that they become out-of-
date if any of the input data pressure (or depth), temperature and salinity changes (e.g., 
after data edits or calibration changes). It is the user’s responsibility to re-compute the 
neutral density values whenever pressure (or depth), temperature or salinity data have 
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changed or have been added.  

To create a new collection with pre-computed neutral density values for all stations or a 
station subset of an existing data collection follow these steps: 

1. Open the existing collection and select the stations to be included in the new col-
lection with pre-computed neutral density. If you want to process the entire col-
lection, make sure you have a global map and the number of selected stations is 
identical to the number of stations in the collection (e.g., two numbers at the end 
of the status bar should agree). 

2. Define Neutral Density as a derived quantity using option View>Derived Va-
riables. 

3. Export the station data including neutral density to a spreadsheet file, by choos-
ing Export>ODV Spreadsheet. Specify a name for the new dataset (denoted as 
xxx.txt in the following) and make sure that Neutral Density is selected for output 
in the Select Variables for Export list.  

4. Use xxx.txt to create a new collection by simply dragging and dropping this file 
on the ODV desktop icon (Windows and some other platforms) or by starting 
ODV from a terminal window with “odvmp xxx.txt” (UNIX, Linux, Mac OS X). The 
newly created collection xxx will have Neutral Density as one of its basic va-
riables stored in the disk files. 

15.5 Using ODV Graphics in Publications and Web Pages  

ODV graphics files of the entire canvas or individual data windows can easily be in-
cluded in print documents, posters or on Web pages.  

To create GIF, PNG or JPG files of the entire canvas or of individual plots press Ctrl-s 
while the mouse is over the canvas or the respective plot window and choose GIF, PNG 
or JPG as output type. Then specify the desired resolution of the graphics file (default: 
screen resolution) and use the GIF, PNG or JPG graphics files in your web pages or in 
text documents. For print documents you can either produce GIF and PNG files with 
high resolution, or you can use ODV PostScript (.eps) output instead. 

A variety of typesetting and page design software support the import of Encapsulated 
PostScript files (.eps) in mixed text/graphics pages (e.g., MS Word or compatibles, La-
TeX, Adobe PageMaker, etc.). If you use the LaTex typesetting system, see the file 
Pssample.tex (usually in directory c:\Program Files\Ocean Data View (mp)\Samples) 
for an example on how to include PostScript graphics in TeX documents. Note that the 
required epsf and epsfig style files are also included in the samples directory.  

If you use Word or PageMaker or other publishing software follow these guidelines: 
Compose your page as usual and insert the respective ODV PostScript file at the right 
position. Adjust the size of the figure appropriately. When you are done composing the 
page you can directly print the document on a PostScript printer. If no PostScript prin-
ter is available you need to have a PostScript printer-driver and the 
GhostScript/GhostView package (http://www.cs.wisc.edu/~ghost/aladdin/index.html) 

http://www.cs.wisc.edu/~ghost/aladdin/index.html�
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installed on your machine. In that case select the PostScript printer-driver as printer 
and redirect the output into a file. Open this file with GhostView and print to any printer 
connected to your system. 

15.6 Making Cruise Maps 

You can create full-page, high quality stations maps showing the currently selected sta-
tions of the open data collection using View>Window Layout>Layout Templates>Full 
Screen Map. Station maps may also be produced if you only have access to the station 
metadata (e.g., station postions, dates, etc.), but the actual station data are unaccessible. 
Here is how to proceed: 

• In an empty directory on your disk create an ASCII file that contains the longi-
tude, latitude coordinates of the stations or way-points of your track. This file 
should have a descriptive name (e.g., CruiseTrack_xxx.txt, where xxx represents 
the name of your cruise) and it should comply with the generic ODV spreadsheet 
format specifications.  

As first line of the file use the following header line (note that columns are TAB sepa-
rated): 
 
Cruise  Station Type yyyy-mm-ddThh:mm Longitude [degrees_east] Latitude [degrees_north]
 Bot. Depth [m] Dummy1 Dummy2 
 
Immediately following the header line, add one data line for each station or cruise track 
node and provide the following information for the respective station or node:  
 
Cruise The name of the cruise 
Station Station label or number 
Type “B” 
yyyy-mm-ddThh:mm Station date and time 
Longitude [degrees_east] Decimal longitude of station  
Latitude [degrees_north] Decimal latitude of station  
Bot. Depth [m] Bottom depth at station location or “0” 
Dummy1 “0” 
Dummy2 “0” 
  

• On Windows systems drag-and-drop the prepared cruise track file on the ODV 
desktop icon. On all other platforms start ODV and open the cruise track file via 
File>Open and choosing file type Data Files (*.txt *.csv *.jos *.o4x). 

• Add new stations to the end of the cruise track file, if necessary, and drag-and-
drop the updated file on the ODV desktop icon (Windows) or invoke ODV using 
the cruise track file name as a command line argument (all other platforms). 

15.7 Preparing Custom Coastline and Bathymetry Files  

ODV comes with a medium resolution global set of coastline and bathymetry files 
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(GlobHR). Higher resolution versions of coast/bathymetry data are available as optional 
packages for selected regions, such as the Arctic, Baltic, NorthSea, MeditHR and many 
others. If you need high-resolution coastline and bathymetry files for a region not in-
cluded in the ODV distribution and if you have such high-resolution data available, here 
is how to produce ODV usable files. 

Preparing New Files 
The data for the coastline and bathymetry contours must be in separate files. Use 
World.coa as name for the coastline file. The names of the bathymetry files must follow 
the xxxm.coa scheme, where xxx represents the depth value of the respective contour 
(no white space between the depth value and the m; example: 1000m.coa). For a sample 
.coa file see the samples directory of your ODV installation. 

The latitude/longitude coordinates of the coastline or depth contour are stored in indi-
vidual polygon segments (see Figure below). The first nS nodes of a segment represent a 
part of the actual coastline or bathymetry contour. This part of the segment is stroked 
when the outline of the contour is requested. In addition, each segment can have an op-
tional, second part which will not be stroked but is only used to properly close the seg-
ment. Segments that also contain this second part can be filled and/or stroked. The total 
number nT of nodes in any segment must not exceed 1500. If a segment has no second 
part, the number of stroke points nS must be equal to nT. 

 

 
Figure 15-3: Schematic diagram of an ODV coastline/bathymetry segment. 

 

Latitude/longitude coordinates are decimal values: longitude is in degrees East (0 – 
360) and latitude is in degrees North (-90 – 90). A polygon segment in a .coa file is spe-
cified as follows: 
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nT  nS 

lat1 lon1 

..... 

latnT lonnT 

 

where nT is the total number of vertices for this segment and nS is the number of ”true” 
coast/bathymetry vertices. nT may be larger than nS, in which case vertices nS +1 .... nT  
are used to close the segment (land-side closure). These extra vertices are not shown 
when the segment is stroked. Note that both, nT and nS, must be smaller than 1500. On 
the line following the last vertex of a segment, the next segment is started by specifying 
its nT and nS values. There is no blank line between segments. To indicate the end of the 
file put ”0 0” in the last line of the file. .coa files have to be converted to binary format 
(.cdt files) before they can be used by ODV. A .coa to .cdt converter (coa2cdt.exe) is in-
cluded in the ODV distribution package for Windows. To use the coa2cdt converter do 
the following: 

1. In the directory containing the .coa files create a file coa2cdt.inp and enter the 
names of the .coa files to be processed. Put one file name per line and omit the 
.coa extension. 

2. In a DOS box change to the respective directory and execute coa2cdt.exe. Make 
sure the coa2cdt.exe executable is in your path or in the .coa directory. Also make 
sure that the .coa files satisfy the .coa format, as described above. 

The .cdt files created by coa2cdt.exe are platform-independent and can be used on all 
supported platforms. 

Please note that if you want to fill the bathymetry and coastlines, you have to close all 
polygons in the .coa files, and the interior of the polygons must represent the areas that 
are shallower than the respective depth contour or coastline. If your depth contours or 
the coastline does not consist of closed polygons, you can still use them with ODV, how-
ever, you should select a line drawing mode and avoid filling in those cases.  Use the 
Display Options menu of the map to change display settings accordingly (see Using New 
Files below). 

Installing New Files 
When installing the binary version of coastline-, bathymetry-, topography and overlay 
files follow these instructions: 

• Create a new subdirectory of the ODV coast directory (normally: c:\Program 
Files\Ocean Data View (mp)\coast) and choose a descriptive name for it (e.g., 
GulfOfMaine). This directory is the base directory of the new file series.  In the 
new directory create subdirectories bathymetry, topography, and overlays. 

• Copy the coastline file (normally called World.cdt) into the series base directory 
(e.g., c:\Program Files\Ocean Data View (mp)\coast\ GulfOfMaine). 

• Copy all bathymetry files (e.g., 100m.cdt, 500m.cdt, etc.) into the bathymetry 
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subdirectory, all topography files into the topography directory and all general 
purpose overlay files (rivers, lakes, borders, etc.) into the overlays directory. If 
no topography and/or overlay files are available the respective directories re-
main empty. 

Using New Files 
To use the newly installed files in ODV maps do the following: 

• Invoke the map Display Options dialog box (e.g., right-click the mouse while over 
the map and choose Display Options) and select the Layers tab. 

• Choose the newly installed series name (e.g., GulfOfMaine) in the Series combo-
box. 

• Compose the layer-set(s) of interest by selecting a layer-set (e.g., Ocean Bathy-
metry) and then pressing Compose. Select the contour files that you want to use 
in the Available list, set the desired stroke and fill properties and finally press << 
to add the files to the Selected list (note: if you forget to press << no file is added). 
To remove files from the Selected list select them and press >>.  

When specifying drawing characteristics follow these rules:  

(a) If the features should be outlined by lines (stroked), choose the appropriate 
line-width, -type and –color or choose none as color, if you don’t want out-
lines. Note that due to limitations of the operating system, on some Windows 
versions thick lines will always be drawn as solid lines on the screen and in 
GIF, PNG and JPG output files. ODV PostScript files, however, honor your se-
lection for any line-width. 

(b) If the features should be filled choose the appropriate Fill color or none, if 
you don’t want filling.  

If you choose automatic for line and fill colors, ODV will use default colors. Note that for 
some layer sets automatic defaults to none. Also note that some feature files like rivers 
or borders should not be filled and you should explicitly set the fill color to none. 

ODV processes the layer sets in the order as listed in the Display Options dialog box. For 
a given layer set it draws the individual layers in the order in which they appear in the 
Selected list (note that ocean bathymetry and land topography layers are sorted auto-
matically when they are added). You should define sea-ice distributions in the pre-
Coastlines set and lakes, rivers and borders in the post-Topography category. 
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16 NetCDF Support 

16.1 NetCDF Overview 

The Network Common Data Form (NetCDF) is an interface for array-oriented data sto-
rage and access, which is widely used in climate research and other fields of geo-
sciences. Many important datasets and model output files are distributed in netCDF 
format. 

16.1.1 NetCDF data is: 

• Self-Describing. A netCDF file includes information about the data it contains.  

• Architecture-independent. A netCDF file is represented in a form that can be ac-
cessed by computers with different ways of storing integers, characters, and 
floating-point numbers.  

• Direct-access. A small subset of a large dataset may be accessed efficiently, with-
out first reading through all the preceding data.  

• Appendable. Data can be appended to a netCDF dataset along one dimension 
without copying the dataset or redefining its structure. The structure of a 
netCDF dataset can be changed, though this sometimes causes the dataset to be 
copied.  

• Sharable. One writer and multiple readers may simultaneously access the same 
netCDF file.  

16.1.2 NetCDF conventions 

The netCDF data model is very general, and the structure and contents of netCDF files 
can vary considerably. In order to facilitate and promote the interchange and sharing of 
netCDF datasets, a variety of conventions have been defined. Two of these conventions 
(COARDS and GDT; see http://www.unidata.ucar.edu/packages/netcdf/conventions.html 
for detailed specifications) are widely used by climate researchers and modelers, and 
many datasets are available as COARDS/GDT compliant netCDF files. Examples of such 
datasets can be downloaded from http://www.cdc.noaa.gov/PublicData/, 
http://ferret.wrc.noaa.gov/, http://ingrid.ldeo.columbia.edu/, or 
http://www.epic.noaa.gov/epic/ewb/. 

For more information on netCDF, see the netCDF web page 
http://www.unidata.ucar.edu/packages/netcdf/. 

16.1.3 ODV netCDF support 

ODV can read and visualize the data in a netCDF file as if it was an ODV collection. The 
full suite of ODV capabilities is available when working with netCDF files. Exceptions 
are those functions that require write permission to the netCDF file and would modify 

http://www.unidata.ucar.edu/packages/netcdf/conventions.html�
http://www.cdc.noaa.gov/PublicData/�
http://ferret.wrc.noaa.gov/�
http://ingrid.ldeo.columbia.edu/�
http://www.epic.noaa.gov/epic/ewb/�
http://www.unidata.ucar.edu/packages/netcdf/�
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the dataset (ODV will never write to a netCDF file). If the netCDF file follows the 
COARDS and GDT netCDF conventions, ODV will be able to interpret a large variety of 
variables such as absolute and relative time formats and it can identify attributes of va-
riables such as missing value indicators, long variable names, units and others. ODV 
allows subsetting of the data, often required for efficient data access in very large data-
sets.  

16.2 Using netCDF Files 

ODV can read and display data in netCDF files, widely used by researchers in different 
fields of geo-sciences. Based on only a few user specifications and selections, ODV ac-
cesses and interprets a given netCDF file in a way that mimics (emulates) a native ODV 
collection. The full suite of ODV’s analysis and visualization capabilities is provided for 
the exploration of the data in the netCDF file. There is no need to translate and re-write 
the data first. Depending on the structure and contents of a netCDF file, different ODV 
“emulations” are possible. Settings of individual emulations are saved in view files for 
later use. Note that netCDF files are platform independent and the same file can be used 
with ODV on Windows or Solaris platforms. 

 (1) Opening a netCDF file 
You open a netCDF file with ODV by choosing File>Open netCDF File. Use the standard 
Windows file selection dialog to identify the file that you want to open. Alternatively 
you can start ODV from the command line and specify a netCDF file name as a command 
line argument. On Windows, you can also drag a netCDF file on the ODV desktop icon. In 
all cases the extension of the netCDF file must be either .nc or .cdf. ODV opens the 
netCDF file and retrieves information on dimensions and variables contained in the file. 

 (2) Defining the netCDF emulation 
In a sequence of steps you must now define how ODV should view (or emulate) the 
netCDF file. This involves selection and subsetting (if required) of coordinate axis (di-
mensions), association of ODV header variables with information from the netCDF file 
and the definition of the primary variable (first variable in an ODV collection), which 
determines the logical structure of a “station” (e.g., profile, sequence, etc.) and the sort-
order within a station. 

ODV first asks whether a new emulation is to be defined or whether a previously de-
fined and saved emulation should be used. If you choose a previously defined emula-
tion, no additional input is required and ODV proceeds as if it was using a native ODV 
collection: it draws a station map and offers the full suite of ODV analysis and display 
capabilities. Note that ODV will not modify an open netCDF file and treats it as a read-
only dataset. As a consequence, all ODV functions that require data-write operations 
(data import, header and data editing, collection manipulation operations, etc.) are dis-
abled when working with netCDF files. 

 (2.a) Selecting netCDF coordinates 
If you define a new emulation, the first step is to select netCDF coordinates. ODV will 
show a list of coordinates contained in the file.  

http://www.unidata.ucar.edu/packages/netcdf/conventions.html�
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Using extended selection techniques (hold down the Ctrl or Shft keys while clicking the 
left mouse button) select all the coordinates that you want to use. If multiple coordi-
nates are provided for the common coordinates X (Longitude), Y (Latitude), Z 
(Depth/Height), and T (Time), make sure to select only one for each direction.  

For a given selection of coordinates, the set of netCDF variables that are defined on 
these dimensions is shown in the Corresponding Variables list. Make sure that the va-
riables that you are interested in are shown in this list. Other variables in the netCDF 
file that depend on coordinates not selected in the Dimensions list are not shown as Cor-
responding Variables. These variables will remain unavailable unless you select the cor-
responding dimensions. To view the complete header information of the netCDF file 
(similar to a “ncdump –h” call) press netCDF Info. 

 

 
Figure 16-1: The netCDF emulation dialog (step 1 of 4) 

 

 

(2.b) Specifying metadata information 
Next, you must identify the netCDF variables that provide header (or meta-) informa-
tion for the ODV stations: e.g., longitude (Longitude [degrees_east]), latitude (Latitude 
[degrees_north]), date (mon/day/yr), etc. This is done by establishing associations be-
tween variables from the netCDF file (Source Variables list) and the ODV header va-
riables (Target Variables list). ODV will try to identify and associate variables automati-
cally. Manual association of variables is only necessary for those header variables not 
marked by a * in the first column. Usually it is sufficient to associate Longitude [de-
grees_east], Latitude [degrees_north], and mon/day/yr. For header variables not asso-
ciated with any netCDF variable, ODV uses default settings. You can modify the default 
value for a header variable (e.g., Cruise, etc.) by selecting it in the Target Variables list 
and pressing Set Default. 

To establish a (1-to-1) association between a netCDF variable and an ODV header vari-
able, select the netCDF variable in the Source Variables list and the header variable in 
the Target Variables list and press Associate. To establish a conversion between a 
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netCDF and ODV header variable (usually needed for netCDF time variables), select the 
two variables as above and then press Convert. Choose one of the available conversion 
options from the combo-box and press OK. For the General Linear Transformation pro-
vide a scale factor and an offset. 

Many netCDF files use relative times as days or hours since a specific start date. You can 
exploit this information to obtain date and time of a station. To do so select the relative 
time in the Source Variables list and mon/day/yr in the Target Variables list, then press 
Convert. ODV will try to establish a conversion function automatically, or it lets you 
choose an appropriate conversion algorithm manually. Note that ODV assumes that the 
reference date is based on the Gregorian calendar. ODV mon/day/yr values are Grego-
rian dates. 

Note that the metadata variables Station and Type are set automatically by ODV.  

 

 
Figure 16-2: The netCDF emulation dialog (step 2 of 4) 

 

 (2.c) Selecting primary coordinate 
Then you have to select the primary coordinate, which is subsequently used by ODV as 
first collection variable. This variable is also used as sorting variable within a sta-
tion/profile/sequence. Specifying the primary coordinate is important, because this 
determines the logical structure of what ODV treats as a station. If, for instance, you use 
“Depth” or another vertical coordinate as primary coordinate, the stations will 
represent vertical profiles; if you use Time, the stations will represent sequences in 
time. If the mon/day/yr header variable was defined in step 2.b above, the Use Decimal 
Date/Time item is enabled and you can use a decimal time variable (units=YEARS) de-
rived from the station header as primary coordinate (note that for time-series, the 
mon/day/yr header information refers to the start of the time series and is a constant 
value). 
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Figure 16-3: The netCDF emulation dialog (step 3 of 4) 

 

If the data in the netCDF file represent values on horizontal surfaces (e.g., fluxes across 
the air-sea interface, etc.) and there is no netCDF variable that explicitly specifies the 
respective surface (e.g., no vertical coordinate or time variable) choose the Use Dummy 
Variable item. 

 

(2.d) Subsetting coordinates 
When working with large netCDF datasets, it is convenient to restrict data access to the 
domain and range of interest. You can do this by subsetting coordinate variables or by 
zooming into the map.  

 

 
Figure 16-4: The netCDF emulation dialog (step 4 of 4) 

 

To subset a particular coordinate select the corresponding item in the Coordinates list 
and press the Subset Coordinate button. ODV shows a list of the respective coordinate 
values and lets you specify a start index, increment, and end index for this coordinate. 
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Press OK to accept the new index set. Repeat this procedure for all dimen-
sions/coordinates that you want to subset.  

If longitude and latitude have been defined in step 2.b, you may visually subset these 
coordinates by zooming into the map. To do so, press the Zoom into Map button, then 
resize and/or move the red zoom box to the desired domain. Press the Enter button or 
double-click the left mouse to accept your choice. Press ESC or right-click the mouse to 
abort the zoom operation. 

 

(3) Exploring the netCDF file 

Once steps 2.a through 2.d are completed, ODV draws a station map and lets you ex-
plore the data in the netCDF file in the same way as if you were using a native ODV data 
collection. Note that ODV treats netCDF files as read-only datasets and never writes to 
these files. Therefore, all options that require data write access are disabled when 
working with netCDF files. This includes all data import operations, editing of metadata 
and data values, most collection manipulation operations, and others. 

ODV stores netCDF emulation settings in view files and uses these settings if you open 
the netCDF file the next time. Should you want to establish new emulation settings 
please proceed as follows: Open the netCDF as usual. Then, with the netCDF file open, 
open the netCDF file again by choosing File > 1.  

Also note that data access from netCDF files is somewhat slower as compared with na-
tive ODV collections. If you are using large netCDF datasets with hundred thousands of 
stations you may encounter slow buildup of  SCATTER and/or SURFACE plots. In such 
cases you should subset coordinates (see above) or you should export the netCDF data 
to a native ODV collection using Export>ODV Collection and then use the newly created 
collection for analysis and visualization. 
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17 Appendix 

17.1 Mouse and Keyboard Actions 

Table 17-1: Mouse actions in ODV’s Ready status. 

Action Object Response 

 
  

L-Click Map 

 

Data Window 

Selects the closest station as current station. 

 

Selects the closest sample as current sample and the parent station as current 
station. 

   

Shft L-Click Map 

 

 

Data Window 

Selects the closest station as current station. Allows selection from list of mul-
tiple stations at the same location. 

 

Selects the closest sample as current sample. Allows selection from list of 
multiple samples at the same location. 

   

L-DbleClick Map Adds the closest station to the pick list and adds the data of this station to 
STATION data windows. 

   

L-Drag GObject 

 

Canvas, Map, 
Data Window 

Drags the graphics object (if object allows dragging). 

 

Drags the canvas (if scroll bars are present). 

   

Ctrl L-Drag 1) Map 

 

Data Window 

Quick-zooms into the map. 

 

Quick-zooms into the data window. 

   

R-Click 2) Canvas, Map, 
Data Window, 
GObject, Data 
List Windows 

Invokes element specific context menu. 

   

Shft R-Click 3) Map, Data 
Window 

Invokes the Extras menu of the map or data window. 

1) On Mac OS X systems hold down the Apple  key and click-and-drag the mouse. 
2) On Mac OS X systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 
3) On Mac OS X systems with a single-button mouse hold down the Alt and Shft keys while clicking the mouse to simulate a Shft right 
mouse button click. 
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Table 17-2: Key press actions in ODV’s Ready status. 

Key Response 

  

Enter Adds the current station to the pick list and adds the data of this station to STATION data windows (if 
any). 

  

Del Removes the current station from the pick list and removes the data of this station from STATION data 
windows (if any). 

  

# Allows selection of a new current station using internal sequence numbers. 

→ Selects the next station as current station. 

← Selects the previous station as current station. 

HOME Selects the first sample as current sample. 

↓ Selects the next sample as current sample. 

↑ Selects the previous sample as current sample. 

END Selects the last sample as current sample. 

PgDn Steps down (forward) the current sample. 

PgUp Steps up (backward) the current sample. 

  

F1 Shows the ODV help document. 

F4 Shows the data statistics of the window containing the mouse. 

F5 Redraws the entire canvas or the window containing the mouse. 

  

Ctrl-C 1) Copies the data of the window containing the mouse to the clipboard. 

Ctrl-F 1) Adjusts the X, Y, Z ranges of the window containing the mouse (or of all data windows) to full range.  

Ctrl-P 1) Prints the entire graphics canvas. 

Ctrl-S 1) Saves the window containing the mouse (or the entire canvas) to an image file (gif, png, jpg). 

  

Alt-D Allows to define derived variables. 

Alt-S Allows to change the station selection criteria. 

Alt-W Allows to change the window layout. 

  

Shft-L Loads view settings from a file. 

Shft-S Allows to modify the sample selection criteria (range and quality filters). 

  

ESC Aborts the current operation (if supported by operation). 
1) On Mac OS X systems hold down the Apple  key while pressing the other key. 
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Table 17-3: Mouse and key press actions in Zoom or Z-Zoom modes. 

Action Object Response 

   

L-Drag Boundaries and corners 
of zoom rectangle 

Resizes the zoom rectangle. 

   

L-DbleClick or 

ENTER 

anywhere Accepts current settings and terminates zooming. 

   

R-Click 1) or ESC anywhere Discards changes and aborts zooming. 
1) On Mac OS X systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 

 
Table 17-4: Mouse and key press actions in GetPoints modes. 

Action Object Response 

   

L-Click Canvas, Map, Data Win-
dow 

Add current point to list. 

   

R-Click 1) Canvas, Map, Data Win-
dow 

Remove closest point from list. 

   

ENTER anywhere Accept current settings and terminate GetPoints mode. 

   

ESC anywhere Abort GetPoints mode. 

1) On Mac OS X systems with a single-button mouse hold down the Alt key while clicking the mouse to simulate a right mouse button 
click. 
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17.2 Quality Flag Schemes 

ODV supports most quality flag schemes widely used in the oceanographic community. 
Any of these schemes can be used to encode the quality flags of a given meta- or collec-
tion variable. See Table 17-5 and file ODV4_QualityFlagSets.pdf for summaries of sup-
ported schemes, lists of quality flag codes and their meaning as well as code mappings 
between the schemes.  

 
Table 17-5: Quality flag schemes supported by ODV. For full lists of quality flag values and value mappings 

between the different schemes see file ODV4_QualityFlagSets.pdf.  

SchemaID Comment 

ARGO ARGO quality codes. Reference: Argo data management, User’s manual, 
Version 2.1, http://www.usgodae.org/argo/argo-dm-user-manual.pdf  

BODC BODC quality codes. Reference: 
http://www.bodc.ac.uk/data/codes_and_formats/request_format/  

ESEAS European Sea Level Service quality codes. Reference: 
www.eseas.org/eseas-ri/deliverables/d1.2/ESEAS_QC_29032005.doc  

GTSPP GTSPP quality codes. Reference: http://www.meds-sdmm.dfo-
mpo.gc.ca/meds/Databases/OCEAN/GTSPPcodes_e.htm  

ODV ODV generic quality flags. Reference: ODV User’s Guide, 
http://odv.awi.de/en/documentation/ 

QARTOD Qartod quality flags. Reference: 
http://dmac.ocean.us/dacsc/docs/apr2005_post_mtg/QARTODI_II.ppt  

PANGAEA PANGAEA generic quality flags. Reference: 
http://wiki.pangaea.de/wiki/Quality_flag  

SEADATANET SeaDataNet quality codes. Reference: 
http://vocab.ndg.nerc.ac.uk/term/L201/1/  

SMHI Swedish Meteorological and Hydrographic Institute quality codes. 

WOCEBOTTLE WOCE bottle value quality codes. Reference: 
http://odf.ucsd.edu/joa/userguide/docs/woceigossqualitycodes.html  

WOCECTD WOCE CTD value quality codes. Reference: 
http://odf.ucsd.edu/joa/userguide/docs/woceigossqualitycodes.html  

WOCESAMPLE WOCE WHP quality flags for the water bottle itself. Reference: 
http://odf.ucsd.edu/joa/userguide/docs/woceigossqualitycodes.html  

WOD World Ocean Database individual observed level quality codes. Reference: 
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ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

WODSTATION World Ocean Database entire station quality flags. Reference: 
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf  

 

17.3 Generic ODV Spreadsheet Format 

The ODV generic spreadsheet format is the recommended format for exchange of data 
beween data producers and data users. The generic spreadsheet format allows auto-
matic import of data into ODV collections, not requiring any user interaction. ODV also 
uses the generic spreadsheet format when exporting data from collections, and the ex-
ported datasets may easily be re-imported into the same or a different collection, possi-
bly after editing and modifying the data in the file. Exporting data from the open collec-
tion into a generic spreadsheet file is done via the Export>ODV Spreadsheet option. 

ODV generic spreadsheet files use the ASCII encoding, and the preferred file extension 
is .txt. Station metadata and data are provided in separate columns, where metadata 
and data columns can be in arbitrary order. Every metadata and data column may have 
an optional quality flag column. A quality flag column may appear anywhere after the 
metadata or data column it belongs to. Quality flag values may be in any one of the sup-
ported quality flag schemes (see Table 17-5). The total number of columns in the file is 
unlimited. All non-comment lines (see below) in the file must have the same number of 
columns. Individual columns are separated by TAB or semicolon ; .  

Typically, ODV spreadsheet files hold the data of many stations from many cruises. The 
number of lines in a file, as well as the length of individual lines are unlimited. There are 
three types of lines in ODV generic spreadsheet files: (1) comment lines, (2) the column 
labels line, and (3) data lines.  

17.3.1 Comment Lines 

Comment lines start with two slashes // as first two characters of the line and may con-
tain arbitrary text in free format. Comment lines may, in principle, appear anywhere in 
the file, most commonly, however, they are placed at the beginning of the file and con-
tain descriptions of the data, information about the originator or definitions of the va-
riables included in the file. Comment lines are optional. 

Comment lines may be used to carry structured information that may be exploitet by 
ODV or other software. Examples are the //SDN_parameter_mapping block employed by 
the SeaDataNet project, and containing references to variable definitions in official pa-
rameter dictionaries, or the //<attribute_name> lines defined by ODV, containing values 
for given attribute names. The currently defined attribute names are summarized in 
Table 15-6. Structured comment lines may only appear before the column labels line or 
the first data line.  

ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf�
ftp://ftp.nodc.noaa.gov/pub/WOD05/DOC/wod05_tutorial.pdf�


Version 4.0 

 120 

Table 17-6: Summary of comment line attributes names supported by ODV. 

Attribute 
Name 

Possible Values 

File information 

Creator Free text specifying the creator of the file. 

Example: //<Creator>rschlitz@GSYSP168</Creator> 

CreateTime Time of file creation in ISO 8601 extended format. 

Example: //<CreateTime>2008-05-16T09:53:45.2</CreateTime> 

Software Software used to create the file. 

Example: //<Software>Ocean Data View - Version 4.0.0</Software> 

Source Absolute path of source collection. 

Example: //<Source>C:/rschlitz/data/eWOCE/data/whp/bottle/WoceBtl</Source> 

SourceLast-
Modified 

Last modified time of source collection in ISO 8601 extended format. 

Example:  
//<SourceLastModified>2003-11-11T19:53:45.2</SourceLastModified> 

Version Version of the file. 

Example: //<Version>ODV Spreadsheet V4.0</Version> 

Data information 

DataField GeneralField, Ocean, Atmosphere, Land, IceSheet, SeaIce, Sediment 

Example: //<DataField>Ocean</DataField> 

DataType GeneralType, Profiles, TimeSeries, Trajectories  

Example: //<DataType>Profiles</DataType> 

 

17.3.2 Column Labels 

There has to be exactly one line containing the labels of the columns. This column labels 
line must always be present, it must appear before any data line and it must be the first 
non-comment line in the file. 

ODV generic spreadsheet files must provide columns for all mandatory metavariables 
(see Table 3-3), and the following labels must be used exactly as given as column labels: 
Cruise, Station, Type, one of the supported date/time formats, Longitude [degrees_east], 
Latitude [degrees_north], Bot. Depth [m]. The recommended date/time format is ISO 
8601, which combines date and time as yyyy-mm-ddThh:mm:ss.sss in a single column. 
The labels Lon (°E) and Lat (°N) for longitude and latitude are still supported for back-
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ward compatibility.  

 

Metadata labels may have extensions of the form :METAVAR:<valueType>:<valueBytes> 
to indicate that the column represents a metavariable of a given value type and byte-
length. valueType may be one of the following: BYTE, SHORT, INTEGER, FLOAT,  
DOUBLE, or TEXT. valueBytes is only needed for valueType=TEXT and represents the 
maximum number of characters to be stored in this field (default: 21Bytes). Note that 
one of the characters is used for string termination and is not available for actual meta-
data text, e.g., a TEXT field of 21 bytes can store a maximum of 20 characters of metada-
ta text. 

Examples:  Longitude [degrees_east]:METAVAR:DOUBLE 
Citation:METAVAR:TEXT:81 
DOI:METAVAR:TEXT:81 
 

 

Data variable labels should include unit specifications enclosed in brackets [ ], e. g., 
Depth [m]. Exactly one column label may have the :PRIMARYVAR extension to indicate 
that this column is the primary variable. 

Example: Depth [m]:PRIMARYVAR 

 

Quality flag column labels must comply with the following naming conventions to 
enable automatic identification of the meta- or collection variable they belong to, as 
well as of the particular quality flag scheme used.  

ODV generic spreadsheet quality flag labels may be specified in one of the following 
forms:   

• QV<Text>:<SchemaID>:<columnLabel> 

• QV<Text>:<SchemaID>:STATION 

• QV<Text>:<SchemaID>:SAMPLE 

• QF 

<Text> is an arbitrary and optional string, <SchemaID> is one of the supported quality 
flag schema identifier (see Table 17-5) and <columnLabel> is the column label of the 
variable to which the quality flag column belongs. The <Text>, <SchemaID> and <colum-
nLabel> parts of the quality flag label are optional. If the <SchemaID> item is missing, it 
is assumed that the quality flag values are ODV generic quality flags. If the <columnLa-
bel> part is missing, it is assumed that the quality flags belong to the variable preceding 
the quality flag column. Note that if the <Text> item is present, it may not contain the ‘:’ 
separation character. Also note that <Text> is not evaluated or used by ODV. This item is 
only included to allow unique column labels for applications that require this feature 
(e.g., QV1, QV2, etc.). 
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In addition to quality flag values for individual data values, ODV also supports entire 
station quality flags describing general quality aspects of the entire station (single flag 
for a given station; e.g., WOCE entire station flags), as well as sample quality flags that 
may be used to indicate problems with the sampling device, possibly affecting the quali-
ty of all measurements made on that sample (one flag for every sample). Entire station 
and sample quality flags are indicated with the words STATION or SAMPLE in the <co-
lumnLabel> part of the column label. 

Note that the QV syntax of quality flag labels is not recognized by ODV versions 3 or 
earlier. If ODV generic spreadsheets file needs to be compatible with these earlier soft-
ware versions, you must use QF as the label of quality flag columns. In such cases, it is 
assumed that the quality flag values are ODV generic flags and that they belong to the 
variable preceding the quality flag column.  

IMPORTANT NOTE: Column labels must not contain the column separation character of 
the spreadsheet file. 

 
Table 17-7: Example quality flag column labels 

Quality Flag Label Comment 

QV or QF ODV generic quality flags for the variable in the preceding col-
umn. 

QV:SEADATANET SeaDataNet quality flags for the variable in the preceding col-
umn.  

QV:ARGO:Nitrate [umol/kg] ARGO quality flags for Nitrate [umol/kg]. 

QV:ODV:Nitrate [umol/kg] 
or 
QV::Nitrate [umol/kg] 

ODV generic quality flags for Nitrate [umol/kg]. 

QV:WOCESAMPLE:SAMPLE WOCESAMPLE sampler quality flags. 

QV:WODSTATION:STATION WODSTATION entire station quality flags. 

QV::STATION ODV generic quality flags for entire station. 
 

17.3.3 Data Lines 

Every non-comment line following the column labels line is considered a data line. All 
data lines must have the same number of columns as the column labels line. Each data 
line contains metadata and data for one sample. All samples of a given station must be 
in consecutive order but need not be sorted. Missing values may be indicated by an 
empty field, the value -1.e10, or by a text indicator, such as na (not available) or NaN 
(not a number).  

Cruise and station labels are limited to the length of the Cruise and Station metava-
riables (default: 20 characters). The use of numbers for station labels will enable en-
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hanced internal sorting and selection functionality and is recommended. 

Station Type is a single character string. You should use B for stations with less than 
about 250 samples (e.g., bottle data) and C for stations with more than about 250 sam-
ples (e.g., CTD, XBT, etc.). Specifying * for Type lets ODV make the choice. If Bot. Depth 
values are not available, you should leave this field empty. 

The station metadata must be provided on the first line of a given station. The metadata 
fields on the remaining lines of the station may remain empty to reduce file size (com-
pact spreadsheet format). An ODV generic spreadsheet file usually stores the data of 
many stations from many cruises. The metadata and data of the first sample of the next 
station follow immediately after the last sample of the previous station. There are no 
separator lines between stations. 

17.4 Supported Date and Time Formats in ODV Spreadsheet Files 

ODV supports the single column ISO 8601 date/time format. This is the recommended 
date/time format for ODV import and export files. In addition, ODV also supports a wide 
range of other date and time formats to allow easy import of data provided in one of the 
many custom file formats, commonly used in the scientific community. This includes 
many date and time specifications that differ in the order of the day, month, year values, 
and cases with day, month, year, hour and minute data in individual columns.  

Use of the column labels in Table 17-8 is strongly recommended (lower, upper or mixed 
case) as this allows automatic date/time identification by ODV. The default date/time 
format in ODV spreadsheet output files is ISO 8601.  

 
Table 17-8: Supported date formats (column labels may be upper, lower or mixed case) 

Column label Comment 

yyyy-mm-dd hh:mm 
or 
yyyy-mm-ddThh:mm 

ISO 8601. Recommended ODV date/time format. Combines date 
and time in a single column. 

Examples: 2006-02-23 10:23 or 2006-02-23T10:23 for 
Feb/23/2006 10:23h. 

mon/day/yr 
or  
mm/dd/yyyy 

Date in one column. Time provided separately. 

Example: 02/23/2006 for Feb/23/2006. 

dd/mm/yyyy 
Date in one column. Time provided separately. 

Example: 23/02/2006 for Feb/23/2006. 

yyyy/mm/dd 
Date in one column. Time provided separately. 

Example: 2006/02/23 for Feb/23/2006. 
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mmddyyyy 
Date in one column. Time provided separately. 

Example: 02232006 for Feb/23/2006. 

ddmmyyyy 
Date in one column. Time provided separately. 

Example: 23022006 for Feb/23/2006. 

yyyymmdd 
Date in one column. Time provided separately. 

Example: 20060223 10:23 for Feb/23/2006 10:23h. 

year 
month 
day 

Date information in individual columns (any order). Time pro-
vided separately. 

Example: 2006 02 23 for Feb/23/2006. 
 

 

Table 17-9: Supported time formats (column labels may be upper, lower or mixed case) 

Column label Comment 

hh:mm Time in one column. Date provided separately. 

Example: 10:23 for 10:23h. 

hhmm Time in one column. Date provided separately. 

Example: 1023 for 10:23h. 

hour 

minute 

Time information in individual columns (any order). Date provided sepa-
rately. 

Example: 10  23 for 10:23h. 

 

17.5 Control Sequences and Functions in Annotations 

 

Table 17-10: Formatting control sequences in ODV annotations.  

Control Sequence Action 

~$ Switches to Symbol font (Greek symbols) 

~# Switches to normal text font 

~% Produces per mille character (‰) 

~^ Next character drawn as superscript 

~_ Next character drawn as subscript. 

Example: “~$S~#CO~_2 [~$m~#mol/kg]” will produce ΣCO2 [µmol/kg]. 
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Figure 17-1: Greek symbols and Latin eqivalents 

 

 
Table 17-11: Available auto-functions in ODV annotations. 

Function Substituted Text 

=date() Current date 

=time() Current time 

=user() User and host name 

=collection() Full path of current collection 

=view() Full path of current view file 

=section() Full path of current section file 

 

17.6 Gridding Methods 

ODV lets the user project irregularly spaced original data onto equi- or non-equidistant 
rectangular grids (for contouring and graphical display or output of gridded values) 
using one of three available methods: Quick Gridding, VG Gridding, and DIVA Gridding. 
The first two methods are built into ODV; DIVA Gridding is available once the respective 
optional package has been installed. 

Quick Gridding is a weighted averaging algorithm optimized for speed that calculates 
estimates at all grid nodes requiring only one loop over the available data. Quick Grid-
ding should only be used in cases when the other algorithms are too slow, e.g., in cases 
with millions of data points. VG Gridding uses a more sophisticated weighted averaging 
algorithm and yields good results in cases with good and homogeneous data coverage. 
VG Gridding is the default gridding method. DIVA Gridding is the most advanced grid-
ding method available in ODV. It is computationally more expensive than the other me-
thods, but should always be used when preparing final graphs for publications or web-
pages. 
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17.6.1 VG Gridding Algorithm 

In contrast to Quick Gridding, for which an equidistant, rectangular grid is used, ODV 
constructs and uses a variable resolution, rectangular grid if VG Gridding is requested. 
In this case, grid-spacing along the X and Y directions varies according to data density. 
High resolution (small grid-spacing) is provided in regions with high data density, whe-
reas in areas of sparse sampling a coarser grid with reduced resolution is used. For hy-
drographic sections, this typically yields high spatial resolution in the upper water col-
umn and in boundary current regions, where data coverage is good, and a coarser reso-
lution grid in open ocean regions and the deep sea, where data typically are sparser.  

After construction of the grid, property estimates ∑⋅∑=
i

ii
i

ie dc αα are calculated at every 

grid point (+) using a simple weighted-averaging scheme. For efficiency reasons, only 
data values di from a small neighborhood of the grid-point are considered for summa-
tion (see figure above). The weights αi decrease exponentially with increasing distance 
between data and grid-point: r

i e−=α , with 22 )/()/( yx LyLxr ∆+∆=  and separate averaging 
length-scales Lx and Lx in X and Y directions, respectively. Averaging length-scales vary 
over the domain, and are 

 
Figure 17-2: Weighted averaging of data values (red symbols) at a grid node (+). See text for details. 

 

proportional to local grid-spacing. Thus, small averaging length-scales are used in areas 
with small grid-spacing (high grid resolution, e.g., in the upper water column or in 
boundary current regions, etc.), whereas in regions with large grid-spacing, large aver-
aging length-scales are applied automatically.  This approach of spatially varying 
length-scales allows resolving small-scale features in areas of dense data coverage and 
at the same time provides smooth and stable fields in other regions with sparse data 
coverage. The user-provided length-scales Lx0 and Ly0 on the Display Options dialog are 
measured in per-mille of the respective axis range and are representative for the area of 
poorest data coverage (coarsest grid). The ODV implementation of the weighted averag-
ing algorithm is highly optimized for speed to allow field estimations within a few 
seconds, even for fields with thousands of data points. 

Once estimates have been obtained for all grid points, the field is passed to shading and 
contouring routines for display on the screen or a printer. 
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17.6.2 DIVA Gridding Integration 

DIVA is a gridding software developed at the University of Liege 
(http://modb.oce.ulg.ac.be/projects/1/diva) that offers a number of advantages over 
the weighted averaging methods built into ODV. DIVA allows analyzing and interpolat-
ing data in an optimal way, comparable to optimal interpolation OI. Unlike OI it also 
takes into account coastlines and bathymetry features to structure and subdivide the 
domain on which estimation is performed. Calculations are highly optimized and per-
formed on a finite element mesh adapted to the specific gridding domains.  

DIVA tools to generate the finite element mesh, optimize the parameters of the analysis 
and calculate the gridded field can be integrated into ODV by installing the optional 
package odvmpOP_DIVA<diva-version>_integration. Once this package is installed, a new 
option DIVA Gridding is available on the Display Options dialog of data windows with a 
Z-variable. You activate DIVA gridding by choosing this option and specifying appropri-
ate X and Y correlation length scales. ODV creates all necessary files for the operation of 
DIVA automatically (in directory odv_local/diva/work in your home directory), runs the 
DIVA mesh generation and field estimation steps, and reads the DIVA output for graphi-
cal display of the field by ODV. As for the other gridding algorithms, you can control the 
smoothness of the estimated field by adjusting the X- and Y- length scales. Note that the 
scale length values are in per mille of the respective axis range and that large values 
result in smooth fields. 

DIVA gridding generally produces better results than Quick Gridding or VG Gridding in 
cases of sparse and heterogeneous data coverage (see Figure above) and in cases where 
sub-regions with quite different property values are separated by land masses, ridges 
or other bathymetric barriers (see Figure below). Whereas the weighted averaging 
schemes used for Quick Gridding or VG Gridding wrongly transmit information across  

 

 
Figure 17-3: Comparison of VG and DIVA gridding methods for a field with inhomogeneous data coverage. 

 

http://modb.oce.ulg.ac.be/projects/1/diva�
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Figure 17-4: Comparison of VG and DIVA gridding methods for separated ocean basins. Note the influence of 

Pacific values in the Caribbean in the VG gridding case. 

 

the barriers, this does not happen with DIVA gridding. DIVA execution times are some-
what larger than for the other gridding methods; nevertheless, you should always con-
sider using DIVA gridding for publication-quality figures. 

System requirements and troubleshooting: For successful operation of the DIVA package 
you need a computer with at least 1GB of RAM. If you run DIVA and the plot window 
remains white, please close other applications and try again. 
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17.7 o4x Exchange Format 

The o4x exchange format is supported for backward compatibility; it is no longer rec-
ommended as data exchange format. New users should use the generic spreadsheet 
format instead. 

ODV .o4x exchange files contain information on the type of the data, the number and 
labels of variables, the actual data values and the data quality flags in a single ASCII file 
with extension .o4x. Typically, .o4x files contain three sections: (1) a (possibly missing) 
comment section consisting of an arbitrary number of free-format lines of at most 200 
characters each (this part may be missing), (2) a variables section that describes the 
type of the data and the number and labels of variables in the file, and (3) the data sec-
tion that contains the actual data values and data quality flags. Data quality flags may be 
missing; if they appear they must be single digit ODV quality flags. For a sample .o4x file 
see the samples directory of your ODV installation. 

The .o4x variables section begins with the keyword ODV4.0 Listing and should be format-
ted as shown in the sample below. Any records before the ODV4.0 Listing line are treated 
as comments and will be added to the collection .info file during import.  

 

Sample .o4x variables section 
(Note that the "....+." lines at the top and bottom only serve as rulers and are not part of 
the file.) 

....+....1....+....2....+....3....+....4....+....5....+....6....  
ODV4.0 Listing 
 File Name: import4.o4x 
      Type: HYD 
     Nstat: 12 
 Variables: 8 
 
Depth [m]                                                    6.0 
Temperature [°C]                                             8.2 
Salinity [psu]                                               8.3 
Oxygen [~$m~#mol/kg]                                         6.0 
Phosphate [~$m~#mol/kg]                                      8.2 
Silicate [~$m~#mol/kg]                                       8.1 
Nitrate [~$m~#mol/kg]                                        7.1 
Nitrite [~$m~#mol/kg]                                        6.1 
....+....1....+....2....+....3....+....4....+....5....+....6....  
 

One empty line separates the variables section of the data file from the header line of 
the first station (see file import4.o4x in the ODV samples directory for an example). Sta-
tion header lines must start with a # in column 1. The following items are: (1) cruise-
label of the station (cols. [3:22], format a20); (2) station-label ([24:43], a20); (3) station-
type (either B, C or X for bottle, CTD or XBT data; [45:45], a1); (4) date mm/dd/yyyy 
([47:66], i2,1x,i2,1x,i4); (5) east longitude (decimal; [58:64], f7.3); (6) north latitude 
(decimal; [66:72], f7.3); (7) bottom depth ([m]; [74:78], i5); (8) depth of deepest obser-
vation ([m]; [80:84], i5); (9) number of depths sampled ([85:89], i5); (10) number of va-
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riables for which data are provided in the file ([91:93], i3). In the example file, the sta-
tion 06MT18/558 is of type "Bottle", it contains 14 observed depths and data for 8 va-
riables at these observed depths are to follow. These variables have to be identified by 
specifying their numbers (as defined in the variables section at the beginning of the file) 
on the second header line (e.g., 1 represents Depth and, for instance, 6 represents Sili-
cate). Note that as the only format restriction, the variable numbers on the second 
header line have to be separated by at least one blank. 

For each observed depth (14 in the example file) one line of data has to follow. Each of 
these lines must contain a data and quality flag value for every variable specified on the 
second header line in that order. Missing values have to be set to -1.000E+10 in the data 
file. Note that data and quality flag values have to be separated by at least one space. 
Quality flags are single digit integers with the following meaning: 0=Good, 1=Unknown, 
4=Questionable, 8=Bad. Immediately after the last data line of a given station follows the 
first header line (starting with the #) of the next station to be imported or the end-of-
file if the station is the last to be read. 

Once the.o4x file has been created, start ODV and open or create the collection that is to 
receive the new data. Then choose ODV4.x Listing from the Import menu. Select the 
ASCII data file created above as data import file. Specify import options and press OK to 
start the data import. ODV will then read the import file and add/merge the stations to 
the collection. Note that you can also drag-and-drop .o4x files onto ODV. 

17.8 o3x Exchange Format 

The o3x exchange format is supported for backward compatibility; it is no longer rec-
ommended as data exchange format. New users should use the generic spreadsheet 
format instead. 

Sample .var File 

....+....1....+....2....+....3....+....4....+....5....+....6.... 
ODV4.0 
Collection: SAVE 
      Type: HYD 
     Nstat: 0 
 Variables: 7 
 
Depth [m]                                                    6.0 
Temperature [°C]                                             8.2 
Salinity [psu]                                               8.3 
Oxygen [~$m~#mol/kg]                                         6.0 
Phosphate [~$m~#mol/kg]                                      8.2 
Silicate [~$m~#mol/kg]                                       8.1 
Nitrate [~$m~#mol/kg]                                        7.1 
....+....1....+....2....+....3....+....4....+....5....+....6.... 
 

To import data using the .o3x exchange format you have to provide two ASCII files, one 
containing the actual data for all the stations that you want to import (default extension 
is .o3x) and one (small) file that describes the variables included in the data file (exten-
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sion must be .var). For a sample .o3x file see the samples directory of your ODV installa-
tion. 

Note that the “....+.” lines at the top and bottom only serve as rulers and are not part of 
the .var file. Also note that the .var file has the same format as ODV4.x collection defini-
tion files but that the information needed for the data import is confined to entries con-
cerning the variables. In line 5 of the file starting in column 13 you have to specify the 
number of variables included in the data file to be imported. Then, after one blank line 
you have to provide variable label and numeric format for all the variables on separate 
lines. The numeric format has the appearance ll.d (ll is the total length in characters and 
d is the number of decimal figures) and starts in column 61. 

 

Sample .o3x header lines 

....+....1....+....2....+....3....+....4....+....5....+....6....+....7... 
# REID_ET           212 B  6/21/1967 243.167 -28.233  3400  3310   34   7 
    1    2    3    4    5    6    7 
 

The data for all the stations to be imported have to be provided in a single ASCII file 
(default extension .o3x). This file has to meet the following format specification (note 
that the ruler at the top is not part of the file): 

The file must begin with the header line of the first station to be imported. Station 
header lines must start with a # in column 1. The following items are: (1) cruise-label of 
the station (cols. [3:12], format a10); (2) station-label ([14:23], a10); (3) station-type 
(either B, C or X for bottle, CTD or XBT data; [25:25], a1); (4) date mm/dd/yyyy 
([27:36], i2,1x,i2,1x,i4); (5) east longitude (decimal; [38:44], f7.3); (6) north latitude 
(decimal; [46:52], f7.3); (7) bottom depth ([m]; [54:58], i5); (8) depth of deepest obser-
vation ([m]; [60:64], i5); (9) number of depths sampled ([66:69], i4); (10) number of 
variables for which data are provided in the file ([71:73], i3). In the example above, the 
station REID_ET/212 is of type “Bottle”, it contains 34 observed depths and data for 7 
variables at these observed depths are to follow. These variables have to be identified 
by specifying their numbers as defined in the .var file on the second header line (e.g., 1 
represents Depth and, for instance, 6 represents Silicate). Note that as the only format 
restriction, the variable numbers on the second header line have to be separated by at 
least one blank. 

For each observed depth (34 in the example above) one line of data has to follow. Each 
of these lines must contain a numerical value for every variable specified on the second 
header line in that order. Missing values have to be set to -1.000E+10 in the data file. 
Immediately after the last data line of a given station follows the first header line (start-
ing with the #) of the next station to be imported or the end-of-file if the station is the 
last to be read. 

Once the .var and .o3x files have been created, run ODV and open or create the collec-
tion that is to receive the new data. Then choose ODV3.0 Listing from the Import menu. 
Select the ASCII data file created above as data import file and identify the variables to 
be imported by selecting the import .var file as the data source. Specify import options 
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and press OK to start the data import. ODV will then read the import file and add/merge 
the stations to the collection. Note that the data quality flags are set to Unknown if you 
import data using ODV3.0 exchange format. 

17.9 ODV Directory Structure 

The default installation directory for ODV is c:\Program Files\Ocean Data View (mp) on 
Windows, /Applications/ODV on Mac OS X and /usr/local/odvmp for Linux and UNIX 
(indicated as <install> below; for Mac OS X, Linux and UNIX replace \ by / in the follow-
ing). The installation directory contains various subdirectories for specific purposes. 
Installation files that may be modified by the user, such as macro files, palette files or 
sample data collections, are installed in subdirectory ODV under the user’s document 
directory (indicated as <user> below). 

Following below is a list of directories used by ODV: 
<install>\bin_w32   on Windows platforms, ...or... 
<install>\bin_macx   on Mac OS X platforms, ...or... 
<install>\bin_linux-i386  on Linux i386 platforms, ...or... 
<install>\bin_solaris-sparc  on SUN Solaris Sparc platforms, ...or... 
<install>\bin_irix6.5_mips  on SGI Irix platforms, ...or... 
<install>\bin_aix-powerpc  on IBM AIX powerpc platforms: 

ODV executable, tools, and PostScript preamble file. 

<install>\coast\GlobHR: 
High-resolution coastline and topography files for the whole globe. 

<install>\doc4: 
ODV html help files (pdf version available from ODV web page). 

<install>\include: 
Default directory for ODV include files (e.g., ETOPO2 global topography avail-
able as optional package). Note that there are several sub-directories contain-
ing other files of a given type. 

<install>\include\atmhist: 
Concentration histories of various atmospheric trace gases. 

<install>\samples: 
Directory for ODV sample files. Use these files as templates for data import or 
macro files. 

<user>\cmd_files: 
ODV command files (.cmd). 

<user>\data: 
Base directory for ODV data collections. While ODV data collections may, in 
principle, reside anywhere on a read-write (hard-disk, memory stick, etc.) or 
read-only (DVD, CD-ROM, etc.) storage medium, it is recommended to main-
tain all your collections under this directory. Every collection should be 
stored in its own sub-directory. 

<user>\diva: 
DIVA working directory (only present if DIVA is installed). 
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<user>\export: 
Base directory for datasets exported via Export>X, Y, Z Window Data. 

<user>\gazetteers: 
ODV gazetteer database files. 

<user>\macros: 
ODV macro files (.mac). 

<user>\palettes: 
ODV palette files (.pal). 

<user>\reference: 
Base directory for reference datasets exported via Export>X, Y, Z Window Da-
ta as Reference. 
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